Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Plicy routing problem when next hop fails!

Dear all,

we have a branch that is connected via a leased line to the main headquarters.

The connection is terminated to a cisco 1721 fast ethernet subinterface (802.1q VLAN).

We also have an ADSL line which is terminated to a PC running WIN2K and "microsoft internet connection software" (ICS, something like NAT ). Basically that PC has an ethernet interface which is also terminated to the above router. So we have two VLANs.

The aim is to reroute all P2P, WWW, FTP etc traffic through the PC and the ADSL line and we tried to solve it with policy routing. The problem is that when the PC ***and*** the ADSL line are OK, then the policy routing is also OK.

*But* when the ADSL line drops, the router continues to send packets to the Ethernet interface of the PC. The same happens when the PC is down (e.g ethernet interface down) also.

I post the configuration below!

Current configuration : 989 bytes

!

version 12.2

!

!

interface FastEthernet0

no ip address

speed auto

!

interface FastEthernet0.1

description <<in this vlan the leased line is terminated>>

encapsulation dot1Q 100

ip address 193.92.81.1 255.255.255.0

ip policy route-map redirect_www_to_adsl_PC

!

interface FastEthernet0.2

description connection_to_PC_running_WIN2kPRO_and_ADSL

encapsulation dot1Q 1 native

ip address 192.168.0.2 255.255.255.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 193.92.81.2

no ip http server

!

access-list 100 permit tcp any any eq www

access-list 100 deny ip any any

route-map redirect_www_to_adsl_PC permit 1

match ip address 100

set ip next-hop 192.168.0.10

!

TIA for your help guys,

ilias

1 REPLY
Bronze

Re: Plicy routing problem when next hop fails!

Hi Ilias,

Before that, you did not mention any application in the scenario. Is it used for voice? In case if it is so, policy-based routing does not work for voice if you are sourcing the traffic localy. This feature is not avialble until 12.2(12)T, I guess.

Voice based policy based routing does work if the source & destination traffic is not originated on the router which is doing the policy based routing. However it fails if the traffic is sourced locally.

84
Views
0
Helpful
1
Replies
CreatePlease login to create content