Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

PLS HELP! Accessing different NAT pools based on destination

I need to set up my router so that any IP address is NATed depending upon where it is going. It looks as If I will need to use route maps. So far this is what I have come up with:

!

interface Serial1/1:1

description T1 to --------------------

ip address 10.x.x.2 255.255.255.0

ip nat outside

encapsulation ppp

!

!

interface ATM3/0.1 point-to-point

description Line to ----------------

ip address 172.x.x.114 255.255.255.252

ip nat outside

pvc JNET 7/33

vbr-nrt 10000 5000 256

oam-pvc manage

encapsulation aal5snap

!

!

interface ATM3/0.33 point-to-point

description pvc to-----------------------

ip address 10.x.x.85 255.255.255.252

ip nat inside

pvc Mt-Holly 3/33

vbr-nrt 570 285 32

oam-pvc 0

encapsulation aal5snap

!

ip nat pool natpool-0 10.x.x.1 10.x.x.254 netmask 255.255.255.0

ip nat pool natpool-1 172.x.x.1 172.x.x.254 netmask 255.255.255.0

ip nat inside source route-map MAP-M pool natpool-0

ip nat inside source route-map MAP-J pool natpool-1

access-list 10 permit 0.0.0.0 255.255.255.255 10.40.100.0 0.0.0.255

access-list 172 permit 0.0.0.0 255.255.255.255 172.X.X.0 0.0.0.255

route-map MAP-M permit 10

match ip address 10

route-map MAP-J permit 10

match ip address 172

Is this config correct? I need IP's comming int a3/0.33 to be NATed differently depending upon if they are going out s1/1:1 or a3/0.1.

1 REPLY
Bronze

Re: PLS HELP! Accessing different NAT pools based on destination

That should work. There is an example of route maps on the web at the following URL -

http://www.cisco.com/warp/customer/105/nat_routemap.html

81
Views
0
Helpful
1
Replies
CreatePlease to create content