Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Point to Point ISDN Connection Issues

I have two Routers, a 804, and 802, and two std ISDN lines. (leased line is not available) I am trying to set-up a dial link between the two that will be able to use both channels and get the full 128k. but every time we set up PPP multilink it will only dial one channel, then when it meets the threshold it will drop the first call and dial the second using the second phone number. Is PPP not the way to go, and what about having to dial 2 phone numbers to get both channels.

Help what am I doing wrong.

any recommended configs could be greatly appreciated.

9 REPLIES
Silver

Re: Point to Point ISDN Connection Issues

Will need to see the following on both the routers, starting off without any B channel connected & then trying to connect on both the B channels:

PPP is the best way to go....

deb isdn q931/ deb dialer/ deb ppp nego / deb ppp multi

sh run / sh ver

Thanks, Mak.

New Member

Re: Point to Point ISDN Connection Issues

To start with here are the configs. I will work on getting the debugs during off hours for the system.

Names and numbers changed for protection.

=========================================

Router 1

----------------------------------------------------------------------------------

ERIK#sho runn

Building configuration...

Current configuration:

!

version 12.0

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname ERIK

!

logging buffered 4096 debugging

enable secret 5 *

!

username ssi password 7 *

!

dial-peer voice 1 pots

no call-waiting

ring 0

port 1

destination-pattern 5554056

!

dial-peer voice 2 pots

no call-waiting

ring 0

port 2

destination-pattern 5554369

!

pots country US

ip subnet-zero

ip dhcp excluded-address 10.0.20.135 10.0.20.200

!

ip dhcp pool 1

network 10.0.20.128 255.255.255.128

domain-name fake.com

default-router 10.0.20.129

dns-server 192.168.1.5

!

no ip domain-lookup

isdn switch-type basic-ni

!

interface Ethernet0

ip address 10.0.20.129 255.255.255.128

no ip directed-broadcast

!

interface BRI0

description coed to ssi

ip address 10.0.0.246 255.255.255.252

no ip directed-broadcast

encapsulation ppp

dialer idle-timeout 2147483

dialer map ip 10.0.0.245 name ssi broadcast 6515559055

dialer hold-queue 10

dialer load-threshold 2 outbound

dialer-group 1

isdn switch-type basic-ni

isdn spid1 10255540560101 5554056

isdn spid2 10255543690101 5554369

no cdp enable

ppp authentication chap

hold-queue 75 in

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.0.0.245

!

map-class dialer ssi

dialer-list 1 protocol ip permit

=========================================

Router 2

----------------------------------------------------------------------------------

ssi#sho runn

Building configuration...

Current configuration:

!

version 12.0

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname ssi

!

logging buffered 4096 debugging

enable secret 5 *

!

username ERIK password 7 *

!

!

!

!

ip subnet-zero

!

no ip domain-lookup

isdn switch-type basic-ni

!

!

process-max-time 200

!

interface Ethernet0

description connected to EthernetLAN

ip address 10.0.20.2 255.255.255.252

no ip directed-broadcast

!

interface BRI0

description connected to ERIK

ip address 10.0.0.245 255.255.255.252

no ip directed-broadcast

encapsulation ppp

dialer idle-timeout 2147483

dialer map ip 10.0.0.246 name ERIK broadcast

dialer-group 1

isdn switch-type basic-ni

isdn spid1 10255590551111

isdn spid2 10255590571111

ppp authentication chap

ppp multilink

!

no ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 10.0.20.1

ip route 10.0.20.128 255.255.255.128 10.0.0.246

!

dialer-list 1 protocol ip permit

Silver

Re: Point to Point ISDN Connection Issues

You did remember to set "ppp multilink" on both routers before testing? Only router 2 above is currently configured. Another trick is to try adding "no ip route cache" to the BRI0 interface. Some IOS release / router platform combinations have strange behavior when fast switching DDR interfaces. Turning off fast switching is a quick way to eliminate IOS anomolies as a factor.

Good luck and good hunting!

Vincent C Jones

www.networkingunlimited.com

Silver

Re: Point to Point ISDN Connection Issues

I assume you had the "ppp multilink" under the BRI of Router1....If yes, then you could be probably running into CSCdx54104 "Cant keep both B-chann on BRI up at same time, alternately go DOWN"

Resolved in 12.2 (latest) /12.2(11)T1.

Thanks, Mak.

New Member

Re: Point to Point ISDN Connection Issues

Sorry, yes I did have the ppp multilink on the first config, but removed it when I couldn't keep the link up. And forgot to put them in for the purposes of the

Also I thought that CSCdx54104 was only in relation to a 3640. These are 800 series units. Please correct me if I am wrong.

Thanks for all your help.

Jerel

Silver

Re: Point to Point ISDN Connection Issues

Bugs could be platform specific or IOS image specific ( means, all platforms for that image will be affected).....Actually I filed that bug & since I encountered it on the 3640 platform have the mention of it....probably it could be affecting other platforms too.

Thanks, Mak.

New Member

Re: Point to Point ISDN Connection Issues

I upgraded both routers, and am still not getting the PPP multilink to come up, But I did find something that does not look right. When I do a sho int, I get

ssi#sho int

BRI0 is up, line protocol is up (spoofing)

Hardware is BRI with U interface

Description: connected to ERIK

Internet address is 10.0.0.245/29

MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation PPP, loopback not set

Last input 00:00:22, output 00:00:22, output hang never

Last clearing of "show interface" counters 8w4d

Input queue: 0/75/0 (size/max/drops); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/1/16 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

404924 packets input, 1997195 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

26 input errors, 0 CRC, 24 frame, 0 overrun, 0 ignored, 2 abort

400535 packets output, 1742765 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

1 carrier transitions

BRI0:1 is up, line protocol is up

Hardware is BRI with U interface

MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation PPP, loopback not set

Keepalive set (10 sec)

LCP Open, multilink Open

Last input 00:00:01, output 00:00:01, output hang never

Last clearing of "show interface" counters never

Queueing strategy: fifo

Output queue 0/40, 3454 drops; input queue 0/75, 0 drops

5 minute input rate 0 bits/sec, 1 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

6291517 packets input, 334821099 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

494 input errors, 282 CRC, 84 frame, 0 overrun, 0 ignored, 128 abort

5039095 packets output, 774421664 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

2812 carrier transitions

BRI0:2 is down, line protocol is down

Hardware is BRI with U interface

MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation PPP, loopback not set

Keepalive set (10 sec)

LCP Closed, multilink Closed

Closed: CDPCP, IPCP

Last input never, output never, output hang never

Last clearing of "show interface" counters never

Queueing strategy: fifo

Output queue 0/40, 0 drops; input queue 0/75, 0 drops

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

0 packets output, 0 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

5984 carrier transitions

On both routers, The thing that is puzzling me is that bri0:2 is down, when I disconnect the call on bri0:1 it comes up. Why would this be?

New Member

Re: Point to Point ISDN Connection Issues

I don't know this is important but you only have dialer load-threshold on one

router. Working with the TAC on a similar issue I was told it had to be configure on both router.

New Member

Re: Point to Point ISDN Connection Issues

Yep, Tried this one too. Still didn't help.

Has Anyone done this before, and do you have a sample set of configs. I want to rule out anthing wrong that I may be doing in the config, before going full force into finding issues with IOS software, or lines.

121
Views
0
Helpful
9
Replies