Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Policing

Folks,

I?ve been messing around with policy-maps with an eye to using policing in a production scenario. Switch is Catalyst 4507R, IOS 12.2(20)EWA.

Currently the test policy-map is applied to my PC switchport as follows:

!My PC IP address

ip access-list extended MT

permit ip host 9.9.9.9 any

class-map match-any MT_THROTTLE_TEST

match access-group name MT

!Policing level set artificially low for testing purposes

policy-map MT_THROTTLE_POLICY

class MT_THROTTLE_TEST

police 100 kbps 1000 byte conform-action transmit exceed-action drop

interface FastEthernet3/45

switchport access vlan 230

switchport mode access

service-policy input MT_THROTTLE_POLICY

speed 100

duplex full

no snmp trap link-status

spanning-tree portfast

Problem is as follows ? No packets are picked up as either conforming or exceeding, even when I run a stress testing tool and saturate the port. Policy-map counters shown below.

CARSWC230#sh policy-map interface f3/45

FastEthernet3/45

Service-policy input: MT_THROTTLE_POLICY

Class-map: MT_THROTTLE_TEST (match-any)

0 packets

Match: access-group name MT

0 packets

police: Per-interface

Conform: 0 bytes Exceed: 0 bytes

Class-map: class-default (match-any)

0 packets

Match: any

Is there something in the IOS or switch configuration stopping this config from working? It?s like the service-policy command is not applying to the fastethernet interface properly.

Any advice appreciated.

3 REPLIES

Re: Policing

Hi,

Bit obvious - but is qos enabled? Also, if you're just testing try match any instead of matching on an access-group.

HTH

Andrew.

New Member

Re: Policing

Andrew,

Boy is my face red. First time I've tried qos settings on this access switch and yes, qos was disabled. Back to the drawing board.

Thanks for your help,

Martin.

Re: Policing

Hi Martin,

Glad to help - please rate any posts you find useful (not just mine!)

cheers,

Andrew.

117
Views
4
Helpful
3
Replies