Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Policy Based Routing is not working with slb configured

I have a 7609 with a slb firewallfarm configured. It is running IOS 12.2(18)SXE3 with sup720. The firewallfarm is configured with default settings with no access parameter, only real servers configured.

All the traffic is coming from a single vlan (it's not possible to implement another layer 2 way to make the traffic pass through) and I would like to make a single flow to exit from another interface and not pass to the real servers configured on FWfarm. I wrote the following PBR statements:

!!!!!!! Begin !!!!!!!

access-list 110 permit ip host XX.XX.XX.XX any

!where XX.XX.XX.XX is an omitted IP address

route-map NEW-ROUTEMAP permit 10

match ip address 110

set ip next-hop 192.168.253.3

interface Vlan55

!vlan 55 is the interface from where the selected flows comes

ip route-cache policy

ip policy route-map NEW-ROUTEMAP

!!!!! END !!!!!!!

The route-map seems working, in fact I can see matched ACL and route-map.

The problem is the SLB seems to take all the traffic in charge, also the one I would like to route to another interface, in fact if I put my desidered output interface in monitor I can see no traffic passing through.

SLB creates the sticky entry anyway, in fact as far as I know, the SLB has the priority to static routing and route-maps.

Any idea for a workaround? Is there a way to make PBR works with SLB?

Thanks in advance.

Ric

1 REPLY
Bronze

Re: Policy Based Routing is not working with slb configured

It's possible to make pbr work with slb for further details refere to the link ,

http://www.cisco.com/en/US/customer/products/sw/iosswrel/ps1835/products_configuration_guide_chapter09186a00800ca75d.html

247
Views
0
Helpful
1
Replies