cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
474
Views
0
Helpful
4
Replies

Policy based Routing problem.

panjwani
Level 1
Level 1

Hello everyone,

I am facing problem while routing the HTTP and FTP based LAN Traffic to high speed internet line connected to the Router interface. and the default interface is another low speed internet line. What is happening is , FTP Traffic despite being matched by access-lists is going to low speed line. Notice that I have kept default interface is low speed internet line.

If somebody can assist me in providing me the right configuration, I would be grateful. Thanks,

Sadiq.

4 Replies 4

millerv
Level 1
Level 1

can you post a config ?

Dear,Below are the configs that you requested ,

==========================================

version 12.0

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname ??????

!

enable secret 5 ??????

enable password 7??????

!

ip subnet-zero

ip name-server 194.170.1.6

ip name-server 194.170.1.7

!

isdn switch-type basic-net3

!

!

!

interface Ethernet0/0

ip address 195.229.40.193 255.255.255.240

no ip directed-broadcast

ip route-cache policy

ip policy route-map HTTPPOLICY

!

interface Ethernet0/1

ip address 192.168.154.10 255.255.255.0

no ip directed-broadcast

!

interface BRI1/0

no ip address

no ip directed-broadcast

shut

isdn switch-type basic-net3

!

interface BRI1/1

description connection to Internet on dialup ISDN 64K

no ip address

no ip directed-broadcast

encapsulation ppp

dialer rotary-group 1

isdn switch-type basic-net3

no cdp enable

no shut

!

interface BRI1/2

no ip address

no ip directed-broadcast

shutdown

isdn switch-type basic-net3

!

interface BRI1/3

no ip address

no ip directed-broadcast

shutdown

isdn switch-type basic-net3

!

interface BRI1/4

no ip address

no ip directed-broadcast

shutdown

isdn switch-type basic-net3

!

interface BRI1/5

no ip address

no ip directed-broadcast

shutdown

isdn switch-type basic-net3

!

interface BRI1/6

no ip address

no ip directed-broadcast

shutdown

isdn switch-type basic-net3

!

interface BRI1/7

no ip address

no ip directed-broadcast

shutdown

isdn switch-type basic-net3

!

interface Dialer1

description connection to internet on dial up isdn

ip unnumbered Ethernet0/0

no ip directed-broadcast

encapsulation ppp

no ip split-horizon

dialer in-band

dialer idle-timeout 205741

dialer string 4004444

dialer hold-queue 25

dialer-group 1

no cdp enable

ppp authentication chap pap callin

ppp chap hostname ?????

ppp chap password ?????

ppp pap sent-username ???? password ?????

!

ip route 0.0.0.0 0.0.0.0 dialer1

ip classless

no ip http server

!

access-list 101 permit tcp any any eq www

access-list 101 permit tcp any any eq domain

access-list 101 permit tcp any any eq 443

access-list 101 permit tcp any any eq 4000

access-list 101 permit tcp any any eq 5190

access-list 101 permit tcp any any eq 1433

access-list 101 permit tcp any any eq 569

access-list 101 permit tcp any any eq 1863

access-list 101 permit tcp any any eq nntp

access-list 101 permit tcp any any eq 563

access-list 101 permit tcp any any eq pop3

access-list 101 permit tcp any any eq 995

access-list 101 permit tcp any any eq 1080

access-list 101 permit tcp any any eq 1434

access-list 101 permit udp any any eq 1434

access-list 101 permit tcp any any eq ftp

access-list 101 permit tcp any any eq ftp-data

access-list 101 permit udp any any

!

dialer-list 1 protocol ip permit

route-map HTTPPOLICY permit 10

match ip address 101

set ip next-hop 192.168.154.1

!

line con 0

exec-timeout 0 0

password 7 121A0A1901040001

login

transport input none

line aux 0

line vty 0 4

password 7 09584B05170003

login

!

no scheduler allocate

end

==============================================

I hope you understood the configs.

Eth0/0 = Lan network

Eth0/1 = Fast internet line say ADSL

BRI1/1 = ISDN 64K line

Please assist. thanks.

vinodgupt
Level 1
Level 1

sadiq,

Go thru the route maps , that help you to configure this or otherwise post the config.

vinod

Dear Vinod, Thanks for your reply, here is the config that you requested. Thanks.

===================================================

version 12.0

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname ??????

!

enable secret 5 ??????

enable password 7??????

!

ip subnet-zero

ip name-server 194.170.1.6

ip name-server 194.170.1.7

!

isdn switch-type basic-net3

!

!

!

interface Ethernet0/0

ip address 195.229.40.193 255.255.255.240

no ip directed-broadcast

ip route-cache policy

ip policy route-map HTTPPOLICY

!

interface Ethernet0/1

ip address 192.168.154.10 255.255.255.0

no ip directed-broadcast

!

interface BRI1/0

no ip address

no ip directed-broadcast

shut

isdn switch-type basic-net3

!

interface BRI1/1

description connection to Internet on dialup ISDN 64K

no ip address

no ip directed-broadcast

encapsulation ppp

dialer rotary-group 1

isdn switch-type basic-net3

no cdp enable

no shut

!

interface BRI1/2

no ip address

no ip directed-broadcast

shutdown

isdn switch-type basic-net3

!

interface BRI1/3

no ip address

no ip directed-broadcast

shutdown

isdn switch-type basic-net3

!

interface BRI1/4

no ip address

no ip directed-broadcast

shutdown

isdn switch-type basic-net3

!

interface BRI1/5

no ip address

no ip directed-broadcast

shutdown

isdn switch-type basic-net3

!

interface BRI1/6

no ip address

no ip directed-broadcast

shutdown

isdn switch-type basic-net3

!

interface BRI1/7

no ip address

no ip directed-broadcast

shutdown

isdn switch-type basic-net3

!

interface Dialer1

description connection to internet on dial up isdn

ip unnumbered Ethernet0/0

no ip directed-broadcast

encapsulation ppp

no ip split-horizon

dialer in-band

dialer idle-timeout 205741

dialer string 4004444

dialer hold-queue 25

dialer-group 1

no cdp enable

ppp authentication chap pap callin

ppp chap hostname ?????

ppp chap password ?????

ppp pap sent-username ???? password ?????

!

ip route 0.0.0.0 0.0.0.0 dialer1

ip classless

no ip http server

!

access-list 101 permit tcp any any eq www

access-list 101 permit tcp any any eq domain

access-list 101 permit tcp any any eq 443

access-list 101 permit tcp any any eq 4000

access-list 101 permit tcp any any eq 5190

access-list 101 permit tcp any any eq 1433

access-list 101 permit tcp any any eq 569

access-list 101 permit tcp any any eq 1863

access-list 101 permit tcp any any eq nntp

access-list 101 permit tcp any any eq 563

access-list 101 permit tcp any any eq pop3

access-list 101 permit tcp any any eq 995

access-list 101 permit tcp any any eq 1080

access-list 101 permit tcp any any eq 1434

access-list 101 permit udp any any eq 1434

access-list 101 permit tcp any any eq ftp

access-list 101 permit tcp any any eq ftp-data

access-list 101 permit udp any any

!

dialer-list 1 protocol ip permit

route-map HTTPPOLICY permit 10

match ip address 101

set ip next-hop 192.168.154.1

!

line con 0

exec-timeout 0 0

password 7 121A0A1901040001

login

transport input none

line aux 0

line vty 0 4

password 7 09584B05170003

login

!

no scheduler allocate

end

==============================================

I hope you understood the configs.

Eth0/0 = Lan network

Eth0/1 = Fast internet line say ADSL

BRI1/1 = ISDN 64K line

Please assist. thanks.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: