Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Policy-map on catalyst 3550

dear all,

how to configure policy-map on catalyst 3550 to shapping bandwidth. I've tried to setting that police-map in one of interface, but when I wrote sh policy-map interface fa0/1, in class-map field, the result are

class-map: policeIn (match-all)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

match: access-group 112qm_police_inform_feature: CLASS_SHOW

Could u give me a clue..??

thx.

..::rhiez::..

  • Other Network Infrastructure Subjects
12 REPLIES

Re: Policy-map on catalyst 3550

Hi Rhiez,

Can you paste the config for your policy and the class which you have defined.

Also I hope your fa0/1 is not a routed port?

Have a look at this link for QOS config on 3550 switch.

http://www.cisco.com/univercd/cc/td/doc/product/lan/c3550/12120ea2/3550scg/swqos.htm

Regards,

Ankur

New Member

Re: Policy-map on catalyst 3550

Hi ankur,

Here i paste my config :

==============================================================

class-map match-all websiteOut

match access-group 111

class-map match-all websiteIn

match access-group 112

!

!

policy-map internetIn

class websiteIn

police 512000 65536 exceed-action drop

policy-map internetOut

class websiteOut

police 512000 65536 exceed-action drop

!

!

interface FastEthernet0/1

bandwidth 512

switchport access vlan 10

no ip address

service-policy input internetIn

!

!

access-list 111 permit tcp any any

access-list 112 permit tcp any any

==============================================================

Port fa0/1 connected to my proxy server via unmanage switch.

one question again :

Is there possible to setting service-policy input and output on same interface..??

thx

..::rhiez::..

Re: Policy-map on catalyst 3550

Hi Rhiez,

You can apply a policy map to the input or output of a particular interface.

Only one policy map per interface per direction is supported.

HTH,

Ankur

Silver

Re: Policy-map on catalyst 3550

Hi,

In your show policymap output it seems to be refering someother policy map (policein). If possible could u attach full config with the sample output of show policymap and show classmap.

Using service-policy command it is possible to assign single policymap to multiple interfaces or multiple policymaps to single interface with the maximam of one in each direction.

Purple

Re: Policy-map on catalyst 3550

Hi,

The 'show policy-map interface' command is not supported on the 3550. While it will work if you type it in, the statistics will not reflect any useful statistics.

To monitor your traffic, you should specify the DSCPs to be monitored by using the 'mls qos monitor dscp dscp1 ... dscp8' interface configuration command, and then you should use the 'show mls qos interface statistics' command to view the stats.

Hope that helps - pls rate the post if it does.

Paresh

New Member

Re: Policy-map on catalyst 3550

hi balajitvk,

here I paste my output show policy-map

============================================

switch# sh policy-map interface fa0/1

FastEthernet0/1

service-policy input: internetIn

class-map: website (match-all)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

match: access-group 11qm_police_inform_feature: CLASS_SHOW

class-map: class-default (match-any)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

match: any

0 packets, 0 bytes

5 minute rate 0 bps

=============================================================

could you give me a clue..

thx

..::rhiez::..

Silver

Re: Policy-map on catalyst 3550

Hi,

from the above output i don't think there is any traffic coming to that particular port. becz there no hits or drops in website in classmap.

Unclassified traffic (traffic that does not meet the match criteria specified in the traffic classes) is treated as belonging to the default traffic class.

But in our case, there is no traffic in default class also. Pls. chk the trffic by using interface status in both side of the link.

Rgs,

New Member

Re: Policy-map on catalyst 3550

hi,

i've checked statistic of interface and there is traffic on that interface :

Hardware is Fast Ethernet, address is xxxx.xxxx.xxxx.xxxx(bia xxxx.xxxx.xxxx)

MTU 1500 bytes, BW 512 Kbit, DLY 100 usec,

reliability 255/255, txload 102/255, rxload 42/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Half-duplex, 100Mb/s

input flow-control is off, output flow-control is off

ARP type: ARPA, ARP Timeout 04:00:00

Last clearing of "show interface" counters 00:03:16

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue :0/40 (size/max)

5 minute input rate 85000 bits/sec, 67 packets/sec

5 minute output rate 961000 bits/sec, 201 packets/sec

12965 packets input, 2137646 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 0 multicast, 0 pause input

0 input packets with dribble condition detected

38564 packets output, 23504798 bytes, 0 underruns

0 output errors, 46 collisions, 0 interface resets

0 babbles, 0 late collision, 62 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out

is there another way to shapping bandwidth per vlan or per port interface on catalyst 3550 with IOS 12.1(8).

thx.

..::rhiez::..

Re: Policy-map on catalyst 3550

pkhatri is correct here. Although the show command will disply the policy-map it does not display any statistics. The only way to show whether the classifier/policer is working is by enabling the monitoring of DSCP values:

interface FastEthernet0/1

mls qos monitor dscp 0 8 24 26 32 46 48 56

mls qos monitor packets [bytes]

!

If you then type 'show mls qos interface statistics' you can see the ingress and egress DSCP values for the ones that were listed above, the ingress also shows a before and after the packets are classified, there is also a column showing packets dropped.

HTH

Andy

464
Views
0
Helpful
12
Replies
This widget could not be displayed.