Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Policy routing based on domain names (NBAR)

Hi,

Our company has two ISPs. One provides FR, the other provides ADSL.

My intention is to route all business critical communications to the FR and route all other to the ADSL.

Business critical request can be classified with NBAR (for example http request going to cisco.com.)

I classify the packets coming from our LAN with a policy-map. (All selected URLs are set to ip precedence 5 - all other left with 0)

I also have a policy routing route-map on the LAN interface directing

- IP prec. 5, DNS and SMTP packets to the FR (if that's unavailable, the reroutes them to the ADSL)

- Other packets to the ADSL (if that's unavailable, the reroutes them to the FR)

The problem is the following:

When one of the interfaces is up, then we have everything running. At the time I bring up both WAN links the traffic marked with IP prec 5 has problems. We cannot access the marked domains, we don't have smtp...

Anyone configured something similar?

Someone notices an error in my config?

Attila

Here's the relevant part of my config:

ip cef

class-map match-any work

match protocol http host "*.cisco.*"

policy-map work_notwork

class work

set ip precedence 5

class class-default

interface Serial0/0

interface Dialer1

interface Vlan1

service-policy input work_notwork

ip policy route-map SERIAL-ADSL

access-list 110 permit ip any any precedence critical

access-list 110 permit tcp any any eq smtp

access-list 110 permit udp any any eq domain

access-list 110 permit tcp any any eq domain

access-list 111 deny ip any any precedence critical

access-list 111 permit ip any any

route-map SERIAL-ADSL permit 10

match ip address 110

set interface Serial0/0 Dialer1

route-map SERIAL-ADSL permit 20

match ip address 111

set interface Dialer1 Serial0/0

1 REPLY
Silver

Re: Policy routing based on domain names (NBAR)

Can you try the service policy applying as output , don't see any problem with the configurtion, please refer this link :

http://www.cisco.com/en/US/products/sw/iosswrel/ps1838/products_feature_guide09186a0080134add.html#1020718

480
Views
0
Helpful
1
Replies
CreatePlease to create content