Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Policy Routing

I'm attempting to force certain subnets out via one of our upstreams:

Our 7206VXR does one-armed routing (Multi Port-Channel sub interfaces)

!

interface Port-channel1.501

description DFX_Internal

encapsulation dot1Q 501

ip address 203.149.69.1 255.255.255.224

ip policy route-map unlimited-traffic

!

And my unlimited-traffic route-map:

!

route-map unlimited-traffic permit 10

match ip address prefix-list unlimited-traffic-prefixes

set ip next-hop 203.63.121.150

!

!

ip prefix-list unlimited-traffic-prefixes seq 10 permit 203.149.70.0/24

ip prefix-list unlimited-traffic-prefixes seq 20 permit 203.149.69.5/32

ip prefix-list unlimited-traffic-prefixes seq 100 deny 0.0.0.0/0 le 32

!

But when trace'ing from 203.149.69.5 to an external dest., it goes via one of our other upstreams.

Thanks in advance for any assistance.

Regards,

MB

3 REPLIES
Gold

Re: Policy Routing

Hi Michael -

Here's two document links on policy routing that might / might not be useful to you. Let us know how get on.

>http://www.cisco.com/warp/public/cc/techno/protocol/tech/plicy_wp.htm

>http://www.cisco.com/warp/public/105/36.pdf

Hope this helps -

Bronze

Re: Policy Routing

Hi MB,

any specific reason why you're using a prefix-list? I think prefix-lists only work when filtering routing protocol updates or redistribution.

For PBR I suggest you try an access-list instead:

route-map unlimited-traffic permit 10

match ip address 1

set ip next-hop 203.63.121.150

!

!

access-list 1 permit 203.149.70.0 0.0.0.255

access-list 1 permit host 203.149.69.5

!

hth

Herbert

Community Member

Re: Policy Routing

Herbert,

Yes - Policy routing only works with Standard or Extended ACL's - Doh!!

Thanks to all who relied.

Regards,

MB

85
Views
0
Helpful
3
Replies
CreatePlease to create content