Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Port aggregation between Netscreen and Cisco

Hi

Does anybody have experience/tried to configure port aggregation between a Netscreen ISG2000 and a Cisco Cat 4003 ?

If yes pls provide me some info since all the tests I did doesn’t worked out…

I tried to config ether-channel on Cisco and aggregation interface on Netscreen with no success.

Netscreen says it currently works but no tech explaination I was able to find out on the web.

Tks

Ric

  • Other Network Infrastructure Subjects
4 REPLIES

Re: Port aggregation between Netscreen and Cisco

Hi,

you will have to use LACP (PAGP is Cisco proprietary). So the Cisco config could look like this:

interface GigabitEthernet0/0

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on

!

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on

!

interface Port-channel1

switchport trunk encapsulation dot1q

switchport mode trunk

Hope this helps

Martin

Cisco Employee

Re: Port aggregation between Netscreen and Cisco

4003 supports only Sup1 and hence runs CAT OS only. LCAP is supported in CAT OS from 7.1(1) and later. The following page should help you with configurations

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat4000/rel7_6/config/channel.htm#1048854

The commands are gonna be like

set channelprotocol lacp

Note that this will change channel mode on the entire module. Then you can assign the ports to the channel using the following example(port 3/33-34)

set port lacp-channel 3/33-34 mode active

New Member

Re: Port aggregation between Netscreen and Cisco

Martin, in your config what does it specify to use LACP?

Re: Port aggregation between Netscreen and Cisco

Hi

The config posted by martin doesnt include any etherchannel protocol related config.

its uses the option on which will bring the port to channel unconditionally and with that option selected u wont be able to mention out the protocol selection.

u can make use of channel-protocol LACP/PAGP to select the protocol and channel-group number mode {active | auto | desirable | on | passive} to select the different modes supported by different protocols.

regds

1364
Views
0
Helpful
4
Replies