Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Port Channel 1 cannot form on separate GE module

Hi ,

I have 2 Cat 6509 that I would like to form EtherChannel between them.

Define gi4/1 on both Catalyst to be switchport trunk, dot1q encapsulaion and created Port-channel1 as a result of channel-group 1 mode on command.

interface GigabitEthernet4/1

description EtherChannel to core B

no ip address

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on

!

interface Port-channel1

no ip address

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

!

I modified the Port-channel to be trunk and dot1q encapsulation.

I also proceeded to make Gi7/1 (different GE module) to be part of the same EtherChannel.

!

interface GigabitEthernet7/1

description EtherChannel to core B

no ip address

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

!

But when I entered the command channel-group 1 mode on Gi7/1 interface,

the Cat 6509 give me an error message:

core_A#conf t

Enter configuration commands, one per line. End with CNTL/Z.

core_A(config)#interface gi7/1

core_A(config-if)#channel-group 1 mode on

Command rejected (Port-channel1): Cannot configure L2 interfaces across DFC cards

core_A(config-if)#

Just wonder where I have gone wrong in configuring ?

Here are the basic modules:

core_A#show module

Mod Ports Card Type Model Serial No.

--- ----- -------------------------------------- ------------------ -----------

1 2 Catalyst 6000 supervisor 2 (Active) WS-X6K-S2U-MSFC2

2 2 Catalyst 6000 supervisor 2 (Standby) WS-X6K-S2U-MSFC2

3 48 SFM-capable 48-port 10/100 Mbps RJ45 WS-X6548-RJ-45

4 16 Pure SFM-mode 16 port 1000mb GBIC WS-X6816-GBIC

5 0 Switching Fabric Module-136 (Active) WS-X6500-SFM2

6 0 Switching Fabric Module-136 (Standby) WS-X6500-SFM2

7 16 Pure SFM-mode 16 port 1000mb GBIC WS-X6816-GBIC

The 2 Cat 6509 is running Native IOS:

core_A#show version

Cisco Internetwork Operating System Software

IOS (tm) c6sup2_rp Software (c6sup2_rp-JK2SV-M), Version 12.1(12c)E4, EARLY DEPL

OYMENT RELEASE SOFTWARE (fc1)

TAC Support: http://www.cisco.com/tac

Copyright (c) 1986-2002 by cisco Systems, Inc.

Compiled Sat 12-Oct-02 13:44 by hqluong

Image text-base: 0x40008980, data-base: 0x41A32000

ROM: System Bootstrap, Version 12.1(11r)E1, RELEASE SOFTWARE (fc1)

BOOTLDR: c6sup2_rp Software (c6sup2_rp-JK2SV-M), Version 12.1(12c)E4, EARLY DEPL

OYMENT RELEASE SOFTWARE (fc1)

core_A uptime is 2 days, 29 minutes

System returned to ROM by power-on (SP by power-on)

System image file is "sup-bootflash:c6sup22-jk2sv-mz.121-12c.E4.bin"

cisco Catalyst 6000 (R7000) processor with 227328K/34816K bytes of memory.

Processor board ID SAL06478Q0B

R7000 CPU at 300Mhz, Implementation 39, Rev 3.3, 256KB L2, 1024KB L3 Cache

Last reset from power-on

Bridging software.

X.25 software, Version 3.0.0.

SuperLAT software (copyright 1990 by Meridian Technology Corp).

TN3270 Emulation software.

1 Virtual Ethernet/IEEE 802.3 interface(s)

48 FastEthernet/IEEE 802.3 interface(s)

36 Gigabit Ethernet/IEEE 802.3 interface(s)

381K bytes of non-volatile configuration memory.

32768K bytes of Flash internal SIMM (Sector size 512K).

Configuration register is 0x2102

core_A#

3 REPLIES
New Member

Re: Port Channel 1 cannot form on separate GE module

Real guess from a far... one of many possibilites, I guess....

Refering to this article:

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat6000/121_8aex/swconfig/l3_int.pdf

It mentions there could be an issue trying to form EtherChannel when the MTU on one interface is default (1500 bytes) and the other is larger.

Best of luck to you.

Bronze

Re: Port Channel 1 cannot form on separate GE module

Hi, I think it's not possible (see note 3):

Notes for Layer 2 EtherChannels:

1. The recommendation is to issue the minimum set of commands on the physical interface as possible to establish it within the port channel. This would mean to only use the 'switchport' to make it a Layer 2 interface, and then the channel-group command. The Port-channel will automatically be created upon entering the command. Enter the remaining command on the Port-channel.

2. After entering switchport command on the interface, the interface will default to a Layer-2 interface, but port-channel will still be disabled. To group that interface into a channel, the command channel-group mode is required. If switchport is erased, all the commands related to that switchport will no longer show in configuration because they do not apply. However, if switchport is re-enabled again, all the commands will still be there. Thus entering no switchport then switchport does not clear the port channel group information.

3. DFC enabled line cards cannot have Layer 2 EtherChannels across multiple line cards but Layer 3 EtherChannels may span multiple cards.

Here's the link:

http://www.cisco.com/en/US/partner/products/hw/switches/ps708/products_white_paper09186a008009d846.shtml

Hope this info helps.

New Member

Re: Port Channel 1 cannot form on separate GE module

Hi all,

Managed to have a Cisco response to this issue. It was in Release notes of

IOS Version 12.1(12c)E4.

It stated:

With a PFC2 and DFCs, you cannot configure Layer 2 EtherChannels that include interfaces on

different DFC-equipped switching modules. You can do the following:

– Create Layer 3 EtherChannels that include ports on different DFC-equipped switching modules.

– Create Layer 2 EtherChannels that include ports on a single DFC-equipped switching module.

– Create Layer 2 EtherChannels that include supervisor engine ports and ports on

non-DFC-equipped switching modules.

Note Layer 2 EtherChannels are formed from ports configured with the switchport keyword.

This problem is resolved in Release 12.1(13)E. (CSCdt27074)

Thanks and rgds,

413
Views
0
Helpful
3
Replies
CreatePlease login to create content