Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Port Grouping and Trunking problem

Hi all

I have 2 swtiches located different places

distance of 2KM

i will explain how the setup look like

main office in central location

branch office different location around 2KM distance

main office having 3548XL switch and VLAN Linux Server

branch office having 2924XL with different VLANS

iam having dark fiber from office to office

different routes

both the routes of cable are working, when i tested individual link.

i want to make them loadbalance and failover

so i started working like this

internet--(eth0)Linux(eth1-vlan 30-40)--(fe0/1)switch(fe0/2-fe0/3)-----fiber2links---(fe0/2-fe0/3)switch2924(fe0/4-vlan30)--clent

above setup is mine

my config

3548XL

interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,30-40,1002-1005

switchport mode trunk

!

interface FastEthernet0/2

port group 1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,30-40,1002-1005

switchport mode trunk

!

interface FastEthernet0/3

port group 1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,30-40,1002-1005

switchport mode trunk

!

interface FastEthernet0/4

!

my config of 2924XL

interface FastEthernet0/2

keepalive 10

port group 1

switchport access vlan 22

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,30-40,1002-1005

switchport mode trunk

no cdp enable

!

interface FastEthernet0/3

keepalive 10

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-22,1002-1005

switchport mode trunk

no cdp enable

!

interface FastEthernet0/4

keepalive 10

switchport access vlan 30

no cdp enable

!

when i connect 3548xl(fe0/2)-2924XL(fe0/2)

when i connect 3548xl(fe0/3)-2924XL(fe0/3)

the ports are not going up

what will be wrong with my setup

any recomendations will be appriciate

one more thing, when iam adding vlan 30-40 in my port

why vlan 1 also adding in to the same port

thanks in advance

hari

5 REPLIES
VIP Purple

Re: Port Grouping and Trunking problem

Hello Hari,

not sure if that is what is configured on your 2924XL, but:

interface FastEthernet0/2

keepalive 10

port group 1

--> switchport access vlan 22

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,30-40,1002-1005

switchport mode trunk

no cdp enable

the interface cannot be trunk and access port at the same time, so take that line out (actually I think that the IOS would not let you type this in anyway).

There are a couple of things to keep in mind when configuring trunking on the 2900XL/3500XL switches, here is what the documentation says:

On a 4MB DRAM Catalyst 2900XL switch, trunking is only supported with the following trunking-capable modules:

WS-X2914-XL-V

WS-X2922-XL-V

WS-X2924-XL-V

WS-X2931-XL

WS-X2932-XL

2900XL and 3500XL switches do not support Dynamic Trunking Protocol (DTP). Thus, it is recommended that you use the nonegotiate option (for the switchport trunk command) on the other side of the trunk link This will prevent the XL switch from receiving DTP frames (from the peer) that it cannot proccess.

You might want to check this document:

Configuring ISL/802.1q Trunking Between Catalyst 2900XL/3500XL/2940/2950/2970 and CatOS Switches

http://www.cisco.com/en/US/partner/tech/tk389/tk390/technologies_configuration_example09186a008009441a.shtml

Regards,

Georg

Community Member

Re: Port Grouping and Trunking problem

Hi Georg

thanks for reply

it was my mistake, i remove the VLAN 22

i think both of my switches are trunk enabled

iam sure that they works

since i have used single port with dot.q with Linux box

now iam extending the Services with 2 ports

so i can do load balace or failover the links

i had visited the link, but the example of mine from this doc only, i made some changes as per my setup

i need to look this, how to make my setup work

can you post me some kind of example config if possible

that will help me lot

thanks

hare

VIP Purple

Re: Port Grouping and Trunking problem

Hello,

can you post the output of the comamnd:

show int fastEthernet X/X switchport

for all interfaces in the port channel ? The output should look similar to this:

Name: Fa0/1

Switchport: Enabled

Administrative mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: Disabled

Access Mode VLAN: 0 ((Inactive))

Trunking Native Mode VLAN: 1 (default)

Trunking VLANs Enabled: ALL

Trunking VLANs Active: 1,2

Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0

Override vlan tag priority: FALSE

Voice VLAN: none

Appliance trust: none

Self Loopback: No

Also, can you post the output of the command:

show vtp status

from both switches ?

Also, check for spanning tree failures with the command:

debug spantree tree

Here is a link with sample configs for 802.1Q trunks on 3500XL (the 2900XL are configured the same way):

CISCO CATALYST 3500 SERIES XL SWITCHES

Creating and Maintaining VLANs

http://www.cisco.com/en/US/partner/products/hw/switches/ps637/products_configuration_guide_chapter09186a008007f261.html

Regards,

Georg

Community Member

Re: Port Grouping and Trunking problem

Hi

thanks for the quick reply

here is teh out put wat you asked for

3500XL#show interfaces fastEthernet 0/2 switchport

Name: Fa0/2

Switchport: Enabled

Administrative mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: Disabled

Access Mode VLAN: 0 ((Inactive))

Trunking Native Mode VLAN: 1 (default)

Trunking VLANs Enabled: 1,30-40,1002-1005

Trunking VLANs Active: 1

Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0

Override vlan tag priority: FALSE

Voice VLAN: none

Appliance trust: none

3500XL#show vtp status

VTP Version : 2

Configuration Revision : 0

Maximum VLANs supported locally : 254

Number of existing VLANs : 5

VTP Operating Mode : Transparent

VTP Domain Name : office.net

VTP Pruning Mode : Disabled

VTP V2 Mode : Disabled

VTP Traps Generation : Disabled

MD5 digest : 0x11 0xD1 0x11 0x31 0x61 0xC1 0xCF 0x60

Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00

iam going through the docs

lets see how i can make the config

one more thing, iam working on a online switch,

by making changes, my rest of the port will not effect anything right ??

hari

Community Member

Re: Port Grouping and Trunking problem

Hi all

iam back to work again

i been trying to achive this setup

could not able to

could some expert put some coment on this setup

that will be great

hari

392
Views
0
Helpful
5
Replies
CreatePlease to create content