Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Port security

I am on a network that is running DHCP for clients.I am currently connected to a 2950 catalyst switch access switch and I want to implement port-security such that other than me,any other computer connected to the switchport where I am connected should be shutdown.

I have this ocnfigurations on the Access switch and yet it is not working. Can somebody help me figure out what is worng with my configuration ?.

AS#conf t

AS(conf)#int fa0/13

As(conf-if)#switchport port-security

As(conf-if)#switchport port-security violation shutdown

As(conf-if)#switchport port-security mac-address 0050.56C0.0001

4 REPLIES
Silver

Re: Port security

Hi

Can you post how are you seeing it is not working?

I only see you are missing command "switchport mode access".

Hope this helps

Community Member

Re: Port security

Re: Port security

make sure fa0/13 is configured as access port and not trunk port.

port-security feature doesn't work with trunk ports.

Community Member

Re: Port security

I think that it depends on which IOS level you are running. I am running Cisco Internetwork Operating System Software

IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(11)EA1, RELEASE SOFTWARE

(fc1)

Here is a sample config from a port that I have setup and tested port security on...

interface FastEthernet0/1

description Locked Down Port

switchport access vlan 101

switchport mode access

switchport port-security

switchport port-security mac-address sticky

switchport port-security mac-address sticky 0013.92c9.680f

no ip address

spanning-tree portfast

138
Views
0
Helpful
4
Replies
CreatePlease to create content