Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Port VLAN ID Mismatch ?!?!

hi guyz, i got connected 2 switch both trunk is using 802.1q and STP on. but 1 of my switch is keep blocking the trunk port and i have only 1 physical connection btw this 2 device... below is the debug msg and sh runn

BTN_CORE_1#sh spanning-tree interface gigabitEthernet 4/1 detail

Port 193 (GigabitEthernet4/1) of VLAN0100 is broken (Port VLAN ID Mismatch)

Port path cost 4, Port priority 128, Port Identifier 128.193.

Designated root has priority 32868, address 0016.466c.ccc0

Designated bridge has priority 32868, address 0016.466c.ccc0

Designated port id is 128.193, designated path cost 0

Timers: message age 0, forward delay 14, hold 0

Number of transitions to forwarding state: 0

Link type is point-to-point by default

BPDU: sent 291, received 0

6 REPLIES
New Member

Re: Port VLAN ID Mismatch ?!?!

BTN_CORE_1#sh run

Building configuration...

Current configuration : 5544 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

service compress-config

!

hostname BTN_CORE_1

!

boot-start-marker

boot-end-marker

!

!

redundancy

mode sso

enable password btn

!

no aaa new-model

hw-module uplink select tengigabitethernet

vtp domain ''

vtp mode transparent

ip subnet-zero

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

power redundancy-mode redundant

!

!

!

vlan internal allocation policy ascending

!

vlan 2

name NATIVE_VLAN

!

vlan 100,200,300,400,500

!

!

interface GigabitEthernet3/1

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet3/2

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet3/3

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet3/4

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet3/5

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet3/6

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet3/7

switchport access vlan 500

switchport mode access

!

interface GigabitEthernet3/8

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet3/9

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet3/10

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet3/11

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet3/12

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet3/13

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet3/14

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet3/15

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet3/16

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet3/17

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet3/18

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet3/19

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet3/20

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet3/21

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet3/22

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet3/23

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet3/24

!

interface GigabitEthernet4/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 100-500

switchport mode trunk

!

interface GigabitEthernet4/23

switchport access vlan 100

switchport mode access

!

interface Vlan1

no ip address

shutdown

!

interface Vlan100

ip address 10.20.152.3 255.255.255.128

standby ip 10.20.152.2

!

interface Vlan200

ip address 10.20.153.2 255.255.255.128

standby ip 10.20.153.1

!

interface Vlan300

ip address 10.20.153.130 255.255.255.128

standby ip 10.20.153.129

!

interface Vlan400

ip address 10.20.154.2 255.255.255.128

standby ip 10.20.154.1

!

interface Vlan500

ip address 10.20.155.2 255.255.255.128

standby ip 10.20.155.1

!

ip route 0.0.0.0 0.0.0.0 10.20.152.1

Re: Port VLAN ID Mismatch ?!?!

HI

This is the normal behaviour for STP to block one link if u r having redundant links in order to prevent loops in u r netwotk.

As far as VLANID mismatch is concerned i think u r having different native vlans on u r trunk ports.

Ensure that u have same native vlan on the ends of the switches.

Thanks

Mahmood

New Member

Re: Port VLAN ID Mismatch ?!?!

both side is running native vlan 1 ... problem still ther...

Re: Port VLAN ID Mismatch ?!?!

Hi William,

Can you also paste the config of the other switch and specify what is the trunk ports.

Regards,

Ankur

Re: Port VLAN ID Mismatch ?!?!

Hi William,

Can you please confirm which is the native vlan on the trunk ports connecting 2 different switches.

If there is a native vlan mismatch between 2 switches it may result in dropping traffic for native vlans and also sometimes I have seen no vlans communicate when there is a native vlan.

Please confirm the native vlans on the trunk and if they are different try to change it and keep them same and see if it resolves the issue.

Regards,

Ankur

New Member

Re: Port VLAN ID Mismatch ?!?!

It looks like you are only permitting vlans 100-500. Your native vlan 1 also needs to be permitted, or you can change your native vlan to be 100. Which is what I would do.

6449
Views
0
Helpful
6
Replies