Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

PPP MULTLINK NOT WORKING

HI i have an issue with PPP multilink.

It seems when i use Windows 98/95 PPP multilink does not work it only connects at 64000kbps when i press the resume button to intiate mutilink it does not initate the second channel. I can get this to work with win 2000 but on intial configuration win 2000 bundles the channels as default and not by pressing the resume button. so it connects directly as 128kbps. Now this would point to the windows 98 client not configured right but we have a us robotics dialin server and this connects at 64kbps then at 128kbps when u press the resume button, so it not the client. pls help i have tried everything. i have 3640 with c3640-is-mz.122-7a.bin ios this is the ip pus software with nm60dm card plus isdn30 combo card. the configuration looks fine to me cheers for any help

here the config

aaa new-model

aaa authentication login default group radius local

aaa authentication login NO_AUTHEN none

aaa authentication login VTYLINE enable

aaa authentication ppp default group radius none

aaa authorization network defaut group radius if-authenticated

enable secret 5 $1$qJOI$xh5DyZACAhN.IdoWhOPnf1

!

username admin callback-dialstring "" password 7 15010E19173E2E36

username newham\darvin1 password 7 110D1817011B055D

memory-size iomem 15

clock timezone gmt 0

ip subnet-zero

isdn switch-type primary-net5

call rsvp-sync

controller E1 0/0

pri-group timeslots 1-31

controller E1 0/1

pri-group timeslots 1-8,16

interface Serial0/0:15

no ip address

encapsulation ppp

dialer rotary-group 1

isdn switch-type primary-net5

isdn incoming-voice modem

no cdp enable

ppp multilink

interface Serial0/1:15

no ip address

encapsulation ppp

dialer rotary-group 1

isdn switch-type primary-net5

isdn incoming-voice modem

no cdp enable

ppp multilink

interface FastEthernet3/0

ip address

interface Group-Async0

ip unnumbered FastEthernet3/0

encapsulation ppp

async mode interactive

peer default ip address pool dhcpclient

ppp callback accept

ppp authentication ms-chap chap

group-range 33 62

interface Group-Async1

ip unnumbered FastEthernet3/0

encapsulation ppp

async mode interactive

ppp callback accept

ppp authentication ms-chap chap

group-range 65 94

interface Dialer1

ip unnumbered FastEthernet3/0

encapsulation ppp

dialer in-band

dialer idle-timeout 3000

dialer load-threshold 1 outbound

peer default ip address pool dhcpclient

ppp callback accept

ppp authentication chap ms-chap

ppp multilink

radius-server host 111.113.101.2 auth-port 1645 acct-port 1646 key 7 15010E01053A232B3A36

dial-peer cor custom

3 REPLIES
Bronze

Re: PPP MULTLINK NOT WORKING

Try collecting the following debug to try and figure out what is going wrong:

debug ppp neg

debug ppp mult event

debug dialer

debug isdn q931

New Member

Re: PPP MULTLINK NOT WORKING

I HAVE TRIED all this before and still no joy. still cant read any problems from the debug maybe u can.

i have some also done some show commands

show ppp multilink

Virtual-Access1, bundle name is NEWHAM\dappanah

Bundle up for 00:03:22

Dialer interface is Dialer1

0 lost fragments, 0 reordered, 0 unassigned

0 discarded, 0 lost received, 1/255 load

0x168 received sequence, 0x0 sent sequence

Member links: 1 (max not set, min not set)

Serial0/0:0, since 00:03:22, last rcvd seq 000167

BRIREMOTEDIAL#show ppp queu

Proc #0 pid=2

authens =134 avg=5 s.

per-user=748 avg=0 s.

preauth =0 avg=0 s.

authors =0 avg=0 s.

queue len=0 max len=4

BRIREMOTEDIAL#show

*Mar 7 02:38:32: Vi1 MLP: Load (1) above threshold in bundle NEWHAM\darvinappanah

% Type "show ?" for a list of subcommands

BRIREMOTEDIAL#how show dialer aler

Serial0/0:0 - dialer type = ISDN

Idle timer (3000 secs), Fast idle timer (20 secs)

Wait for carrier (30 secs), Re-enable (15 secs)

Dialer state is multilink member (NEWHAM\darvinappanah)

Serial0/0:1 - dialer type = ISDN

Idle timer (3000 secs), Fast idle timer (20 secs)

Wait for carrier (30 secs), Re-enable (15 secs)

Dialer state is idle

Serial0/0:2 - dialer type = ISDN

Idle timer (3000 secs), Fast idle timer (20 secs)

Wait for carrier (30 secs), Re-enable (15 secs)

Dialer state is idle

Serial0/0:3 - dialer type = ISDN

Idle timer (3000 secs), Fast idle timer (20 secs)

Wait for carrier (30 secs), Re-enable (15 secs)

Dialer state is idle

Serial0/0:4 - dialer type = ISDN

Idle timer (3000 secs), Fast idle timer (20 secs)

BRIREMOTEDIAL#show dialer maps

Dynamic dialer map ip 151.133.101.98 name NEWHAM\darvinappanah () on Di1

*Mar 7 02:34:59: ISDN Se0/0:15: RX <- SETUP pd = 8 callref = 0x0001

*Mar 7 02:34:59: Sending Complete

*Mar 7 02:34:59: Bearer Capability i = 0x8890

*Mar 7 02:34:59: Channel ID i = 0xA98381

*Mar 7 02:34:59: Called Party Number i = 0x81, '345766', Plan:ISDN, Type:Unknown

*Mar 7 02:34:59: Low Layer Compat i = 0x8890

*Mar 7 02:34:59: ISDN Se0/0:15: llc valid, speed 64, call type is DATA

speed:0 async:N

*Mar 7 02:34:59: %LINK-3-UPDOWN: Interface Serial0/0:0, changed state to up

*Mar 7 02:34:59: Se0/0:0 PPP: Treating connection as a callin

*Mar 7 02:34:59: Se0/0:0 PPP: Phase is ESTABLISHING, Passive Open [0 sess, 0 load]

*Mar 7 02:34:59: Se0/0:0 LCP: State is Listen

*Mar 7 02:34:59: ISDN Se0/0:15: TX -> CALL_PROC pd = 8 callref = 0x8001

*Mar 7 02:34:59: Channel ID i = 0xA98381

*Mar 7 02:34:59: ISDN Se0/0:15: TX -> CONNECT pd = 8 callref = 0x8001

*Mar 7 02:34:59: Channel ID i = 0xA98381

*Mar 7 02:34:59: ISDN Se0/0:15: RX <- CONNECT_ACK pd = 8 callref = 0x0001

*Mar 7 02:34:59: ISDN Se0/0:15: CALL_PROGRESS: CALL_CONNECTED call id 0x9A, bchan 0, dsl 0

*Mar 7 02:34:59: Se0/0:0 LCP: I CONFREQ [Listen] id 1 len 46

*Mar 7 02:34:59: Se0/0:0 LCP: ACCM 0x000A0000 (0x0206000A0000)

*Mar 7 02:34:59: Se0/0:0 LCP: MagicNumber 0x000AEE34 (0x0506000AEE34)

*Mar 7 02:34:59: Se0/0:0 LCP: PFC (0x0702)

*Mar 7 02:34:59: Se0/0:0 LCP: ACFC (0x0802)

*Mar 7 02:34:59: Se0/0:0 LCP: Callback 6 (0x0D0306)

*Mar 7 02:34:59: Se0/0:0 LCP: MRRU 1500 (0x110405DC)

*Mar 7 02:34:59: Se0/0:0 LCP: EndpointDisc 1 Local

*Mar 7 02:34:59: Se0/0:0 LCP: (0x1313017403000033EE0A0070FD4EC140)

*Mar 7 02:34:59: Se0/0:0 LCP: (0x180000)

*Mar 7 02:34:59: Se0/0:0 LCP: O CONFREQ [Listen] id 55 len 35

*Mar 7 02:34:59: Se0/0:0 LCP: AuthProto MS-CHAP (0x0305C22380)

*Mar 7 02:34:59: Se0/0:0 LCP: MagicNumber 0x27956698 (0x050627956698)

*Mar 7 02:34:59: Se0/0:0 LCP: MRRU 1524 (0x110405F4)

*Mar 7 02:34:59: Se0/0:0 LCP: EndpointDisc 1 BRIREMOTEDIAL (0x13100142524952454D4F54454449414C)

*Mar 7 02:34:59: Se0/0:0 LCP: O CONFACK [Listen] id 1 len 46

*Mar 7 02:34:59: Se0/0:0 LCP: ACCM 0x000A0000 (0x0206000A0000)

*Mar 7 02:34:59: Se0/0:0 LCP: MagicNumber 0x000AEE34 (0x0506000AEE34)

*Mar 7 02:34:59: Se0/0:0 LCP: PFC (0x0702)

*Mar 7 02:34:59: Se0/0:0 LCP: ACFC (0x0802)

*Mar 7 02:34:59: Se0/0:0 LCP: Callback 6 (0x0D0306)

*Mar 7 02:34:59: Se0/0:0 LCP: MRRU 1500 (0x110405DC)

*Mar 7 02:34:59: Se0/0:0 LCP: EndpointDisc 1 Local

*Mar 7 02:34:59: Se0/0:0 LCP: (0x1313017403000033EE0A0070FD4EC140)

*Mar 7 02:34:59: Se0/0:0 LCP: (0x180000)

*Mar 7 02:34:59: Se0/0:0 LCP: I CONFACK [ACKsent] id 55 len 35

*Mar 7 02:34:59: Se0/0:0 LCP: AuthProto MS-CHAP (0x0305C22380)

*Mar 7 02:34:59: Se0/0:0 LCP: MagicNumber 0x27956698 (0x050627956698)

*Mar 7 02:34:59: Se0/0:0 LCP: MRRU 1524 (0x110405F4)

*Mar 7 02:34:59: Se0/0:0 LCP: EndpointDisc 1 BRIREMOTEDIAL (0x13100142524952454D4F54454449414C)

*Mar 7 02:34:59: Se0/0:0 LCP: State is Open

*Mar 7 02:34:59: Se0/0:0 PPP: Phase is AUTHENTICATING, by this end [0 sess, 0 load]

*Mar 7 02:34:59: Se0/0:0 MS-CHAP: O CHALLENGE id 35 len 26 from "BRIREMOTEDIAL"

*Mar 7 02:34:59: Se0/0:0 MS-CHAP: I RESPONSE id 35 len 74 from "NEWHAM\darvinappanah"

*Mar 7 02:34:59: Se0/0:0 MS-CHAP: O SUCCESS id 35 len 4

*Mar 7 02:34:59: Se0/0:0 DDR: Authenticated host NEWHAM\dppanah with no matching dialer map

*Mar 7 02:34:59: Se0/0:0 MCB: Callback not authorized for this user NEWHAM\dappanah

*Mar 7 02:34:59: Serial0/0:0 PPP: O MCB Request(1) id 28 len 6

*Mar 7 02:34:59: Serial0/0:0 MCB: O 1 1C 0 6 1 2

*Mar 7 02:34:59: Se0/0:0 MCB: O Request Id 28 Callback Type None

*Mar 7 02:34:59: Se0/0:0 PPP: Phase is CBCP [0 sess, 0 load]

*Mar 7 02:34:59: Serial0/0:0 PPP: I MCB Response(2) id 28 len 6

*Mar 7 02:34:59: Serial0/0:0 MCB: I 2 1C 0 6 1 2

*Mar 7 02:34:59: Se0/0:0 MCB: Received response

*Mar 7 02:34:59: Se0/0:0 MCB: Response CBK-None 1 2

*Mar 7 02:34:59: Serial0/0:0 PPP: O MCB Ack(3) id 29 len 6

*Mar 7 02:34:59: Serial0/0:0 MCB: O 3 1D 0 6 1 2

*Mar 7 02:34:59: Se0/0:0 MCB: O Ack Id 29 Callback Type None

*Mar 7 02:34:59: Se0/0:0 MCB: No Callback negotiated; Exit

*Mar 7 02:34:59: Se0/0:0 MLP: Request add link to bundle

*Mar 7 02:34:59: Se0/0:0 PPP: Phase is VIRTUALIZED [0 sess, 0 load]

*Mar 7 02:34:59: Se0/0:0 MLP: Adding link to bundle

*Mar 7 02:34:59: Vi1 PPP: Phase is DOWN, Setup [0 sess, 0 load]

*Mar 7 02:34:59: Vi1 PPP: No remote authentication for call-in

*Mar 7 02:34:59: Vi1 PPP: Phase is ESTABLISHING [0 sess, 0 load]

*Mar 7 02:34:59: Vi1 MLP: Added to huntgroup Di1

*Mar 7 02:34:59: Vi1 MLP: Clone from Di1

*Mar 7 02:34:59: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up

*Mar 7 02:34:59: Vi1 DDR: Dialer statechange to up

*Mar 7 02:34:59: Vi1 DDR: Dialer received incoming call from

*Mar 7 02:34:59: Vi1 PPP: Treating connection as a callin

*Mar 7 02:34:59: Vi1 LCP: State is Listen

*Mar 7 02:34:59: Vi1 DDR: Authenticated host NEWHAM\darvinappanah with no matching dialer map

*Mar 7 02:34:59: Vi1 PPP: Phase is UP [0 sess, 0 load]

*Mar 7 02:34:59: Vi1 IPCP: O CONFREQ [Closed] id 1 len 10

*Mar 7 02:34:59: Vi1 IPCP: Address 151.133.101.1 (0x030697856501)

*Mar 7 02:34:59: Vi1 MLP: Added first link Se0/0:0 to bundle NEWHAM\dappanah

*Mar 7 02:35:00: Vi1 IPCP: I CONFREQ [REQsent] id 1 len 40

*Mar 7 02:35:00: Vi1 IPCP: CompressType VJ 15 slots CompressSlotID (0x0206002D0F01)

*Mar 7 02:35:00: Vi1 IPCP: Address 0.0.0.0 (0x030600000000)

*Mar 7 02:35:00: Vi1 IPCP: PrimaryDNS 0.0.0.0 (0x810600000000)

*Mar 7 02:35:00: Vi1 IPCP: PrimaryWINS 0.0.0.0 (0x820600000000)

*Mar 7 02:35:00: Vi1 IPCP: SecondaryDNS 0.0.0.0 (0x830600000000)

*Mar 7 02:35:00: Vi1 IPCP: SecondaryWINS 0.0.0.0 (0x840600000000)

*Mar 7 02:35:00: Vi1 IPCP: Pool returned 151.133.101.98

*Mar 7 02:35:00: Vi1 IPCP: O CONFREJ [REQsent] id 1 len 22

*Mar 7 02:35:00: Vi1 IPCP: CompressType VJ 15 slots CompressSlotID (0x0206002D0F01)

*Mar 7 02:35:00: Vi1 IPCP: SecondaryDNS 0.0.0.0 (0x830600000000)

*Mar 7 02:35:00: Vi1 IPCP: SecondaryWINS 0.0.0.0 (0x840600000000)

*Mar 7 02:35:00: Vi1 IPCP: I CONFACK [REQsent] id 1 len 10

*Mar 7 02:35:00: Vi1 IPCP: Address 151.133.101.1 (0x030697856501)

*Mar 7 02:35:00: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0:0, changed state to up

*Mar 7 02:35:00: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up

*Mar 7 02:35:01: Vi1 IPCP: TIMEout: State ACKrcvd

*Mar 7 02:35:01: Vi1 IPCP: O CONFREQ [ACKrcvd] id 2 len 10

*Mar 7 02:35:01: Vi1 IPCP: Address 151.133.101.1 (0x030697856501)

*Mar 7 02:35:02: Vi1 IPCP: I CONFACK [REQsent] id 2 len 10

*Mar 7 02:35:02: Vi1 IPCP: Address 151.133.101.1 (0x030697856501)

*Mar 7 02:35:02: Vi1 MLP: Load (1) above threshold in bundle NEWHAM\darvinappanah

*Mar 7 02:35:03: Vi1 IPCP: I CONFREQ [ACKrcvd] id 2 len 34

*Mar 7 02:35:03: Vi1 IPCP: Address 0.0.0.0 (0x030600000000)

*Mar 7 02:35:03: Vi1 IPCP: PrimaryDNS 0.0.0.0 (0x810600000000)

*Mar 7 02:35:03: Vi1 IPCP: PrimaryWINS 0.0.0.0 (0x820600000000)

*Mar 7 02:35:03: Vi1 IPCP: SecondaryDNS 0.0.0.0 (0x830600000000)

*Mar 7 02:35:03: Vi1 IPCP: SecondaryWINS 0.0.0.0 (0x840600000000)

*Mar 7 02:35:03: Vi1 IPCP: O CONFREJ [ACKrcvd] id 2 len 16

*Mar 7 02:35:03: Vi1 IPCP: SecondaryDNS 0.0.0.0 (0x830600000000)

*Mar 7 02:35:03: Vi1 IPCP: SecondaryWINS 0.0.0.0 (0x840600000000)

*Mar 7 02:35:03: Vi1 IPCP: I CONFREQ [ACKrcvd] id 3 len 22

*Mar 7 02:35:03: Vi1 IPCP: Address 0.0.0.0 (0x030600000000)

*Mar 7 02:35:03: Vi1 IPCP: PrimaryDNS 0.0.0.0 (0x810600000000)

*Mar 7 02:35:03: Vi1 IPCP: PrimaryWINS 0.0.0.0 (0x820600000000)

*Mar 7 02:35:03: Vi1 IPCP: O CONFNAK [ACKrcvd] id 3 len 22

*Mar 7 02:35:03: Vi1 IPCP: Address 151.133.101.98 (0x030697856562)

*Mar 7 02:35:03: Vi1 IPCP: PrimaryDNS 151.133.103.30 (0x81069785671E)

*Mar 7 02:35:03: Vi1 IPCP: PrimaryWINS 151.133.75.200 (0x820697854BC8)

*Mar 7 02:35:03: Vi1 IPCP: I CONFREQ [ACKrcvd] id 4 len 22

*Mar 7 02:35:03: Vi1 IPCP: Address 151.133.101.98 (0x030697856562)

*Mar 7 02:35:03: Vi1 IPCP: PrimaryDNS 151.133.103.30 (0x81069785671E)

*Mar 7 02:35:03: Vi1 IPCP: PrimaryWINS 151.133.75.200 (0x820697854BC8)

*Mar 7 02:35:03: Vi1 IPCP: O CONFACK [ACKrcvd] id 4 len 22

*Mar 7 02:35:03: Vi1 IPCP: Address 151.133.101.98 (0x030697856562)

*Mar 7 02:35:03: Vi1 IPCP: PrimaryDNS 151.133.103.30 (0x81069785671E)

*Mar 7 02:35:03: Vi1 IPCP: PrimaryWINS 151.133.75.200 (0x820697854BC8)

*Mar 7 02:35:03: Vi1 IPCP: State is Open

*Mar 7 02:35:03: Vi1 DDR: dialer protocol up

*Mar 7 02:35:03: Di1 IPCP: Install route to 151.133.101.98

*Mar 7 02:35:05: %ISDN-6-CONNECT: Interface Serial0/0:0 is now connected to NEWHAM\dappanah

*Mar 7 02:35:32: Vi1 MLP: Load (1) above threshold in bundle NEWHAM\darvinappanah

*Mar 7 02:36:02: Vi1 MLP: Load (1) above threshold in bundle NEWHAM\darvinappanah

*Mar 7 02:36:32: Vi1 MLP: Load (7) above threshold in bundle NEWHAM\darvinappanah

*Mar 7 02:37:02: Vi1 MLP: Load (39) above threshold in bundle NEWHAM\darvinappanah

*Mar 7 02:37:32: Vi1 MLP: Load (23) above threshold in bundle NEWHAM\darvinappanah

Bronze

Re: PPP MULTLINK NOT WORKING

We are not seeing a second call incoming.

At 02:34:59 we recieve the first call; it is established (ISDN and PPP) at 02:35:03. The messages you see after that are simply an indication that the load-threshold (which you have configured as 1) has been met or exceeded; however, since this side only receives calls we cannot dial out. The debug lasts for 150 seconds after the initial call, yet we do NOT see an ISDN Q.931 SETUP message incoming...therefore, we don't know about any second call. I suspect the client is not dialing out; I can't tell you why this works with non-cisco

equipment.

99
Views
0
Helpful
3
Replies