Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

Bronze

ppp over frame relay question

Does anyone know if the ppp quality command works on a circuit setup for ppp over frame relay?

Also, the frame circuit is currently a p2p subinterface. Can ppp over f/r be done on an individual subinterface and not on the others?

1 REPLY
Bronze

Re: ppp over frame relay question

Well I guess no one likes my question. Heres some added info.

I found some examples in cisco docs that used ppp quality on frame relay sub-interfaces. But I cant get it to work. I set it up in my lab like this. This is just a lab so dont worry about hiding the addresses.

! R2

interface Virtual-Template1

ip address 10.1.4.2 255.255.255.0

!

interface Virtual-Template2

ip address 10.1.5.2 255.255.255.0

!

interface Serial0

no ip address

encapsulation frame-relay

!

interface Serial0.1 point-to-point

frame-relay interface-dlci 104 ppp Virtual-Template1

!

interface Serial0.2 point-to-point

frame-relay interface-dlci 105 ppp Virtual-Template2

!

interface Serial0.3 point-to-point

ip address 10.1.6.2 255.255.255.0

frame-relay interface-dlci 106

! R5!

interface Serial0

no ip address

encapsulation frame-relay

!

interface Serial0.1 point-to-point

frame-relay interface-dlci 501 ppp Virtual-Template1

!

It works like this but as soon as I add the command

ppp quality 80

to either side or both sides the link goes down.

Debug ppp packets is on

00:33:33: Vi1 PPP: O pkt type 0x0021, datagramsize 72

00:33:33: Vi1 PPP: I pkt type 0x0021, datagramsize 72

r4(config)#int virtual-te 1 „²---virtual template1

r4(config-if)#ppp quali

00:33:43: Vi1 PPP: O pkt type 0x0021, datagramsize 72

00:33:43: Vi1 PPP: I pkt type 0x0021, datagramsize 72

r4(config-if)#ppp quality 80 „²----set quality

r4(config-if)#

00:33:46: Vi1 LCP: O CONFREQ [Closed] id 3 len 18

00:33:46: Vi1 LCP: QualityType 0xC025 period 1000 (0x0408C025000003E8)

00:33:46: Vi1 LCP: MagicNumber 0x109A6CC9 (0x0506109A6CC9)

00:33:46: Vi1 PPP: I pkt type 0xC021, datagramsize 14

00:33:46: Vi1 PPP: I pkt type 0xC021, datagramsize 22

00:33:46: Vi1 LCP: I CONFREQ [REQsent] id 13 len 10

.

.

.

r4(config-if)# ---- LQRs start here

00:33:56: Vi1 LQM: O state Open magic 0x109A6CC9 len 48

00:33:56: Vi1 LQM: LastOutLQRs 0 LastOutPackets/Octets 0/0

00:33:56: Vi1 LQM: PeerInLQRs 0 PeerInPackets/Discards/Errors/Octets 0/0/0/0

00:33:56: Vi1 LQM: PeerOutLQRs 1 PeerOutPackets/Octets 241/32225

00:33:56: Vi1 PPP: I pkt type 0xC025, datagramsize 52

00:33:56: Vi1 LQM: I state Open magic 0xE0CE862E len 48

00:33:56: Vi1 LQM: LastOutLQRs 1 LastOutPackets/Octets 241/32225

00:33:56: Vi1 LQM: PeerInLQRs 1 PeerInPackets/Discards/Errors/Octets 240/0/0/1

6044

00:33:56: Vi1 LQM: PeerOutLQRs 1 PeerOutPackets/Octets 1185/91773

.

.

.

00:34:46: Vi1 LQM: PeerOutLQRs 6 PeerOutPackets/Octets 1219/94415

00:34:46: Vi1 IPCP: O TERMREQ [Open] id 3 len 4

r4(config-if)#

00:34:46: Vi1 PPP: I pkt type 0x8021, datagramsize 8

00:34:46: Vi1 IPCP: I TERMACK [Closed] id 3 len 4

-----50 seconds later it goes down -------

r4(config-if)#

00:34:47: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, change

d state to down

00:34:47: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.6.2 on Virtual-Access1 from FULL to

DOWN, Neighbor Down: Interface down or detached

This is lab. It doesn¡¦t have a quality problem. Does anyone know whats going on??? When I try the same thing on a point to point serial circuit it stays up.

107
Views
0
Helpful
1
Replies