Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

PPP over X25 on ISDN dchannel using two 1600's

Hi,

I am trying to connect two 1600's together using PPP over X25 on ISDN dchannel using the AODI method. The following two configs are the client and server running configs of each router (client first). I keep getting this error (Pending on AODI dialer) in debug and this (%ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0, TEI 82 changed to down) indicating the x25 vc is not working. Isdn status show MULTIPLE_FRAME_ESTABLISHED.

Any help on this would be great.

Thanks,

Ed

-------------------------------------------------------------------------------

Client Router Config

ip subnet-zero

isdn switch-type basic-net3

x25 routing

!

!

!

interface Ethernet0

ip address 192.168.1.1 255.255.255.0

no ip directed-broadcast

!

interface Serial0

ip address 10.24.111.2 255.255.255.252

no ip directed-broadcast

no fair-queue

clockrate 2000000

!

interface BRI0

no ip address

no ip directed-broadcast

encapsulation ppp

dialer rotary-group 0

dialer-group 1

isdn switch-type basic-net3

isdn x25 dchannel

!

interface BRI0:0

no ip address

no ip directed-broadcast

x25 address 4923923

x25 htc 4

x25 win 3

x25 wout 3

x25 aodi

x25 map ppp 4923070 interface Dialer0

!

interface Dialer0

ip address 172.16.12.2 255.255.255.252

no ip directed-broadcast

encapsulation ppp

dialer in-band

dialer string 4923070

dialer-group 1

ppp multilink bap

ppp bap call request

ppp bap timeout pending 20

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.24.111.1

ip route 172.16.13.0 255.255.255.0 172.16.12.1

!

dialer-list 1 protocol ip permit

no cdp run

--------------------------------------------

Server Router Config

ip subnet-zero

no ip domain-lookup

!

isdn switch-type basic-net3

x25 routing

!

!

!

!

interface Loopback0

ip address 172.16.13.1 255.255.255.0

no ip directed-broadcast

!

interface Ethernet0

ip address 10.24.110.2 255.255.255.0

no ip directed-broadcast

!

interface Serial0

ip address 10.24.111.1 255.255.255.252

no ip directed-broadcast

no ip mroute-cache

!

interface BRI0

no ip address

no ip directed-broadcast

encapsulation ppp

no ip mroute-cache

dialer rotary-group 0

dialer-group 1

isdn switch-type basic-net3

isdn x25 dchannel

!

interface BRI0:0

no ip address

no ip directed-broadcast

no ip mroute-cache

x25 address 4923070

x25 htc 4

x25 win 3

x25 wout 3

x25 map ppp 4923923 no-outgoing interface Dialer0

!

interface Dialer0

ip address 172.16.12.1 255.255.255.252

no ip directed-broadcast

encapsulation ppp

ppp multilink bap

ppp multilink idle-link

ppp bap call accept

ppp bap timeout pending 20

ppp bap number default 4923070

!

router eigrp 100

network 10.0.0.0

!

ip classless

ip route 192.168.1.0 255.255.255.0 172.16.12.2

no ip http server

!

dialer-list 1 protocol ip permit

no cdp run

1 REPLY
Silver

Re: PPP over X25 on ISDN dchannel using two 1600's

Try configuring static TEI using the command "isdn x25 static-tei " because some switches require static TEI to be configured.

Since the TEI value is not getting assigned dynamically in your case ,i think if we configure the TEI stattically,it should work.

For configuration guidelines go through the following URL:

http://www.cisco.com/en/US/products/sw/iosswrel/ps1828/products_command_reference_chapter09186a00800ca53c.html

http://www.cisco.com/en/US/products/sw/iosswrel/ps1828/products_command_reference_chapter09186a00800ca53b.html#xtocid15

147
Views
0
Helpful
1
Replies