Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

PPP routing issue

I have a client who has the following setup. network_1 (10.166.53.0) on this network is a 1601-R with a T1 for internet. behind that 1601 is a firewall (10.166.53.101). Everyone on network_1 sees internet fine. They also have 2 1601-R's that are set up with a T1 between them thro the serial1 interface. RouterA has an eth0 address of 10.166.53.251 and a serial1 interface of 10.10.10.1/30. RouterB has an eth0 of 10.26.7.251 and a serial1 interface of 10.10.10.2/30. From RouterA I can ping both of the interfaces on RouterB. But nothing past eth0 on RouterB (IE 10.26.7.194). When I do traceroute it stops at 10.10.10.2

The following is the configs from the 2 routers.

RouterA

!

service timestamps debug uptime

service timestamps log uptime

service password-encryption

no service tcp-small-servers

no service udp-small-servers

!

hostname GMC

!

enable password silver

!

no ip name-server

!

ip subnet-zero

no ip domain-lookup

ip routing

!

interface Ethernet 0

no shutdown

description connected to EthernetLAN

ip address 10.166.53.251 255.255.255.0

keepalive 10

!

interface Serial 0

no description

no ip address

shutdown

!

interface Serial 1

no shutdown

description connected to Dodge

service-module t1 clock source line

service-module t1 data-coding normal

service-module t1 remote-loopback full

service-module t1 framing esf

service-module t1 linecode b8zs

service-module t1 lbo none

service-module t1 remote-alarm-enable

ip address 10.10.10.1 255.255.255.252

encapsulation ppp

!

router rip

version 2

network 10.0.0.0

no auto-summary

!

!

ip classless

no ip http server

snmp-server community public RO

no snmp-server location

no snmp-server contact

!

line console 0

exec-timeout 0 0

password silver

login

!

line vty 0 4

password silver

login

!

end

RouterB

!

service timestamps debug uptime

service timestamps log uptime

service password-encryption

no service tcp-small-servers

no service udp-small-servers

!

hostname Dodge

!

enable password silver

!

no ip name-server

!

ip subnet-zero

no ip domain-lookup

ip routing

!

interface Ethernet 0

no shutdown

description connected to EthernetLAN_1

ip address 10.26.7.251 255.255.255.0

keepalive 10

!

interface Serial 0

no description

no ip address

shutdown

!

interface Serial 1

no shutdown

description connected to GMC

service-module t1 clock source line

service-module t1 data-coding normal

service-module t1 remote-loopback full

service-module t1 framing esf

service-module t1 linecode b8zs

service-module t1 lbo none

service-module t1 remote-alarm-enable

ip address 10.10.10.2 255.255.255.252

encapsulation ppp

!

router rip

version 2

network 10.0.0.0

no auto-summary

!

!

ip classless

no ip http server

snmp-server community public RO

no snmp-server location

no snmp-server contact

!

line console 0

exec-timeout 0 0

password silver

login

!

line vty 0 4

password silver

login

!

end

I have been stumped for a couple of days now any help appreciated.

2 REPLIES
Cisco Employee

Re: PPP routing issue

Make sure that 10.26.7.194 and all devices connected to routerB Ethernet are configured with RIP or with a default gateway pointing at router B (10.26.7.251).

Hope this helps,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: PPP routing issue

Hi,

As you can ping Router B's ethernet interface (10.26.7.251) but nothing else on that network, i would suggest that the hosts behind Router B need they're default gateway set to router B.

Good luck

Teggs

93
Views
0
Helpful
2
Replies