Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

PPPoE connection using 2611 router

Hello:

I have 2611 router with IOS 12.2(15).T10. I am trying to make it accept DSL connection.I spent 3 whole days to make the router work and I believe I am very close to the solution but still can't connect to our ISP.

I found a doc from cisco.com web-site (www.cisco.com/warp/public/794/adslguide_pppoedsl_ts.shtml). It tells after the string

*Mar 3 03:33:19.539: Vi1 PAP: I AUTH-ACK id 255 Len 5

I should have the string similar to

*Mar 3 03:33:19.539: Vi1 PPP: Phase is UP [0 sess, 0 load]

but I have 10 timeouts in this place (see my debug information):

----------------------------------------------------

2d19h: Vi2 LCP: I TERMREQ [Open] id 3 len 4

2d19h: Vi2 LCP: O TERMACK [Open] id 3 len 4

2d19h: Vi2 PPP: Sending Acct Event[Down] id[F9]

2d19h: Vi2 PPP: Phase is TERMINATING

2d19h: PPPoE 62848: I PADT R:0009.7bcf.4854 L:0002.b915.ad81 Et0/1

00 02 B9 15 AD 81 00 09 7B CF 48 54 88 63 11 A7

F5 80 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ...

2d19h: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di1

2d19h: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down

2d19h: PPPoE 0: I PADO R:0009.7bcf.4854 L:0002.b915.ad81 Et0/1

00 02 B9 15 AD 81 00 09 7B CF 48 54 88 63 11 07

00 00 00 34 01 01 00 00 01 03 00 04 82 AE 38 FC ...

2d19h: PPPoE 62869: I PADS R:0009.7bcf.4854 L:0002.b915.ad81 Et0/1

00 02 B9 15 AD 81 00 09 7B CF 48 54 88 63 11 65

F5 95 00 34 01 01 00 00 01 03 00 04 82 AE 38 FC ...

2d19h: IN PADS from PPPoE Session

2d19h: %DIALER-6-BIND: Interface Vi2 bound to profile Di1

2d19h: Vi2 PPP: Phase is DOWN, Setup

2d19h: Vi2 PPP: Using dialer call direction

2d19h: Vi2 PPP: Treating connection as a callout

2d19h: Vi2 PPP: Phase is ESTABLISHING, Active Open

2d19h: Vi2 LCP: O CONFREQ [Closed] id 1 len 14

2d19h: Vi2 LCP: AuthProto PAP (0x0304C023)

2d19h: Vi2 LCP: MagicNumber 0x112E9577 (0x0506112E9577)

2d19h: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up

2d19h: Vi2 LCP: I CONFREQ [REQsent] id 1 len 18

2d19h: Vi2 LCP: MRU 1492 (0x010405D4)

2d19h: Vi2 LCP: AuthProto PAP (0x0304C023)

2d19h: Vi2 LCP: MagicNumber 0x32E11581 (0x050632E11581)

2d19h: Vi2 LCP: O CONFNAK [REQsent] id 1 len 8

2d19h: Vi2 LCP: MRU 1500 (0x010405DC)

2d19h: Vi2 LCP: I CONFACK [REQsent] id 1 len 14

2d19h: Vi2 LCP: AuthProto PAP (0x0304C023)

2d19h: Vi2 LCP: MagicNumber 0x112E9577 (0x0506112E9577)

2d19h: Vi2 LCP: I CONFREQ [ACKrcvd] id 2 len 18

2d19h: Vi2 LCP: MRU 1500 (0x010405DC)

2d19h: Vi2 LCP: AuthProto PAP (0x0304C023)

2d19h: Vi2 LCP: MagicNumber 0x32E11581 (0x050632E11581)

2d19h: Vi2 LCP: O CONFACK [ACKrcvd] id 2 len 18

2d19h: Vi2 LCP: MRU 1500 (0x010405DC)

2d19h: Vi2 LCP: AuthProto PAP (0x0304C023)

2d19h: Vi2 LCP: MagicNumber 0x32E11581 (0x050632E11581)

2d19h: Vi2 LCP: State is Open

2d19h: Vi2 PPP: Phase is AUTHENTICATING, by both

2d19h: Vi2 PAP: Using hostname from interface PAP

2d19h: Vi2 PAP: Using password from interface PAP

2d19h: Vi2 PAP: O AUTH-REQ id 1 len 28 from "MoyLogin"

2d19h: Vi2 PAP: I AUTH-ACK id 1 len 5

2d19h: Vi2 AUTH: Timeout 1

2d19h: Vi2 AUTH: Timeout 2

2d19h: Vi2 AUTH: Timeout 3

2d19h: Vi2 AUTH: Timeout 4

2d19h: Vi2 AUTH: Timeout 5

2d19h: Vi2 AUTH: Timeout 6

2d19h: Vi2 AUTH: Timeout 7

2d19h: Vi2 AUTH: Timeout 8

2d19h: Vi2 AUTH: Timeout 9

2d19h: Vi2 AUTH: Timeout 10

2d19h: Vi2 LCP: I TERMREQ [Open] id 3 len 4

2d19h: Vi2 LCP: O TERMACK [Open] id 3 len 4

2d19h: Vi2 PPP: Sending Acct Event[Down] id[FA]

2d19h: Vi2 PPP: Phase is TERMINATING

2d19h: PPPoE 62869: I PADT R:0009.7bcf.4854 L:0002.b915.ad81 Et0/1

00 02 B9 15 AD 81 00 09 7B CF 48 54 88 63 11 A7

F5 95 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ...

2d19h: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di1

2d19h: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down

2d19h: PPPoE 0: I PADO R:0009.7bcf.4854 L:0002.b915.ad81 Et0/1

00 02 B9 15 AD 81 00 09 7B CF 48 54 88 63 11 07

00 00 00 34 01 01 00 00 01 03 00 04 82 AE 38 FC ...

2d19h: PPPoE 62887: I PADS R:0009.7bcf.4854 L:0002.b915.ad81 Et0/1

00 02 B9 15 AD 81 00 09 7B CF 48 54 88 63 11 65

F5 A7 00 34 01 01 00 00 01 03 00 04 82 AE 38 FC ...

----------------------------------------------------

And so on . . .

I ran out of clever thoughts :)

I tried PAP and CHAP authentications (ISP uses PAP), I tested the line with regular PC connection -- all works OK.

My current configuration is as follows:

-------------------------------------------------

GTI#sh run

Building configuration...

Current configuration : 1458 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname GTI

!

logging queue-limit 100

enable secret xxxxxxxxxx

!

ip subnet-zero

!

!

!

ip audit notify log

ip audit po max-events 100

vpdn enable

!

vpdn-group 1

request-dialin

protocol pppoe

!

!

!

!

!

!

!

!

!

!

!

!

!

no voice hpi capture buffer

no voice hpi capture destination

!

!

mta receive maximum-recipients 0

!

!

!

!

interface Ethernet0/0

ip address 10.0.0.1 255.255.255.0

ip nat inside

no ip route-cache

no ip mroute-cache

half-duplex

no cdp enable

!

interface Serial0/0

no ip address

shutdown

!

interface BRI0/0

no ip address

shutdown

!

interface Ethernet0/1

no ip address

no ip route-cache

no ip mroute-cache

half-duplex

pppoe enable

pppoe-client dial-pool-number 1

no cdp enable

!

interface Dialer1

ip address negotiated

ip mtu 1492

ip nat outside

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication pap

ppp pap sent-username ourlogin password 0 ourpassword

!

ip nat inside source list 1 interface Dialer1 overload

ip http server

no ip http secure-server

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 10.0.0.0 255.255.255.0 10.0.0.2

!

!

!

access-list 1 permit 10.0.0.0 0.0.0.255

dialer-list 1 protocol ip permit

!

call rsvp-sync

!

!

mgcp profile default

!

dial-peer cor custom

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

password anotherpassword

login

!

!

end

GTI#

I tried to reach the ISP's technical support today, the guy told me they don’t support cisco routers and he can’t help me with this.

I appreciate any suggestions very much.

Sincerely,

Arkadiy

P.S. I forgot to say. The DSL line has one static IP address.

2 REPLIES

Re: PPPoE connection using 2611 router

I just had a very similar experience, small subnet instead of 1 IP, the only main difference in our configs is that a cisco rep told me to do

ppp authentication chap pap callin

my ISP is using CHAP though, not sure if that makes a difference. Yours looks ok to me for PAP...

My problem was a bit different though, if I rebooted the router, it would dial in once perfectly. After that, it wouldn't even try to get out. It would keep telling me that the "dialer-string" wasn't set (which it shouldn't be!!).

I finally decided to upgrade my IOS from 12.3(3c) to 12.3(5a) on a whim and all my problems disappeared. I am running the IP Plus feature pack with VPN hooks also...

You might try debugging the dialer or the authentication processes also. I believe

debug dialer events

debug ppp authenticatino

debug ppp negotiation

should give you more good info.

Community Member

Re: PPPoE connection using 2611 router

my isp is Bell Canada, Sympatico.

I connect internet by 2611.

you miss "ip tcp adjust-mss 1452", please make sure your IOS support it.

(config)#vpdn enable

(config)#vpdn-group pppoe

request-dialin

protocol pppoe

(config)#inter e 0/0

pppoe enable

pppoe-client dial-pool-number 1

(config)#inter e 0/1

ip nat inside

ip access-group 1 in

ip addr 192.168.1.1 255.255.255.0

ip tcp adjust-mss 1452

(config)#inter dialer 1

ip nat outside

mtu 1492

ip addr negotiated

enca ppp

dialer pool 1

ppp chap hostname YOUR_LOGIN

ppp chap password YOUR_PASSWORD

ppp pap sent-username YOUR_LOGIN password YOUR_PASSWORD

(config)# ip nat inside source list 1 inter dialer1 overload

ip route 0.0.0.0 0.0.0.0 dialer 1

454
Views
0
Helpful
2
Replies
CreatePlease to create content