Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

PPPOE - DNS problem

Hello,

I have setup the PPPOE on my 3620 router. But I am having some problem with my DNS, my DSL service is through Verizon, the way I have setup before with the Linksys router is working fine, the Linksys router will automaticlly obtain the IP address and DNS server IP address with NAT as well. Since I setup with my 3620 router, some URL is working fine and some is does not (like CNN.com or cisco.com). with PPPOE setup, I do not get the DNS ip address, so I manually set it in my DHCP config. But still does not working right. Anyone has same problem as mine ? Thanks for your response. Here is my configuration.

Router.FW.RO> en

Password:

Router.FW.RO#sh run

Building configuration...

Current configuration : 1676 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router.FW.RO

!

boot-start-marker

boot-end-marker

!

logging buffered 210000 debugging

enable secret xxxxxxx

!

no aaa new-model

ip subnet-zero

!

!

ip cef

no ip domain lookup

ip dhcp excluded-address 10.1.1.50 10.1.1.250

!

ip dhcp pool thieubui

network 10.1.1.0 255.255.255.0

default-router 10.1.1.50

dns-server 199.45.32.43 199.45.32.38

lease 7

!

ip inspect dns-timeout 3

ip audit po max-events 100

vpdn enable

!

vpdn-group pppoe

request-dialin

protocol pppoe

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface Ethernet0/0

ip address 10.1.1.50 255.255.255.0

ip nat inside

full-duplex

!

interface Serial0/0

no ip address

shutdown

!

interface Serial0/1

no ip address

shutdown

!

interface Ethernet0/1

no ip address

ip tcp adjust-mss 1452

full-duplex

pppoe enable

pppoe-client dial-pool-number 1

!

interface Serial0/0

no ip address

shutdown

no fair-queue

!

interface Dialer1

ip address negotiated

ip mtu 1492

ip nat outside

encapsulation ppp

dialer pool 1

ppp authentication chap callin

ppp chap hostname xxxx

ppp chap password xxxx

ppp pap sent-username xxxx password xxxxx

!

ip nat inside source list 1 interface Dialer1 overload

ip http server

no ip http secure-server

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

!

!

access-list 1 permit any

!

!

!

!

!

^C

!

line con 0

line aux 0

line vty 0 4

password password

login

!

!

!

end

  • Other Network Infrastructure Subjects
3 REPLIES
VIP Purple

Re: PPPOE - DNS problem

Hello,

I guess you have already checked the configuration of your hosts ?

Just to be sure try a couple of the DNS servers below, they are public ones; this just to exclude that your Verizon servers are overloaded:

199.166.28.10 (PS0.NS2.VRX.NET) - Apopka, Fl

199.166.29.3 (nl.public.rootfix.net) - Nederlands

199.166.31.3 (NS1.QUASAR.NET) - Orlando, FL, USA

195.117.6.25 (ZOLIBORZ.ELEKTRON.PL) - Poland

204.57.55.100 (NS1.JERKY.NET) - Boston, MA, USA

199.5.157.128 (ASLAN.OPEN-RSC.ORG) - Detroit, MI, USA

Regards,

Georg

New Member

Re: PPPOE - DNS problem

It also possible to add the dns entries manualy. If you use the command.

ip name-server

for instance

ip name-server 195.121.1.34

ip name-server 195.121.1.66

for each dns server you want to use, it should be possible to ping anything on the internet from the router console.

New Member

Re: PPPOE - DNS problem

Remember that you need to adjust your MTU settings

with PPPOE MTU 1456 works well

332
Views
0
Helpful
3
Replies
This widget could not be displayed.