Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

PPPOE on Fast Ethernet interface

I'm attempting to configure PPPOE on FE interface on Cisco 2621XM to non-Cisco DSL CPE. I have the sampe config from Cisco's doc, but I am not sure about the dialer pool and dialer-group commands and what they reference. This router also has ISDN interfaces configured and I don't want to conflict with those dialer interfaces. Thank you

devans

8 REPLIES
New Member

Re: PPPOE on Fast Ethernet interface

Are you wanting the 2621 to authenicate the dsl cpe using pppoe..?

New Member

Re: PPPOE on Fast Ethernet interface

Hope this can give you a hint (I will assume that ISDN has pool1 and you're using an ADSL modem)

interface fa0

no ip address

pppoe enable

pppoe-client dial-pool-number 2

interface Dialer (2 or Whatever)

ip mtu 1492

ip address (whatever)

ip nat outside

encapsulation ppp

dialer pool 2

dialer-group 1

dialer-list 1 protocol ip permit //depends on your routes

Please keep me informed, alot of people had authentication problems,so make sure to supply the correct authentication type and the username/password at the dialer interface.

Good Luck

New Member

Re: PPPOE on Fast Ethernet interface

Yes, it appears I am having authentication problems or ? At this point I am unable to connect. Verified username/password with ISP, however debug ppp negotiation shows failure to negotiate with peer ? My config:

version 12.2

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Lxxxxxxx

!

logging buffered 40000 debugging

no logging console

enable secret xxxxxxxxxxxxx

enable password xxxxxxxxx

!

username xxxx

username xxxx

ip subnet-zero

!

!

no ip domain lookup

ip name-server 199.224.86.16

ip name-server 199.224.86.20

ip name-server 199.224.86.15

!

ip audit notify log

ip audit po max-events 100

vpdn enable

!

vpdn-group 5

request-dialin

protocol pppoe

!

!

isdn switch-type basic-ni

isdn voice-call-failure 0

!

!

voice call carrier capacity active

!

!

!

!

mta receive maximum-recipients 0

!

!

!

!

interface FastEthernet0/0

description Dushore LAN interface

ip address 10.0.0.1 255.255.0.0

ip nat inside

load-interval 30

duplex auto

speed auto

no cdp enable

!

interface FastEthernet0/1

description Dushore Epix DSL interface

no ip address

load-interval 30

duplex auto

speed auto

pppoe enable

pppoe-client dial-pool-number 5

no cdp enable

!

interface BRI1/0

description ISDN BRI to Nicholson

no ip address

encapsulation ppp

dialer rotary-group 0

dialer-group 1

isdn switch-type basic-ni

isdn spid1 9999999999

isdn spid2 8888888888

no cdp enable

ppp multilink

!

interface BRI1/1

description ISDN Connection to Tunkhannock

no ip address

encapsulation ppp

dialer rotary-group 1

dialer-group 1

isdn switch-type basic-ni

isdn spid1 88888888

isdn spid2 88888888

no cdp enable

ppp multilink

!

interface BRI1/2

description ISDN BRI to Lacyville

no ip address

encapsulation ppp

dialer rotary-group 2

dialer-group 1

isdn switch-type basic-ni

isdn spid1 777777777

isdn spid2 77777777

no cdp enable

ppp multilink

!

interface BRI1/3

no ip address

shutdown

isdn switch-type basic-ni

!

interface Dialer0

description ISDN Connection to Nicholson

ip address 192.168.1.1 255.255.255.252

encapsulation ppp

dialer in-band

dialer idle-timeout 999999

dialer map ip 192.168.1.2 name LECHSNICH802 broadcast 639xxxx

dialer map ip 192.168.1.2 name LECHSNICH802 broadcast 639xxxx

dialer load-threshold 1 either

dialer-group 1

no cdp enable

ppp authentication chap

!

interface Dialer1

description ISDN Connection to Tunkhannock

ip address 192.168.1.5 255.255.255.252

encapsulation ppp

dialer in-band

dialer idle-timeout 999999

dialer map ip 192.168.1.6 name LECHSTUNK802 broadcast 639xxxx

dialer map ip 192.168.1.6 name LECHSTUNK802 broadcast 639xxxx

dialer load-threshold 1 either

dialer-group 1

no cdp enable

ppp authentication chap

!

interface Dialer2

description ISDN Connection to Lacyville

ip address 192.168.1.9 255.255.255.252

encapsulation ppp

dialer in-band

dialer idle-timeout 999999

dialer map ip 192.168.1.10 name LECHSLACY804 broadcast 639xxxx

dialer map ip 192.168.1.10 name LECHSLACY804 broadcast 639xxxx

dialer load-threshold 1 either

dialer-group 1

no cdp enable

ppp authentication chap

!

interface Dialer5

description Dialer Interface for DSL

ip address negotiated

ip mtu 1492

ip nat outside

encapsulation ppp

no ip mroute-cache

dialer pool 5

dialer idle-timeout 0

dialer persistent

dialer-group 5

no cdp enable

ppp authentication pap

ppp pap sent-username abcde@epix.net password xxxxxxxxxxxx

!

ip nat inside source list 1 interface Dialer5 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer5

ip route 10.1.0.0 255.255.0.0 192.168.1.2

ip route 10.2.0.0 255.255.0.0 192.168.1.6

ip route 10.3.0.0 255.255.0.0 192.168.1.10

no ip http server

!

!

access-list 1 permit 10.0.0.0 0.0.255.255

dialer-list 1 protocol ip permit

dialer-list 5 protocol ip permit

!

call rsvp-sync

!

!

mgcp profile default

!

dial-peer cor custom

!

!

!

!

banner motd ^Cx^C

!

line con 0

exec-timeout 5 0

password 7 125D003B1708220D293B252634

login

line aux 0

line vty 0 4

exec-timeout 5 0

password xxxx

login

transport input telnet

line vty 5 15

exec-timeout 5 0

password 7 xxxxxx

login

transport input telnet

!

!

end

New Member

Re: PPPOE on Fast Ethernet interface

Now try to disable the authentcation, "no ppp authentication pap". Yes

leave it with no authentication type.

Please keep me informed

Good Luck

New Member

Re: PPPOE on Fast Ethernet interface

If it worked with you (as I guess), then re-enable the authentication using this command:

ppp authentication pap callin

Note that without the "callin " your router will try to authenticate the other side, so your router must have a username/password entries for the peer. With "Callin", your router does not require the called router to authenticate.

Hope I helped

Regards,

Jawad

New Member

Re: PPPOE on Fast Ethernet interface

Nope, did not work. Looking through some of the debug outputs, the virtual-access interface and the dialer interface come up, it appears to be attempting to authenticate, and then the interfaces go down. It may not be able to authenticate because it doesn't connect, I don't know. ?

New Member

Re: PPPOE on Fast Ethernet interface

I don't see anything wrong in your config, but I don't see the need for rotary groups since you are not grouping multiple connections, I also think that some dialer pool commands are needed, however this, has nothing to do with the ADSL connection and the dialer 5 interface or the fast ethernet interface.

I think you should check the connection itself on a windows machine for example. Can you dump the debug output, it would help alot. Please use the "debug vpdn pppoe-error" and the "debug ppp authentication".

Regards,

Jawad

New Member

Re: PPPOE on Fast Ethernet interface

Jawad,

I solved the problem by using the command "ppp chap refuse". Apparently the router or the ISP was trying to authenticate with chap first, when I needed pap only. Thanks for all your help ?

PS, as for the rotary groups, I'm unfamilair with ISDN and this is how I got things to work.

D. Evans

466
Views
0
Helpful
8
Replies
CreatePlease login to create content