Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

PPPoE with Dialer Backup

Hello everyone!

I'm trying to set up an 1721 with 1ENET and 1-BS/T.

The 1ENET is used to set up a PPPoE connection to your ISP. I need to configure the BRI/Dialer Interface to Backup the PPPoE-Connection.

The complete sceanrio looks like this:

PIX501 connected to 1721

1721 connected via 1ENET PPPoE to ISP

PIX501 connected via easyVPN to PIX515 OUTSIDE

1721 Dialer 2 connected to Router on PIX515 DMZ as Backup

I have found several Backup hints regaring ATM etc but no backing up pppoe (with dialer) ?!?!?!

Thanks in advance for any help!

Mike

1 REPLY
VIP Purple

Re: PPPoE with Dialer Backup

Hello Mike,

check this sample config, you can put the ´backup interface´ statement in the ATM0 interface configuration. This sample config is for two dialer pools and for an 836 router, if you need only one pool disregard the config for the second pool.

Cisco#

!

vpdn enable

!

vpdn-group 1

accept-dialin

protocol pppoe

!

!Specifies the ISDN switch type

isdn switch-type basic-net3

!

interface Ethernet0

ip address 192.168.1.1 255.255.255.0

hold-queue 100 out

!

!ISDN interface to be used as a backup interface

interface BRI0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

!

interface ATM0

backup interface BRI0

no ip address

no atm ilmi-keepalive

pvc 1/40

encapsulation aal5snap

pppoe-client dial-pool-number 2

!

dsl operating-mode auto

!

! Dial backup interface, associated with physical BRI0 interface. Dialer pool 1 associates it with BRI0's dialer pool member 1

interface Dialer0

ip address negotiated

encapsulation ppp

dialer pool 1

dialer idle-timeout 30

dialer string 384040

dialer-group 1

!

! Primary interface associated with physical ATM0's interface, dialer pool 2 associates it with ATM0's dial-pool-number2

interface Dialer2

ip address negotiated

ip mtu 1492

encapsulation ppp

dialer pool 2

dialer-group 2

no cdp enable

!

ip classless

!Primary and backup interface given route metric

ip route 0.0.0.0 0.0.0.0 22.0.0.2

ip route 0.0.0.0 0.0.0.0 192.168.2.2 80

ip http server

!

!Specifies interesting traffic to trigger backup ISDN traffic

dialer-list 1 protocol ip permit

Regards,

Georg

259
Views
0
Helpful
1
Replies