Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

priority-list with PAT

Hi,

we have a low-speed leased-line to a customer-site, which is used for remote-administration. Because the traffic from GUI-clients is making telnet/ssh-sessions unworkable, we would like to implement priority-queueing.

I can see that the priority-queueing is working on our local-router by looking at the increasing access-list counters and the interface queue-counters, but it does not work on the remote-router. I presume this is due to the fact that we are using PAT on the remote-router. The priority access-list seems to be checked before the PAT translates the tcp-ports back to the original tcp-ports.

Anybody know of a solution to this problem? Or am I overlooking something obvious?

The (abreviated) setup:

Local-router:

=============

interface Serial0/0

ip address 10.0.0.1 255.255.255.0

priority-group 1

access-list 150 permit tcp any any eq telnet

priority-list 1 protocol ip high list 150

priority-list 1 default low

Remote-router:

==============

interface Ethernet0/0

ip address 10.1.1.1 255.255.255.0

ip nat outside

interface Serial0/0

ip address 10.0.0.2 255.255.255.0

ip nat inside

priority-group 1

ip nat inside source list 18 interface Ethernet0/0 overload

access-list 150 permit tcp any any eq telnet

priority-list 1 protocol ip high list 150

priority-list 1 default low

Thanks for any help!

2 REPLIES
Silver

Re: priority-list with PAT

Try switching the following remote-router statement:

access-list 150 permit tcp any any eq telnet

with:

access-list 150 permit tcp any eq telnet any

Hope this helps.

Rais.

New Member

Re: priority-list with PAT

That did it! I knew I was overlooking something simple.

Thanks a lot!

105
Views
0
Helpful
2
Replies
CreatePlease to create content