Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

problem dialing from BRI to PRI

Hi, I have a problem when dialing from a BRI interface to the PRI interface. I have tested it by pinging to 192.168.10.3 (this is the dialer interface of the PRI). Who can help me?

by pinging to 192.168.10.3 It seems that a link is build up, but by viewing the log, the link is hang up. There won't be any reply's on that ping.

router with BRI interface

interface BRI0/0

ip address 192.168.10.2 255.255.255.0

encapsulation ppp

dialer idle-timeout 30

dialer map ip 192.168.10.3 name CiscoRAS class dov broadcast xxxxxx

dialer watch-group 2

dialer-group 3

isdn switch-type basic-net3

ppp authentication pap

ppp pap sent-username ISDNBACKUP password 7 01240F165E07031C32

!

interface FastEthernet0/1

description connected to EthernetLAN_1

ip address 172.17.1.2 255.255.0.0

duplex auto

speed auto

ipx network 11 encapsulation SAP

!

router eigrp 100

network 11.0.0.0

network 172.16.0.0

network 172.17.0.0

network 192.168.10.0

no auto-summary

no eigrp log-neighbor-changes

!

ip classless

ip forward-protocol udp 6502

ip route 0.0.0.0 0.0.0.0 172.16.1.1

ip route 172.17.0.0 255.255.0.0 FastEthernet0/1

ip route 192.168.88.0 255.255.255.0 FastEthernet0/1

ip http server

ip pim bidir-enable

!

access-list 103 deny eigrp any any

access-list 103 permit ip any any

dialer watch-list 2 ip 11.1.1.1 255.0.0.0

dialer-list 3 protocol ip list 103

!

router with PRI interface

interface Serial1/0:15

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type primary-net5

isdn incoming-voice modem

no cdp enable

ppp callback accept

ppp authentication pap ms-chap

interface Dialer0

ip unnumbered Loopback0

ip nat inside

encapsulation ppp

dialer pool 1

dialer idle-timeout 300

dialer enable-timeout 5

dialer redial interval 5 attempts 1

dialer-group 1

peer default ip address pool inbpool

ppp callback accept

ppp authentication pap callin

ppp chap refuse

!

interface Dialer1

ip address 11.1.1.1 255.0.0.0 secondary

ip address 192.168.10.3 255.255.255.0

encapsulation ppp

dialer pool 1

dialer idle-timeout 30

dialer-group 3

ppp authentication pap

!

router eigrp 100

network 11.0.0.0

network 172.16.0.0

network 192.168.10.0

auto-summary

no eigrp log-neighbor-changes

!

ip local pool inbpool 192.168.100.1 192.168.100.100

ip nat inside source list 101 interface FastEthernet1/0 overload

ip classless

ip route 0.0.0.0 0.0.0.0 172.16.1.1

ip route 192.168.100.0 255.255.255.0 FastEthernet1/0

no ip http server

!

access-list 101 permit ip 192.168.100.0 0.0.0.255 any

access-list 103 deny eigrp any any

access-list 103 permit ip any any

dialer-list 1 protocol ip permit

dialer-list 3 protocol ip list 103

3 REPLIES
Bronze

Re: problem dialing from BRI to PRI

You don't provide the complete config for the BRI, but the map has a "class dov" on it that (I presume) is intended to make this data call using the bearer capability of voice. On the PRI side you have "isdn incoming-voice modem", which means that the PRI will take incoming voice calls and hand them to a modem. This won't work at all, so if that is the case you need to either remove the "class dov" from the BRI or try "no isdn incoming-voice modem" on the PRI.

New Member

Re: problem dialing from BRI to PRI

Thanks for your answer, here's the complete config of both routers. I did added the "class dov" in a later stadium, without the class dov, see below, it was also not possible to make a call when pinging to the dialer interface of the PRI.

1 must I also deleted the "ísdn incoming-voice modem"? If I delete it, I think that other users cant call in anymore.

config of the BRI router:

Cisco2651#sh runn

Building configuration...

Current configuration : 1626 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Cisco2651

!

enable password 7 xxxxxxx

!

ip subnet-zero

ip cef

!

!

no ip domain-lookup

!

ipx routing 1897.7854.6c4e

isdn switch-type basic-net3

!

!

!

interface FastEthernet0/0

description connected to EthernetLAN

ip address 172.16.1.2 255.255.0.0

duplex auto

speed auto

ipx network 10 encapsulation SAP

!

interface BRI0/0

ip address 192.168.10.2 255.255.255.0

encapsulation ppp

dialer idle-timeout 30

dialer map ip 192.168.10.3 name CiscoRAS broadcast xxxxx

dialer watch-group 2

dialer-group 3

isdn switch-type basic-net3

ppp authentication pap

ppp pap sent-username ISDNBACKUP password 7 Wireless

!

interface FastEthernet0/1

description connected to EthernetLAN_1

ip address 172.17.1.2 255.255.0.0

duplex auto

speed auto

ipx network 11 encapsulation SAP

!

router eigrp 100

network 11.0.0.0

network 172.16.0.0

network 172.17.0.0

network 192.168.10.0

no auto-summary

no eigrp log-neighbor-changes

!

ip classless

ip forward-protocol udp 6502

ip route 0.0.0.0 0.0.0.0 172.16.1.1

ip route 172.17.0.0 255.255.0.0 FastEthernet0/1

ip route 192.168.88.0 255.255.255.0 FastEthernet0/1

ip http server

ip pim bidir-enable

!

access-list 103 deny eigrp any any

access-list 103 permit ip any any

dialer watch-list 2 ip 11.1.1.1 255.0.0.0

dialer-list 3 protocol ip list 103

!

configuration PRI router

CiscoRAS#sh runn

Building configuration...

Current configuration : 5135 bytes

!

version 12.1

service timestamps debug datetime

service timestamps log datetime

no service password-encryption

!

hostname CiscoRAS

!

logging buffered 4096 debugging

no logging console

enable password 7 095C5B021A0415

!

username xxxxxxxxxxx

username ISDNBACKUP password 0 Wireless

!

!

!

!

modem country mica netherlands

ip subnet-zero

!

isdn switch-type primary-net5

isdn voice-call-failure 0

modemcap entry TAC:MSC=&F&D2S34=18000S40=10S54=456S10=50debugthismodemS71=4

!

controller E1 1/0

pri-group timeslots 1-31

!

controller E1 1/1

!

!

!

interface Loopback0

ip address 192.168.100.254 255.255.255.0

!

interface FastEthernet1/0

ip address 172.16.1.20 255.255.0.0

ip nat outside

no keepalive

duplex auto

speed auto

!

interface Serial1/0:15

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type primary-net5

isdn incoming-voice modem

no cdp enable

ppp callback accept

ppp authentication pap ms-chap

!

interface Group-Async1

no ip address

encapsulation ppp

dialer in-band

dialer pool-member 2

async mode dedicated

ppp callback accept

ppp authentication pap ms-chap

group-range 1 30

!

interface Dialer0

ip unnumbered Loopback0

ip nat inside

encapsulation ppp

dialer pool 1

dialer idle-timeout 300

dialer enable-timeout 5

dialer redial interval 5 attempts 1

dialer-group 1

peer default ip address pool inbpool

ppp callback accept

ppp authentication pap callin

ppp chap refuse

!

interface Dialer1

ip address 11.1.1.1 255.0.0.0 secondary

ip address 192.168.10.3 255.255.255.0

encapsulation ppp

dialer pool 1

dialer idle-timeout 30

dialer-group 3

ppp authentication pap

!

interface Dialer60

ip unnumbered Loopback0

ip nat inside

encapsulation ppp

dialer pool 2

dialer idle-timeout 300

dialer redial interval 5 attempts 1

dialer-group 1

peer default ip address pool inbpool

ppp callback accept

ppp authentication pap callin

ppp chap refuse

!

router eigrp 100

network 11.0.0.0

network 172.16.0.0

network 192.168.10.0

auto-summary

no eigrp log-neighbor-changes

!

ip local pool inbpool 192.168.100.1 192.168.100.100

ip nat inside source list 101 interface FastEthernet1/0 overload

ip classless

ip route 0.0.0.0 0.0.0.0 172.16.1.1

ip route 192.168.100.0 255.255.255.0 FastEthernet1/0

no ip http server

!

access-list 101 permit ip 192.168.100.0 0.0.0.255 any

access-list 103 deny eigrp any any

access-list 103 permit ip any any

dialer-list 1 protocol ip permit

dialer-list 3 protocol ip list 103

!

Cisco Employee

Re: problem dialing from BRI to PRI

Since you are using a dialer-profiles on receiving router to terminate the call based on username of the dial in router, you need to enter "dialer remote-name ISDNBACKUP" under the dialer interface on which you want to terminate the call (may be under interface Dialer1 )..So in other wards, you need to create dialer interface for each user with that "dialer remote-name xxx" command.

OR

you can use lagacy config..means one interface for all isdn users instead of seperate interface for each user as documented in a following url with sample config

http://www.cisco.com/warp/public/793/access_dial/5300.html

For async calls, you don't need "dialer pool-member 2 " under interface group-async 1..take that out and just add following two commands

dialer-group 1

peer default ip address pool inbpool

Now above url does talk about that too.

128
Views
0
Helpful
3
Replies
CreatePlease to create content