Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

problem dialing ISP

Hello,

I've a cisco 2503 running ios c2500-i-l.120-22

When the cisco dials to the ISP CHAP authentication is OK but IPCP addres negotiation is going wrong.

What can be wrong in my configuration?

See attached debugging output and configuration.

Thanks.

Henk van Steeg.

*Mar 1 01:18:30: ISDN BR0: TX -> SETUP pd = 8 callref = 0x07

*Mar 1 01:18:30: Bearer Capability i = 0x8890

*Mar 1 01:18:30: Channel ID i = 0x83

*Mar 1 01:18:30: Calling Party Number i = 0xA1, '524291892'

*Mar 1 01:18:30: Called Party Number i = 0x80, '0676003505'

*Mar 1 01:18:30: ISDN BR0: RX <- STATUS pd = 8 callref = 0x87

*Mar 1 01:18:30: Cause i = 0x82E46C - Invalid IE contents

*Mar 1 01:18:30: Call State i = 0x01

*Mar 1 01:18:30: ISDN BR0: RX <- CALL_PROC pd = 8 callref = 0x87

*Mar 1 01:18:30: Channel ID i = 0x89

*Mar 1 01:18:32: ISDN BR0: RX <- CONNECT pd = 8 callref = 0x87

*Mar 1 01:18:32: Date/Time i = 0x02071F091D0A

*Mar 1 01:18:32: Connected Number i = 0x00A3

*Mar 1 01:18:32: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up

*Mar 1 01:18:32: BR0:1 PPP: Treating connection as a callout

*Mar 1 01:18:32: BR0:1 PPP: Phase is ESTABLISHING, Active Open

*Mar 1 01:18:32: BR0:1 PPP: No remote authentication for call-out

*Mar 1 01:18:32: BR0:1 LCP: O CONFREQ [Closed] id 4 len 10

*Mar 1 01:18:32: BR0:1 LCP: MagicNumber 0x60A4DD24 (0x050660A4DD24)

*Mar 1 01:18:32: ISDN BR0: TX -> CONNECT_ACK pd = 8 callref = 0x07

*Mar 1 01:18:32: BR0:1 LCP: I CONFREQ [REQsent] id 82 len 36

*Mar 1 01:18:32: BR0:1 LCP: AuthProto CHAP (0x0305C22305)

*Mar 1 01:18:32: BR0:1 LCP: MagicNumber 0x278A5840 (0x0506278A5840)

*Mar 1 01:18:32: BR0:1 LCP: MRRU 1524 (0x110405F4)

*Mar 1 01:18:32: BR0:1 LCP: EndpointDisc 1 Local

*Mar 1 01:18:32: BR0:1 LCP: (0x1311014D4D4C505F3534303073746163)

*Mar 1 01:18:32: BR0:1 LCP: (0x6B)

*Mar 1 01:18:32: BR0:1 LCP: O CONFREJ [REQsent] id 82 len 25

*Mar 1 01:18:32: BR0:1 LCP: MRRU 1524 (0x110405F4)

*Mar 1 01:18:32: BR0:1 LCP: EndpointDisc 1 Local

*Mar 1 01:18:32: BR0:1 LCP: (0x1311014D4D4C505F3534303073746163)

*Mar 1 01:18:32: BR0:1 LCP: (0x6B)

*Mar 1 01:18:32: BR0:1 LCP: I CONFACK [REQsent] id 4 len 10

*Mar 1 01:18:32: BR0:1 LCP: MagicNumber 0x60A4DD24 (0x050660A4DD24)

*Mar 1 01:18:32: BR0:1 LCP: I CONFREQ [ACKrcvd] id 83 len 15

*Mar 1 01:18:32: BR0:1 LCP: AuthProto CHAP (0x0305C22305)

*Mar 1 01:18:32: BR0:1 LCP: MagicNumber 0x278A5840 (0x0506278A5840)

*Mar 1 01:18:32: BR0:1 LCP: O CONFACK [ACKrcvd] id 83 len 15

*Mar 1 01:18:32: BR0:1 LCP: AuthProto CHAP (0x0305C22305)

*Mar 1 01:18:32: BR0:1 LCP: MagicNumber 0x278A5840 (0x0506278A5840)

*Mar 1 01:18:32: BR0:1 LCP: State is Open

*Mar 1 01:18:32: BR0:1 PPP: Phase is AUTHENTICATING, by the peer

*Mar 1 01:18:32: BR0:1 CHAP: I CHALLENGE id 121 len 35 from "MMLP_5400stack"

*Mar 1 01:18:33: BR0:1 CHAP: Using alternate hostname vansteeg@tref.nl

*Mar 1 01:18:33: BR0:1 CHAP: Username MMLP_5400stack: lookup failure

*Mar 1 01:18:33: BR0:1 CHAP: Using default password

*Mar 1 01:18:33: BR0:1 CHAP: O RESPONSE id 121 len 37 from "vansteeg@tref.nl"

*Mar 1 01:18:33: BR0:1 CHAP: I SUCCESS id 121 len 4

*Mar 1 01:18:33: BR0:1 PPP: Phase is UP

*Mar 1 01:18:33: BR0:1 IPCP: O CONFREQ [Closed] id 34 len 10

*Mar 1 01:18:33: BR0:1 IPCP: Address 0.0.0.0 (0x030600000000)

*Mar 1 01:18:34: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, changp

*Mar 1 01:18:35: BR0:1 IPCP: TIMEout: State REQsent

*Mar 1 01:18:35: BR0:1 IPCP: O CONFREQ [REQsent] id 35 len 10

*Mar 1 01:18:35: BR0:1 IPCP: Address 0.0.0.0 (0x030600000000)

*Mar 1 01:18:37: BR0:1 IPCP: TIMEout: State REQsent

*Mar 1 01:18:37: BR0:1 IPCP: O CONFREQ [REQsent] id 36 len 10

vsa#*Mar 1 01:18:37: BR0:1 IPCP: Address 0.0.0.0 (0x030600000000)

*Mar 1 01:18:38: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 0676003

vsa#

*Mar 1 01:18:39: BR0:1 IPCP: TIMEout: State REQsent

*Mar 1 01:18:39: BR0:1 IPCP: O CONFREQ [REQsent] id 37 len 10

*Mar 1 01:18:39: BR0:1 IPCP: Address 0.0.0.0 (0x030600000000)

vsa#

*Mar 1 01:18:41: BR0:1 IPCP: TIMEout: State REQsent

*Mar 1 01:18:41: BR0:1 IPCP: O CONFREQ [REQsent] id 38 len 10

*Mar 1 01:18:41: BR0:1 IPCP: Address 0.0.0.0 (0x030600000000)

vsa#

*Mar 1 01:18:43: BR0:1 IPCP: TIMEout: State REQsent

*Mar 1 01:18:43: BR0:1 IPCP: O CONFREQ [REQsent] id 39 len 10

*Mar 1 01:18:43: BR0:1 IPCP: Address 0.0.0.0 (0x030600000000)

vsa#

*Mar 1 01:18:45: BR0:1 IPCP: TIMEout: State REQsent

*Mar 1 01:18:45: BR0:1 IPCP: O CONFREQ [REQsent] id 40 len 10

*Mar 1 01:18:45: BR0:1 IPCP: Address 0.0.0.0 (0x030600000000)

vsa#

*Mar 1 01:18:47: BR0:1 IPCP: TIMEout: State REQsent

*Mar 1 01:18:47: BR0:1 IPCP: O CONFREQ [REQsent] id 41 len 10

*Mar 1 01:18:47: BR0:1 IPCP: Address 0.0.0.0 (0x030600000000)

vsa#

*Mar 1 01:18:49: BR0:1 IPCP: TIMEout: State REQsent

*Mar 1 01:18:49: BR0:1 IPCP: O CONFREQ [REQsent] id 42 len 10

*Mar 1 01:18:49: BR0:1 IPCP: Address 0.0.0.0 (0x030600000000)

vsa#

*Mar 1 01:18:51: BR0:1 IPCP: TIMEout: State REQsent

*Mar 1 01:18:51: BR0:1 IPCP: O CONFREQ [REQsent] id 43 len 10

*Mar 1 01:18:51: BR0:1 IPCP: Address 0.0.0.0 (0x030600000000)

vsa#

*Mar 1 01:18:53: BR0:1 IPCP: TIMEout: State REQsent

*Mar 1 01:18:53: BR0:1 IPCP: O CONFREQ [REQsent] id 44 len 10

*Mar 1 01:18:53: BR0:1 IPCP: Address 0.0.0.0 (0x030600000000)

vsa#

*Mar 1 01:18:55: BR0:1 IPCP: TIMEout: State REQsent

*Mar 1 01:18:55: BR0:1 IPCP: State is Listen

vsa#

*Mar 1 01:19:49: BR0:1 PPP: Missed 5 keepalives, taking LCP down

*Mar 1 01:19:49: BR0:1 PPP: Phase is DOWN

*Mar 1 01:19:49: BR0:1 IPCP: State is Closed

*Mar 1 01:19:49: BR0:1 PPP: Phase is ESTABLISHING, Passive Open

*Mar 1 01:19:49: BR0:1 PPP: No remote authentication for call-out

*Mar 1 01:19:49: BR0:1 LCP: State is Listen

*Mar 1 01:19:49: %ISDN-6-DISCONNECT: Interface BRI0:1 disconnected from 06760s

*Mar 1 01:19:49: ISDN BR0: TX -> DISCONNECT pd = 8 callref = 0x07

*Mar 1 01:19:49: Cause i = 0x8090 - Normal call clearing

*Mar 1 01:19:49: ISDN BR0: RX <- RELEASE pd = 8 callref = 0x87

*Mar 1 01:19:49: Cause i = 0x8290 - Normal call clearing

*Mar 1 01:19:49: isdn_Call_disconnect()

*Mar 1 01:19:49: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down

*Mar 1 01:19:49: BR0:1 LCP: State is Closed

*Mar 1 01:19:49: BR0:1 PPP: Phase is DOWN

*Mar 1 01:19:49: ISDN BR0: TX -> RELEASE_COMP pd = 8 callref = 0x07

vsa#

*Mar 1 01:19:50: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, changn

vsa#sh ru

Building configuration...

Current configuration:

!

version 12.0

service timestamps debug datetime

service timestamps log datetime

service password-encryption

!

hostname vsa

!

enable secret xxxxxxxx

!

ip subnet-zero

no ip domain-lookup

isdn switch-type basic-net3

isdn tei-negotiation first-call

!

!

!

interface Ethernet0

ip address 10.0.0.12 255.0.0.0

no ip directed-broadcast

ip nat inside

!

interface Serial0

no ip address

no ip directed-broadcast

no ip mroute-cache

shutdown

!

interface Serial1

no ip address

no ip directed-broadcast

shutdown

!

interface BRI0

description internet 0528227966 / 0676003505

ip address negotiated

ip access-group internet in

no ip directed-broadcast

ip nat outside

encapsulation ppp

dialer idle-timeout 300

dialer string 0676003505

dialer hold-queue 20

dialer-group 1

isdn switch-type basic-net3

isdn tei-negotiation first-call

isdn calling-number 524291892

ppp max-bad-auth 5

ppp authentication ms-chap chap callin

ppp chap hostname vansteeg@tref.nl

ppp chap password xxxxxxxx

!

ip nat inside source list 100 interface BRI0 overload

ip classless

ip route 0.0.0.0 0.0.0.0 BRI0 permanent

!

!

ip access-list extended internet

permit ip any any

access-list 100 permit ip any any

dialer-list 1 protocol ip permit

no cdp run

!

line con 0

exec-timeout 600 0

logging synchronous

transport input none

line aux 0

line vty 0 4

password xxxxxxxx

!

end

3 REPLIES
Bronze

Re: problem dialing ISP

I'm not sure that it's possible to get debug from the ISP, but it would be interesting to see what they are seeing. The config is fine; essentially what is happening is that we are requesting the ISP give us an address (0.0.0.0), but we never get a response to our request, AND we never get a CONFREQ from the ISP, telling us what address they will be using. To ensure that the cisco isn't goofing it up somewhere, it would be good to check the output of "sh int" to verify how many packets came in and how many went out, and whether or not there were any errors or drops. Clear the counters before you ping, and then check the counters afterwords to compare. In general, you should see the in/out counters the same when all that has happened is the PPP negotiations.

New Member

Re: problem dialing ISP

Thanks for your answer.

It was not possible to get debugging output from the ISP.

At last I enabled mulitlink ppp.

And now the connection is WORKING.

I can not explain this behaviour.

Bronze

Re: problem dialing ISP

Hmmm...nor can I.

118
Views
0
Helpful
3
Replies
CreatePlease to create content