Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Problem for PPP on Leased Line

I have leased line back to back routers.I have configured dialer interface although dialer interface is mostly used on switched ckts.But I am using here on leased line bavck to back.Now what happens after restting the interface physical

It get disconnect after idle-timeout so I have made dilaer list to define interesting traffic also but still I am not able to trigger the call so dilaer interface timesout after being idle.I have used Map command

Map protocol ip <ip> name <remote side> broadcast ..I have not defined any string.I cannot define any string in above command as I have leased line ,no number to dial.

During which the call is active i am able to transfer data but if it times out after idle time specified I am unable to activate the call.

Please do help

5 REPLIES
Cisco Employee

Re: Problem for PPP on Leased Line

We need to see the config on both the routers.

You can turn on following debug to know what is going on.

debug ppp negotiation

debug dialer

debug ppp authentication

Capture it when the call gets disconnected and when you try the interesting traffic (you can use ping for that) to activate the line again.

New Member

Re: Problem for PPP on Leased Line

Hi sorry for delay here is my configuration and debug o/p also.

Regards,

Munit

Configuration of router 1:

router1#sh run

Building configuration...

Current configuration : 1209 bytes

!

version 12.2

no parser cache

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname router1

!

no logging console

enable secret 5 $1$xYa1$1.YkO1.NXT1epX8oSH8KQ1

!

username router2 password 0 abc

ip subnet-zero

!

frame-relay de-list 3 protocol ip gt 500

!

!

!

!

interface Loopback0

ip address 192.168.10.2 255.255.255.0

!

interface FastEthernet0

ip address 10.77.152.223 255.255.255.0

speed auto

!

interface Serial0

no ip address

encapsulation ppp

dialer in-band

dialer rotary-group 1

pulse-time 1

!

interface Serial1

no ip address

encapsulation ppp

shutdown

dialer in-band

dialer rotary-group 1

pulse-time 1

!

interface Dialer1

ip unnumbered Loopback0

encapsulation ppp

dialer in-band

dialer idle-timeout 30

dialer map ip 192.168.20.1 name router2 broadcast

dialer-group 1

ppp authentication chap

ppp direction callout

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.77.152.129

ip route 192.168.20.1 255.255.255.255 Dialer1

no ip http server

!

access-list 100 permit ip any any

dialer-list 1 protocol ip list 100

!

line con 0

line aux 0

line vty 0 4

exec-timeout 200 0

password lab

login

line vty 5 15

login

!

no scheduler allocate

end

router1#

similar is configuration on router 2

Debug ppp nego o/p on router 1

4:39:54: %LINK-3-UPDOWN: Interface Serial0, changed state to up

4:39:54: Se0 PPP: Using configured call direction

4:39:54: Se0 PPP: Treating connection as a callout

4:39:54: Se0 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load]

4:39:54: Se0 LCP: O CONFREQ [Closed] id 203 len 15

4:39:54: Se0 LCP: AuthProto CHAP (0x0305C22305)

4:39:54: Se0 LCP: MagicNumber 0x03B9ED37 (0x050603B9ED37)

4:39:54: Se0 LCP: I CONFREQ [REQsent] id 44 len 15

4:39:54: Se0 LCP: AuthProto CHAP (0x0305C22305)

4:39:54: Se0 LCP: MagicNumber 0x00FF543D (0x050600FF543D)

4:39:54: Se0 LCP: O CONFACK [REQsent] id 44 len 15

4:39:54: Se0 LCP: AuthProto CHAP (0x0305C22305)

4:39:54: Se0 LCP: MagicNumber 0x00FF543D (0x050600FF543D)

4:39:54: Se0 LCP: I CONFACK [ACKsent] id 203 len 15

4:39:54: Se0 LCP: AuthProto CHAP (0x0305C22305)

4:39:54: Se0 LCP: MagicNumber 0x03B9ED37 (0x050603B9ED37)

4:39:54: Se0 LCP: State is Open

4:39:54: Se0 PPP: Phase is AUTHENTICATING, by both [0 sess, 1 load]

4:39:54: Se0 CHAP: O CHALLENGE id 240 len 28 from "router1"

4:39:54: Se0 CHAP: I CHALLENGE id 35 len 28 from "router2"

4:39:54: Se0 CHAP: O RESPONSE id 35 len 28 from "router1"

4:39:54: Se0 CHAP: I SUCCESS id 35 len 4

4:39:54: Se0 CHAP: I RESPONSE id 240 len 28 from "router2"

4:39:54: Se0 CHAP: O SUCCESS id 240 len 4

4:39:54: Se0 PPP: Phase is UP [0 sess, 1 load]

4:39:54: Se0 IPCP: O CONFREQ [Closed] id 8 len 10

4:39:54: Se0 IPCP: Address 192.168.10.2 (0x0306C0A80A02)

4:39:54: Se0 CDPCP: O CONFREQ [Closed] id 8 len 4

4:39:54: Se0 IPCP: I CONFREQ [REQsent] id 1 len 10

4:39:54: Se0 IPCP: Address 192.168.20.1 (0x0306C0A81401)

4:39:54: Se0 IPCP: O CONFACK [REQsent] id 1 len 10

4:39:54: Se0 IPCP: Address 192.168.20.1 (0x0306C0A81401)

4:39:54: Se0 IPCP: I CONFACK [ACKsent] id 8 len 10

4:39:54: Se0 IPCP: Address 192.168.10.2 (0x0306C0A80A02)

4:39:54: Se0 IPCP: State is Open

4:39:54: Se0 LCP: I PROTREJ [Open] id 45 len 10 protocol CDPCP (0x820701080004)

4:39:54: Se0 CDPCP: State is Closed

4:39:54: Di1 IPCP: Install route to 192.168.20.1

4:39:55: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state

to up

router1#show dialer

Di1 - dialer type = IN-BAND SYNC NO-PARITY

Idle timer (30 secs), Fast idle timer (20 secs)

Wait for carrier (30 secs), Re-enable (15 secs)

Number of active calls = 1

Dial String Successes Failures Last DNIS

Se0 - dialer type = IN-BAND SYNC NO-PARITY

Rotary group 1, priority 0

Idle timer (30 secs), Fast idle timer (20 secs)

Wait for carrier (30 secs), Re-enable (15 secs)

Dialer state is data link layer up

Time until disconnect 24 secs( this is decreasing after it expires I cant ping also)

Connected to (router2)

Se1 - dialer type = IN-BAND SYNC NO-PARITY

Rotary group 1, priority 0

Idle timer (30 secs), Fast idle timer (20 secs)

Wait for carrier (30 secs), Re-enable (15 secs)

Dialer state is shutdown

If I ping during this remaining time then the timer is reset idle timer but once it times off I am unable to generate the interesting traffic.

New Member

Re: Problem for PPP on Leased Line

I have enabled now debug ip packet detail when the idle disconnect time reaches zero it gives me this o/p.Problem is I am unable to generate interesting traffic after that will initiate call.Please help

router1#ping 192.168.20.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.20.1, timeout is 2 seconds:

00:07:21: IP: s=10.10.10.13 (FastEthernet0), d=255.255.255.255, len 49, rcvd 2

00:07:21: UDP src=2606, dst=69

00:07:21: IP: s=192.168.10.2 (local), d=192.168.20.1 (Dialer1), len 100, sendi

00:07:21: ICMP type=8, code=0

00:07:21: IP: s=192.168.10.2 (local), d=192.168.20.1 (Dialer1), len 100, encap

lation failed

00:07:21: ICMP type=8, code=0

00:07:22: IP: s=10.10.10.13 (FastEthernet0), d=255.255.255.255, len 49, rcvd 2

00:07:22: UDP src=9906, dst=69.

00:07:23: IP: s=192.168.10.2 (local), d=192.168.20.1 (Dialer1), len 100, sendi

00:07:23: ICMP type=8, code=0

00:07:23: IP: s=192.168.10.2 (local), d=192.168.20.1 (Dialer1), len 100, encap

lation failed

00:07:23: ICMP type=8, code=0.

00:07:25: IP: s=192.168.10.2 (local), d=192.168.20.1 (Dialer1), len 100, sendi

00:07:25: ICMP type=8, code=0

00:07:25: IP: s=192.168.10.2 (local), d=192.168.20.1 (Dialer1), len 100, encap

lation failed

00:07:25: ICMP type=8, code=0

00:07:26: IP: s=10.10.10.13 (FastEthernet0), d=255.255.255.255, len 49, rcvd 2

00:07:26: UDP src=2606, dst=69.

00:07:27: IP: s=10.10.10.13 (FastEthernet0), d=255.255.255.255, len 49, rcvd 2

00:07:27: UDP src=9906, dst=69

00:07:27: IP: s=192.168.10.2 (local), d=192.168.20.1 (Dialer1), len 100, sendi

00:07:27: ICMP type=8, code=0

00:07:27: IP: s=192.168.10.2 (local), d=192.168.20.1 (Dialer1), len 100, encap

lation failed

00:07:27: ICMP type=8, code=0.

00:07:29: IP: s=192.168.10.2 (local), d=192.168.20.1 (Dialer1), len 100, sendi

00:07:29: ICMP type=8, code=0

00:07:29: IP: s=192.168.10.2 (local), d=192.168.20.1 (Dialer1), len 100, encap

lation failed

00:07:29: ICMP type=8, code=0.

Success rate is 0 percent (0/5)

router1#

Cisco Employee

Re: Problem for PPP on Leased Line

You have ip address mismatch..router1 has ip address 192.168.10.0 and other side of the link have 192.168.20.0..that is the probelm..Pl. change the ip address at router1 to 192.168.20.2..it will work..Not sure why you use "unnumbered loopback" instead of ip address config under the dialer interface..

New Member

Re: Problem for PPP on Leased Line

Hi Mr. Patel,

Thanx for instant reply.See I tried using directly putting ip address to dialer interface also on both sides that too in the same subnet

like router1(config)int dialer1,ip address 1.1.1.1

router2(config) int dialer 2,ip address 2.2.2.2

Above mentioned way also i tried.when i reset the interface it works but suppose during idle disconect time i dont send any traffic then I am unable to initiate a call as weused to do in case of isdn.same error messages here also comes if idle disconnect timer is expired.Moreover if any traffic is sent during the idle disconnect timer then it resets the timer.Everything is fine only question is that after dialer interface goes to idle state can i initiate call,I am unable to do here in case of leased lines.Moreover the configuration which i have showed you is from the following link which shows how to do load balacing on leased lines using ppp.

http://www.cisco.com/warp/public/793/access_dial/pppmultilink.html

Are we able to do it .

waiting for u reply

Munit

109
Views
0
Helpful
5
Replies
CreatePlease login to create content