Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Problem in ANIServer

Hai,

I am facing problem in ANIServer working. When I try to open the campus manager applications like User tracking or path analysis, the process getting delayed and a error message is reported saying that the ANIServer is not running. When I check out the process status, ANIServer is running with busy flag set. What can I do sort out this problem.

Suggestion please,

Majeed

3 REPLIES
New Member

Re: Problem in ANIServer

Majeed,

First thing is to check if ANI Discovery worked or not. Goto: Server Configuration->Diagnostics->Discovery Metrics

If there is not a completed discovery, ie. 100%, then you are not going to get anything for User Tracking and Path Analysis since both heavily rely on ANI Device Discovery, which is Topology Services.

Please check if all clients are having this problem.

Also make sure the CiscoWorks Server is resolvable both forward and reverse nslookup.

Here's a link you should look at:

http://www.cisco.com/warp/public/477/Campus/connect-19000.html

Hope that helps

New Member

Re: Problem in ANIServer

Check out the AniServer log, and look for errors, having to do with the systems that you are not getting User Tracking, etc. for. There is an IOS bug, where the NMS platform tries to use SNMP to pull information about the target device, using the bridge MIB, but it polls for an object that is not there. You will see an error in the log for the interface associated with the IP used as the device name, or if you used a device name, that or the IP that an nslookup provides will be there. The error will say that it tried to get subinterface information but it failed. This means that the IOS on the target system needs to be upgraded. Check out this online resource:

http://www.cisco.com/en/US/products/sw/cscowork/ps563/products_tech_note09186a0080094949.shtml

the fix for this is to upgrade to 12.1(14)E1.

Stay Strong,

Michael "OpenView Mike" Stoller

CEO/Senior Consultant and Engineer

EHI-INSM Inc.

michael.stoller@ehiinsm.com

http://www.ehiinsm.com

Disclaimer: My opinion, remarks, advice, etc. are not indicative of any of my company's policies or procedures. The information transmitted is intended only for the person or entity to which it is addressed and may contain confidential and/or privileged material. Any review, retransmission, dissemination or other use of or taking of any action in reliance upon, this information by persons or entities other than the intended recipient is prohibited. If you received this in error, please contact the sender and delete the material from any computer.

New Member

Re: Problem in ANIServer

If this is for Campus 3.3, I've had a similar problem that was resolved by not using either localhost or the loopback ip address in the url to access the homepage

i.e. dont use http://localhost:1741

but instead use http://10.1.1.1:1741 or http://lms:1741 where lms = the hostname of the server.

Cheers

Dave

100
Views
0
Helpful
3
Replies
CreatePlease login to create content