Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Problem in assaining IP address

I have a Cisco 2610 with WIC2T and 1 PRI Module.

When the remote client (BRI ISDN) client logs in all the clients get the same IP assained. The following is the config of the router. Please advice and help.

!

ip multicast-routing

isdn switch-type primary-net5

!

controller E1 1/0

framing NO-CRC4

pri-group timeslots 1-31

!

!

!

interface Loopback0

no ip address

!

interface FastEthernet0/0

ip address 172.168.10.254 255.255.255.0

ip access-group 101 in

ip nat inside

no ip mroute-cache

speed auto

full-duplex

!

interface Serial0/0

ip address 192.168.200.22 255.255.255.252

no ip mroute-cache

no fair-queue

!

interface Serial0/1

bandwidth 2000000

no ip address

no ip mroute-cache

shutdown

!

interface Serial1/0:15

no ip address

encapsulation ppp

load-interval 60

dialer pool-member 1

isdn switch-type primary-net5

!

interface Dialer1

ip unnumbered FastEthernet0/0

ip access-group 101 in

ip nat outside

encapsulation ppp

dialer pool 1

dialer idle-timeout 3500

dialer-group 1

peer default ip address pool isdn

ppp authentication chap

!

ip local pool isdn 172.168.10.200 172.168.10.240

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.200.21

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 172.17.0.0 255.255.0.0 192.168.200.21

ip route 172.168.0.0 255.255.0.0 172.168.10.5

ip http server

ip pim bidir-enable

!

!

access-list 1 permit 172.168.10.0 0.0.0.255

access-list 101 permit ip any any

dialer-list 1 protocol ip list 101

!

line con 0

line aux 0

line vty 0 4

password xxxx

login

!

!

end

1 REPLY
Bronze

Re: Problem in assaining IP address

Hi, are your clients all logging in with the same username?

If so try adding the following commands to your dialer config

ppp ipcp ignore-map

ppp ipcp unique-address

dialer mult-map-same-name (hidden command, won't tab)

Haven't tried them lately, with later IOS it may be that all you need is

ppp ipcp username unique

hth

128
Views
0
Helpful
1
Replies