Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Problem updating IOS via Xmodem

Hello. I've connected to the router via the console port (I've also tried the AUX port). And I can't get an image to upload. I keep getting this error message:

BP-INET1#copy xmodem flash:

Destination filename []? c2600-i-mz.122-17a.bin

Erase flash: before copying? [confirm]n

%Error opening xmodem: (Read-only file system)

I don't get it. I don't see how this router is any different than any other I've updated in this way. Here is another output:

File Systems:

Size(b) Free(b) Type Flags Prefixes

29688 27320 nvram rw nvram:

- - opaque rw null:

- - opaque rw system:

- - opaque ro xmodem:

- - opaque ro ymodem:

- - network rw tftp:

* 8388608 8388608 flash rw flash:

- - opaque wo lex:

- - network rw rcp:

- - network rw ftp:

Also, it's a 2620 router. Any ideas?

Thanks,

-Tim

3 REPLIES
New Member

Re: Problem updating IOS via Xmodem

Oh - and my flash is alrady erased. I've also tried it both ways saying to erase or not erase my flash (which is already gone). And it's on-board flash not a card.

New Member

Re: Problem updating IOS via Xmodem

Is this the first 2600 series router you've tried this on? If so here is the website that goes step by step through the process.

http://www.cisco.com/en/US/customer/products/hw/routers/ps259/products_tech_note09186a008015bfac.shtml

New Member

Re: Problem updating IOS via Xmodem

Yes. But I'm trying to upload it without bringing the router down. So I'm trying to upload via console cable while the router is live. Then I can schedule a reboot for off-hours.

365
Views
0
Helpful
3
Replies
CreatePlease login to create content