Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Problem with 3640 config

I have a 3640 router acting as a remote dialin server for PC clients over two ISDN30 lines. My config is below, I am unable to dial into this router. Can anybody see a problem?

Thanks for your time !

ip address-pool local

isdn switch-type primary-net5

!

controller E1 0/0

pri-group timeslots 1-31

!

controller E1 0/1

pri-group timeslots 1-31

!

!

!

interface Loopback0

ip address 192.168.1.0 255.255.255.255

!

interface FastEthernet0/0

ip address x.x.x.x 255.255.255.252

duplex auto

speed auto

!

interface Serial0/0:15

ip address x.x.x.1 255.255.255.0

encapsulation ppp

dialer-group 1

isdn switch-type primary-net5

isdn incoming-voice modem

!

interface Serial0/1:15

ip address x.x.x.2 255.255.255.0

encapsulation ppp

dialer-group 1

isdn switch-type primary-net5

isdn incoming-voice modem

ppp authentication chap pap

!

interface Group-Async0

ip unnumbered Loopback0

encapsulation ppp

async mode interactive

peer default ip address pool dialin

ppp authentication chap dialins

group-range 33 62

!

interface Group-Async1

ip unnumbered Loopback0

encapsulation ppp

async mode interactive

peer default ip address pool dialin

ppp authentication chap dialins

group-range 65 94

!

interface Dialer0

ip unnumbered Loopback0

encapsulation ppp

no ip mroute-cache

dialer in-band

dialer-group 1

peer default ip address pool dialup

ppp authentication chap

ppp multilink

!

ip local pool dialin x.x.x.2 x.x.x.64

Daniel,

4 REPLIES
Bronze

Re: Problem with 3640 config

If these are modem users, then try adding the following:

interface Serial0/0:15

isdn incoming-voice modem

!

line 33 94

modem dialin

autoselect during-login

autoselect ppp

It looks like you can remove the config for Dialer0, it's not being used.

To troubleshoot, try each of these steps in order

- debug isdn q931 - make sure the calls arrive and are answered

- debug modem - make sure the modems train up and answer

- debug ppp neg - make sure that PPP negotiates and an address is assigned

New Member

Re: Problem with 3640 config

No joy,

Do the serial interfaces look correctly configured to you?

Daniel,

Bronze

Re: Problem with 3640 config

You've never specified if these are async or ISDN users dialing in. If they are async, the only command you need under the serial interfaces is "isdn incoming-voice modem". For sync ISDN users, the configs look fine except that Serial0/0:15 should have PPP authentication enabled.

Again, if you are having problems still you should enable the debugs to see what is going on.

New Member

Re: Problem with 3640 config

Hi,

In the D-channel configuration of your PRI port (Ser0/0:15 and ser0/1:15)

IP processing should not be used.

As Joy said, the modem/line configuration need to be done to allow dialin access.(If you have installed the MICA bank in slot 1 .. line 32-64, slot 1 65-96)

line 32 62

modem DialIn

the following config should work fine for dial in access of Async/ ISDN

interface serial0/0:15

no ip address

encapsulation ppp

dialer-group 1

isdn incoming-voice modem

interface serial0/1:15

no ip address

encapsulation ppp

dialer-group 1

isdn incoming-voice modem

interface Group-Async0

ppp authentication chap pap dialin

group-range 33 62

interface Group-Async1

ppp authentication chap pap dialin

group-range 65 94

line 33 62

autoselect ppp

autoselect during-login

login authentication dialin

modem DialIn

line 65 94

autoselect ppp

autoselect during-login

login authentication dialin

modem DialIn

thanks

100
Views
0
Helpful
4
Replies
CreatePlease login to create content