Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
You may experience some slow load times, errors, and slight inconsistencies. We ask for your patience as we finalize the launch. Thank you.

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Problem with CallBack nm-16am

I do this configuration on my router(2611) but callback does not work.please tell me why?

CAORAS#sh ru

Building configuration...

Current configuration : 3071 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname CAORAS

!

aaa new-model

!

!

aaa authentication login LOCAL local

aaa authentication ppp default none

aaa authentication ppp isputil group radius local

aaa authorization network default none

aaa authorization network isputil group radius local

aaa accounting update newinfo

aaa accounting network default none

aaa accounting network isputil start-stop group radius

aaa session-id common

enable secret xxxxxxxxxxx

enable password xxxxxxxxx

!

username admin password xxxxxxxxxxx

username abtahi callback-dialstring "" password xxxxxxxx

ip subnet-zero

no ip source-route

!

!

ip name-server 192.x.x.3

ip name-server 81.x.x.66

!

!

async-bootp dns-server 192.168.3.3 80.231.163.195

chat-script offhook "" "ATH1" ok

chat-script callback ABORT ERROR ABORT BUSY "" "ATZ" ok "ATDT \T"

timeout 60 co

nect \c

!

!

!

interface Ethernet0/0

ip address 192.168.3.4 255.255.255.0

ip nat outside

half-duplex

!

interface Ethernet0/1

ip address 192.168.0.9 255.255.255.248

ip access-group NAT in

ip nat inside

half-duplex

!

interface Async48

ip unnumbered Ethernet0/0

ip accounting output-packets

encapsulation ppp

ip tcp header-compression passive

no ip mroute-cache

load-interval 60

async mode interactive

peer default ip address pool DIALIN

no fair-queue

ppp max-bad-auth 3

ppp callback accept

ppp authentication chap pap

!

!

ip local pool DIALIN 192.168.3.200 192.168.3.216

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.3.3

ip http server

ip pim bidir-enable

!

!

snmp-server community xxxxx RW

snmp-server community xxxxx RW

radius-server host 192.168.3.2 auth-port 2228 acct-port 2229

radius-server retransmit 5

radius-server timeout 15

radius-server key xxxxxxxxxxx

!

line con 0

exec-timeout 0 0

password xxxxxxxxxxxxx

line 48

script modem-off-hook offhook

script callback callback

login authentication LOCAL

modem InOut

transport input all

autoselect during-login

autoselect ppp

callback forced-wait 10

line aux 0

line vty 0 4

password xxxxxxxxxxxxx

!

!

end

  • Other Network Infrastructure Subjects
8 REPLIES
Cisco Employee

Re: Problem with CallBack nm-16am

We need more information. 1)who is dialin in with what kind of PC etc 2)how you want to configure callback 1) via router b) via AAA server. 3)Is PC configured properly for callback.

Now looking on the config you have posted, its not clear. You can visit following link for Configuring MS Callback via router Between a Router and a Windows PC

http://www.cisco.com/en/US/tech/tk801/tk36/technologies_configuration_example09186a0080094338.shtml

So if that doesn't work, we need to see the following debug from router for a call and post it here

debug modem

debug ppp negotiation

debug aaa authentication

debug aaa authorization

debug ppp negotiations

debug ppp cbcp

debug callback

Also if you want callback using AAA server, visit

http://cco/en/US/products/sw/secursw/ps2086/products_configuration_example09186a008009404f.shtml

New Member

Re: Problem with CallBack nm-16am

Hi

thanks about your help.I must to say that I want to configure only one of async port (example async 48) to accept callback from local user account on my router and reject all other incoming dial-in from AAA server.I want to use a Windows XP to dialin and my callback number must be asked before performing dialing proccess from router.

I have enabled my pc to accept callback but nothing happend.

thanks

Cisco Employee

Re: Problem with CallBack nm-16am

As i have mentioned, we need to see the debugs when you dialin. So post the debugs for a call here.

Cisco Employee

Re: Problem with CallBack nm-16am

If you want the router to ask you the callback number, use "ppp callback permit" on the interface.

As Tejal mentioned, we need to see the requested debugs to see why callback is not working.

~Zulfi

New Member

Re: Problem with CallBack nm-16am

I've found my problem with debug commands and could solve it.My problem was about Authorization in AAA configuration after config it my callback worked.

New Member

Re: Problem with CallBack nm-16am

Hi Ahmad

I saw your mail on the Cisco’s Discussion Forum site. You had problem with implementing callback at 2610. I have same problem with 3525 and NM-8AM v2. Would you please let me know how you solved the problem. Do you have any suggestion. I have heard about the same problem from some friends. Some of them changed the IOS and solved. Some of them couldn’t solve it. I have tried with IOS 12.3.4 (XD), 12.3.4 (XD1), 12.3.4 (XD3) and 12.3.7 (T2). No response. As you defined, when you remove ppp callback accept command, everything is fine connecting to the 3725.

If you have any suggestion about another topic I will be grateful. I am trying to connect Nokia30 GSM modem to the 3725 Asycn port. (NM-8A/S)

But I couldn’t .

Thanks.

You can use my email hulusi.turgut@servus.com.tr

New Member

Re: Problem with CallBack nm-16am

Hi JMCNIERNEY

Did you get a result on the PPP Callback on your 3725.

I have a similar issue on a 3745 with Group Async interface and PRI. I have had various issues and each IOS has moved the fault along without fixing it.

Now IOS mz.123-10 Callback is offered to Users however will not dial back. Outgoing call is rejected. Have you had any success.

Many thanks

Larry_s

Silver

Re: Problem with CallBack nm-16am

If you are seeing this issue on various IOS images then I will definitely want to try this out in my lab & maybe raise a bug if need be. Can you please post the running configuration (where the callback fails) & the sh ver.

1. Are you configured for callback thru AAA? If yes, can you try locally?

2. If this is MS callback, what is the OS on the PC?

3. If it’s a modem connected to Router as a callback client & 3745 as the callback server then like to know the modem make/ router make?

Thanks, Mak

149
Views
5
Helpful
8
Replies