Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

problem with cisco 801

Hello,

i have a problem with a cisco 801 that cannot connect to internet. The

configuration is the following:

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname central1

!

no logging console

enable secret --------

enable password -------

!

username remote password 0 remote

ip subnet-zero

!

no ip domain-lookup

isdn switch-type basic-net3

!

!

!

interface Ethernet0

ip address 192.100.102.254 255.255.255.0

ip nat inside

no cdp enable

!

interface BRI0

timeout absolute 2

no ip address

encapsulation ppp

dialer pool-member 1

dialer pool-member 2

isdn switch-type basic-net3

no cdp enable

ppp authentication chap pap callin

!

interface Dialer1

description LIGACAO A INTERNET

ip address negotiated

ip nat outside

encapsulation ppp

dialer idle-timeout 240

timeout absolute 2

dialer pool 1

dialer remote-name Telepac

dialer idle-timeout 240

dialer string 671715000

no cdp enable

ppp authentication pap callin

ppp pap sent-username ------ password -----

!

interface Dialer2

description LIGACAO AO ESCRITORIO REMOTO

ip address 192.168.18.2 255.255.255.252

ip nat inside

dialer idle-timeout 240

timeout absolute 2

encapsulation ppp

dialer pool 2

dialer remote-name remote

dialer string ------

no cdp enable

ppp authentication chap callin

!

router rip

network 192.100.102.0

network 192.168.18.0

!

ip nat translation timeout 240

ip nat translation tcp-timeout 240

ip nat translation udp-timeout 240

ip nat inside source list 101 interface Dialer1 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 192.100.100.0 255.255.255.0 Dialer2

no ip http server

!

!

no cdp run

!

line con 0

exec-timeout 3 0

stopbits 1

line vty 0 4

exec-timeout 3 0

password rcmadetel

login

!

no rcapi server

!

!

end

This configuration was working and the connection configured in dialer2 is

working.

The username and password in the ISP are correct, and the connection is

establihed.

The debug log indicates me that the problem is during the PPP negotiation.

The log is the following:

*Mar 1 00:07:11.999: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up

*Mar 1 00:07:12.095: %DIALER-6-BIND: Interface BR0:1 bound to profile BR0

*Mar 1 00:07:12.155: BR0:1 PPP: Treating connection as a callout

*Mar 1 00:07:12.167: BR0:1 PPP: Phase is ESTABLISHING, Active Open [0 sess,

0 load]

*Mar 1 00:07:12.183: BR0:1 PPP: No remote authentication for call-out

*Mar 1 00:07:12.219: BR0:1 LCP: O CONFREQ [Closed] id 11 len 10

*Mar 1 00:07:12.223: BR0:1 LCP: MagicNumber 0xB0C923D0 (0x0506B0C923D0)

*Mar 1 00:07:12.251: ISDN BR0: Event: Connected to 671715000 on B1 at 64

Kb/s

*Mar 1 00:07:12.255: ISDN Error: Illegal Interface BR0:1

*Mar 1 00:07:12.255: ISDN Error: Illegal Interface BR0:1

*Mar 1 00:07:12.259: ISDN BR0: TX -> CONNECT_ACK pd = 8 callref = 0x03

*Mar 1 00:07:13.255: S7_T200_EXPIRY VA = 1, VS = 2

I don't understand the meaning of ISDN Error: Illegal Interface BR0:1.

I search in Cisco forums but i didn't found anything.

Can you help me? Thank you.

Best regards

Nuno Moniz

Departamento de Hardware

Email: nuno.moniz@ricmade.pt

2 REPLIES
Bronze

Re: problem with cisco 801

Since you are saying that this config was working, just wondering if the problem is related to one of the B-channels. Since it shows that it uses 64Kbps as speed, try with 56 Kbps or confirm with the service provider if anything has changed. You can also try to see if you get any hint from 'debug isdn q931'. There are few bugs in IOS related to this message. If you have access to Bug toolkit, check out whether there is any bug related to this in the image that you are using. You config does not show the 'dialer-list and 'dialer-group' commands being used. I hope you have them, but not pasted it here.

Cisco Employee

Re: problem with cisco 801

First you need to add "dialer-group 1" under both the dialer interface and also add "dialer-list 1 protocol ip permit" in the global config.

After that we need to see the debug for following only to see how ppp negotiation have went through and what is the issue.

debug dialer

debug ppp nego

debug ppp auth

debug isdn q931

So pl. post the debug for a callout for review.

147
Views
0
Helpful
2
Replies