Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Problem with HSRP and Asymetric Routing.

Hello,

I search feedback about the problem HSRP and Asymetric Routing (

description here : http://www.cisco.com/en/US/tech/tk648/tk365/technologies_tech_note09186a0080094afd.shtml#t8 )

I want more details about symptoms and the solution apply in compliance with Cisco.

I think I have this problem in network customer.

(When we activate HSRP, all

network VLAN slow down , we have got duplicate packets and broadcast/multicast storm and when we desactivate HSRP it is OK.)

Thanks for Your reply.

2 REPLIES
New Member

Re: Problem with HSRP and Asymetric Routing.

Without posting your configs, it is impossible to determine where an error might be. Post those, and we can take a look.

-Bo

New Member

Re: Problem with HSRP and Asymetric Routing.

Thank you for your answer,sorry for my late anwser.

Here are the interesting configuration on both 4000 :

Last IOS version on 4232 : cat4232-in-mz.120-18.W5.22b.bin

CatOs Version 4000 : cat4000.6-3-4a.bin

On the two 4000 : there are 10 Vlan.

Interesting Configuration L2 on interface 4000A

#vlan

set spantree priority 10 1

set spantree priority 30 2

set spantree priority 10 8

set spantree priority 30 12

set spantree priority 10 16

set spantree priority 30 20

set spantree priority 10 24

set spantree priority 30 244

set spantree priority 10 248

set spantree priority 30 252

set spantree enable 1003

set spantree fwddelay 4 1003

set spantree hello 2 1003

set spantree maxage 10 1003

set spantree priority 32768 1003

set spantree enable 1005

set spantree fwddelay 4 1005

set spantree hello 2 1005

set spantree maxage 10 1005

set spantree priority 32768 1005

#vlan(defaults)

set spantree enable 1-2,8,12,16,20,24,244,248,252

set spantree fwddelay 15 1-2,8,12,16,20,24,244,248,252

set spantree hello 2 1-2,8,12,16,20,24,244,248,252

set spantree maxage 20 1-2,8,12,16,20,24,244,248,252

set cam agingtime 1-2,8,12,16,20,24,244,248,252,1003,1005 300

Interesting Configuration L2 on interface 4000B

set spantree priority 30 1

set spantree priority 30 8

set spantree priority 10 12

set spantree priority 30 16

set spantree priority 10 20

set spantree priority 30 24

set spantree priority 10 244

set spantree priority 30 248

set spantree priority 10 252

!

Configuration L3 on interface 4000A

interface Port-channel1

no ip address

no ip redirects

no ip directed-broadcast

hold-queue 300 in

!

interface Port-channel1.1

encapsulation dot1Q 1 native

ip address X.X.1.(X1.1a) 255.0.0.0

no ip redirects

no ip directed-broadcast

standby 255 priority 100

standby 255 preempt

standby 255 ip Y.Y.1.(Y1.1)

!

interface Port-channel1.2

encapsulation dot1Q 2

ip address X.X.2.(X1.2a) 255.255.255.0

no ip redirects

no ip directed-broadcast

standby 2 priority 90

standby 2 preempt

standby 2 ip Y.Y.2.(Y1.2)

!

interface Port-channel1.8

encapsulation dot1Q 8

ip address X.X.8.(X1.8a) 255.255.252.0

no ip redirects

no ip directed-broadcast

standby 8 priority 100

standby 8 preempt

standby 8 ip Y.Y.8.(Y1.8)

!

interface Port-channel1.12

encapsulation dot1Q 12

ip address X.X.12.(X1.12a) 255.255.252.0

no ip redirects

no ip directed-broadcast

standby 12 priority 90

standby 12 preempt

standby 12 ip Y.Y.12.(Y1.12)

!

interface Port-channel1.16

encapsulation dot1Q 16

ip address X.X.16.(X1.16a) 255.255.252.0

no ip redirects

no ip directed-broadcast

standby 16 priority 100

standby 16 preempt

standby 16 ip Y.Y.16.(Y1.16)

!

interface Port-channel1.20

encapsulation dot1Q 20

ip address X.X.20.(X1.20a)1 255.255.252.0

no ip redirects

no ip directed-broadcast

standby 20 priority 90

standby 20 preempt

standby 20 ip Y.Y.20.(Y1.20)

!

interface Port-channel1.24

encapsulation dot1Q 24

ip address X.X.24.(X1.24a) 255.255.252.0

no ip redirects

no ip directed-broadcast

standby 24 priority 100

standby 24 preempt

standby 24 ip Y.Y.24.(Y1.24)

!

interface Port-channel1.244

encapsulation dot1Q 244

ip address X.X.244.(X1.244a) 255.255.252.0

no ip redirects

no ip directed-broadcast

standby 244 priority 90

standby 244 preempt

standby 244 ip Y.Y.244.(Y1.244)

!

interface Port-channel1.248

encapsulation dot1Q 248

ip address X.X.248.(X1.248a) 255.255.252.0

no ip redirects

no ip directed-broadcast

standby 248 priority 100

standby 248 preempt

standby 248 ip Y.Y.248.(Y1.248)

!

interface Port-channel1.252

encapsulation dot1Q 252

ip address X.X.252.(X1.252a) 255.255.252.0

no ip redirects

no ip directed-broadcast

standby 252 priority 90

standby 252 preempt

standby 252 ip Y.Y.252.(Y1.252)

!

Configuration L3 on interface 4000B

interface Port-channel1

no ip address

no ip directed-broadcast

hold-queue 300 in

!

interface Port-channel1.1

encapsulation dot1Q 1 native

ip address X.X.1.(X1.1b) 255.0.0.0

no ip redirects

no ip directed-broadcast

shutdown

standby 255 priority 90 preempt

standby 255 ip Y.Y.1.(Y1.1)

!

interface Port-channel1.8

encapsulation dot1Q 8

ip address X.X.8.(X1.8b) 255.255.252.0

no ip redirects

no ip directed-broadcast

shutdown

standby 8 priority 90 preempt

standby 8 ip Y.Y.8.(Y1.8)

!

interface Port-channel1.12

encapsulation dot1Q 12

ip address X.X.12.(X1.12b) 255.255.252.0

no ip redirects

no ip directed-broadcast

shutdown

standby 12 priority 100 preempt

standby 12 ip Y.Y.12.(Y1.12)

!

interface Port-channel1.16

encapsulation dot1Q 16

ip address X.X.16.(X1.16b) 255.255.252.0

no ip redirects

no ip directed-broadcast

shutdown

standby 16 priority 90 preempt

standby 16 ip Y.Y.16.(Y1.16)

!

interface Port-channel1.20

encapsulation dot1Q 20

ip address X.X.20.(X1.20b) 255.255.252.0

no ip redirects

no ip directed-broadcast

shutdown

standby 20 priority 100 preempt

standby 20 ip Y.Y.20.(Y1.20)

!

interface Port-channel1.24

encapsulation dot1Q 24

ip address X.X.24.(X1.24b) 255.255.252.0

no ip redirects

no ip directed-broadcast

shutdown

standby 24 priority 90 preempt

standby 24 ip Y.Y.24.(Y1.24)

!

interface Port-channel1.244

encapsulation dot1Q 244

ip address X.X.244.(X1.244b) 255.255.252.0

no ip redirects

no ip directed-broadcast

shutdown

standby 244 priority 100 preempt

standby 244 ip Y.Y.244.(Y1.244)

!

interface Port-channel1.248

encapsulation dot1Q 248

ip address X.X.248.(X1.248b) 255.255.252.0

no ip redirects

no ip directed-broadcast

shutdown

standby 248 priority 90 preempt

standby 248 ip Y.Y.248.(Y1.248)

!

interface Port-channel1.252

encapsulation dot1Q 252

ip address X.X.252.(X1.252b) 255.255.252.0

no ip redirects

no ip directed-broadcast

shutdown

standby 252 priority 100 preempt

standby 252 ip Y.Y.252.(Y1.252)

!

HSRP is active on 4000A (interface no shutdown)

HSRP is not active on 4000B (interface shutdown)

What's happen ?

When we reactivate HSRP on 4000B (no shutdown all interfaces)

We have asymetric routing.

Symptoms on the network :

-> Slow network.

-> Packets duplicate.

-> Broadcast / multicast Storm.

-> Cpu increase on others routers.

-> Crazy Hosts.

When we desactivate HSRP on 4000B (shutdown all interfaces)

All becomes good.

All ideas are welcome.

99
Views
0
Helpful
2
Replies