Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Problem with ISDN-TA X.75 conntection to a c3640

Hi, I `ve got a problem with a remote access connection with a ISDN TA x.75

(no ppp authentication) to a c3640 access router. Below you can see the configuration and the debug output thanks for your help.

hostname tpie1o

!

enable password 7 00011512005219030C35

!

modem country mica switzerland

ip subnet-zero

!

!

!

ip address-pool local

vty-async

vty-async keepalive 0

vty-async virtual-template 1

isdn switch-type primary-net5

call rsvp-sync

!

!

!

!

!

!

controller E1 0/0

pri-group timeslots 1-31

description ISDN PRI 031-305 18 64

!

controller E1 0/1

!

!

!

interface Loopback0

ip address 172.22.5.22 255.255.255.255

!

interface Loopback1

description default-gateway for ppp users

ip address 172.22.216.129 255.255.255.192

!

interface Serial0/0:15

no ip address

encapsulation ppp

ip tcp header-compression passive

dialer rotary-group 1

autodetect encapsulation ppp v120 lapb-ta

isdn switch-type primary-net5

isdn incoming-voice modem 64

no cdp enable

!

interface Serial1/0

no ip address

shutdown

serial restart-delay 0

!

interface Serial1/1

no ip address

shutdown

serial restart-delay 0

!

interface Serial1/2

no ip address

shutdown

serial restart-delay 0

!

interface Serial1/3

no ip address

shutdown

serial restart-delay 0

!

interface FastEthernet2/0

ip address 172.22.220.10 255.255.255.0

speed 100

full-duplex

!

interface Virtual-Template1

ip unnumbered Loopback1

ip tcp header-compression

autodetect encapsulation ppp

peer default ip address pool eft2000

!

interface Group-Async1

ip unnumbered Loopback1

encapsulation ppp

ip tcp header-compression

no ip mroute-cache

async mode interactive

peer default ip address pool eft2000

group-range 97 126

!

interface Dialer1

ip unnumbered Loopback1

encapsulation ppp

ip tcp header-compression passive

dialer in-band

dialer-group 1

peer default ip address pool eft2000

no cdp enable

!

ip local pool eft2000 172.22.216.130 172.22.216.190

ip classless

ip route 0.0.0.0 0.0.0.0 172.22.220.254

ip http server

ip pim bidir-enable

!

dialer-list 1 protocol ip permit

!

!

dial-peer cor custom

!

!

!

!

line con 0

line 97 126

flush-at-activation

modem InOut

autoselect during-login

autoselect ppp

line aux 0

line vty 0 4

password 7 0603093548471B1C0603

login

transport input telnet

line vty 5 34

exec-timeout 0 0

no login

rotary 1

autocommand ppp neg

transport input v120 lapb-ta

autoselect ppp

!

end

tpie1o#sh deb

LAPB Terminal Adapter:

LAPB TA events debugging is on

PPP:

PPP protocol negotiation debugging is on

ISDN:

ISDN Q931 packets debugging is on

ISDN Q931 packets debug DSLs. (On/Off/No DSL:1/0/-)

DSL 0 --> 31

1 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

tpie1o#

19:42:14: ISDN Se0/0:15: RX <- SETUP pd = 8 callref = 0x0110

19:42:14: Sending Complete

19:42:14: Bearer Capability i = 0x8890

19:42:14: Channel ID i = 0xA98396

19:42:14: Calling Party Number i = 0x01, 0x83, '0319140470', Plan:ISDN,n

19:42:14: %LINK-3-UPDOWN: Interface Serial0/0:21, changed state to up

19:42:14: ISDN Se0/0:15: TX -> CALL_PROC pd = 8 callref = 0x8110

19:42:14: Channel ID i = 0xA98396

19:42:14: ISDN Se0/0:15: TX -> CONNECT pd = 8 callref = 0x8110

19:42:14: Channel ID i = 0xA98396

19:42:14: ISDN Se0/0:15: RX <- CONNECT_ACK pd = 8 callref = 0x0110

19:42:14: ISDN Se0/0:15: CALL_PROGRESS: CALL_CONNECTED call id 0x15, bchan 21, 0

19:42:14: LAPB-TA: Autodetect trying to detect LAPB on Se0/0:21

19:42:14: sampled pkt: 2 bytes: 1 3F.. match

19:42:14: LAPBTA: get_ll_config: Serial0/0:21

19:42:14: LAPBTA135: vty allocated for Se0/0:21

19:42:14: LAPBTA135: process 98

19:42:14: Se0/0:21: LAPB-TA started

19:42:14: LAPBTA: service change: LAPB physical layer up, context 6272B658 inten

19:42:14: LAPBTA: service change: , context 6272B658 up

19:42:14: Vi2 PPP: Phase is DOWN, Setup [0 sess, 1 load]

19:42:14: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up

19:42:14: Vi2 PPP: Treating connection as a dedicated line

19:42:14: Vi2 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load]

19:42:14: Vi2 LCP: O CONFREQ [Closed] id 1 len 20

19:42:14: Vi2 LCP: ACCM 0x000A0000 (0x0206000A0000)

19:42:14: Vi2 LCP: MagicNumber 0xE458B818 (0x0506E458B818)

19:42:14: Vi2 LCP: PFC (0x0702)

19:42:14: Vi2 LCP: ACFC (0x0802)

19:42:14: LAPBTA: cfg_idb Serial0/0:21

19:42:15: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0:21, changedp

19:42:16: Vi2 LCP: TIMEout: State REQsent

19:42:16: Vi2 LCP: O CONFREQ [REQsent] id 2 len 20

19:42:16: Vi2 LCP: ACCM 0x000A0000 (0x0206000A0000)

19:42:16: Vi2 LCP: MagicNumber 0xE458B818 (0x0506E458B818)

19:42:16: Vi2 LCP: PFC (0x0702)

19:42:16: Vi2 LCP: ACFC (0x0802)

19:42:18: Vi2 LCP: TIMEout: State REQsent

19:42:18: Vi2 LCP: O CONFREQ [REQsent] id 3 len 20

19:42:18: Vi2 LCP: ACCM 0x000A0000 (0x0206000A0000)

19:42:18: Vi2 LCP: MagicNumber 0xE458B818 (0x0506E458B818)

19:42:18: Vi2 LCP: PFC (0x0702)

19:42:18: Vi2 LCP: ACFC (0x0802)

19:42:19: ISDN Se0/0:15: RX <- DISCONNECT pd = 8 callref = 0x0110

19:42:19: Cause i = 0x8090 - Normal call clearing

19:42:19: %ISDN-6-CONNECT: Interface Serial0/0:21 is now connected to 031914047

19:42:19: %ISDN-6-DISCONNECT: Interface Serial0/0:21 disconnected from 0319140s

19:42:19: %LINK-3-UPDOWN: Interface Serial0/0:21, changed state to down

19:42:19: LAPBTA: service change: LAPB physical layer down, context 6272B658 inn

19:42:19: LAPBTA: stop 6272B658 line 135

19:42:19: LAPBTA135: stopped, removing lapb, disconnecting

19:42:19: LAPBTA: removing context 6272B658

19:42:19: ISDN Se0/0:15: TX -> RELEASE pd = 8 callref = 0x8110

19:42:19: %LINK-5-CHANGED: Interface Virtual-Access2, changed state to reset

19:42:19: Vi2 LCP: State is Closed

19:42:19: Vi2 PPP: Phase is DOWN [0 sess, 1 load]

19:42:19: LAPBTA: close 6287E94C, line 135

19:42:19: ISDN Se0/0:15: RX <- RELEASE_COMP pd = 8 callref = 0x0110

19:42:19: Vi2 IPCP: Remove route to 172.22.216.147

19:42:19: Vi2 LCP: State is Closed

19:42:19: Vi2 LCP: State is Closed

19:42:20: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0:21, changedn

tpie1o#

1 REPLY
Bronze

Re: Problem with ISDN-TA X.75 conntection to a c3640

I'm not sure where the problem is, although I suspect the telco initially. We send out LCP CONFREQ packets, but do not receive in any data. Then 5 seconds after the connection was established the remote end tears it down. Your config looks OK, with the exception of the "autocommand" under the virtual-template interface; normally that command only applies to the physical interfaces. I would suggest you try to confirm if the remote dialin client is receiving any of the PPP packets that the cisco is sending out. This link here may help some, too:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/dialts_c/dtsprt3/dcdvtyas.htm

101
Views
0
Helpful
1
Replies
CreatePlease to create content