Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

problem with NAT on 2600

We can't get any translations to show on our router when connecting from the outside. I was looking at the config and was wondering if the sub-interface portion was correct. I am curius to know that if I put an IP on fa0/1 (instead of fa0/1.1) if this works the same way? below is a snippet of what I am talking about.

interface FastEthernet0/1

description LAN Interface to CJF

ip address xxx

ip access-group 103 in

ip access-group 103 out

ip nat outside

no ip mroute-cache

duplex auto

speed auto

!

interface FastEthernet0/1.2

encapsulation dot1Q 3

ip address xxx

ip helper-address 10.100.1.28

no ip redirects

ip nat inside source statice "local IP" "outside IP" extendable

4 REPLIES

Re: problem with NAT on 2600

What you get by putting an IP on the interface is a connection with the native vlan.

This will only work when the other side also supports packets -without- dot1Q encapsulation.

Regards,

Leo

New Member

Re: problem with NAT on 2600

Ok. Then 1 more question. Is it possible to do a static NAT translation to an IP that is not defined on an interface? Does the below configuration work?

interface FastEthernet0/0

description WAN Interface To Wireless

ip address 192.168.20.1 255.255.255.0

ip access-group 100 in

ip access-group 100 out

no ip mroute-cache

duplex auto

speed auto

!

interface Serial0/0

ip address 192.168.253.250 255.255.255.252

ip nat inside

!

interface FastEthernet0/1

description LAN Interface to CJF

ip address 10.100.112.1 255.255.248.0

ip access-group 103 in

ip access-group 103 out

ip nat outside

no ip mroute-cache

duplex auto

speed auto

!

interface FastEthernet0/1.2

encapsulation dot1Q 3

ip address 10.100.128.1 255.255.248.0

ip helper-address 10.100.1.28

no ip redirects

ip nat inside source static 172.16.1.3 10.100.112.10 extendable

all I see in the nat table is the following:

HCJFROUTER#sh ip nat translations

Pro Inside global Inside local Outside local Outside global

--- 10.100.112.10 172.16.1.3 --- ---

I am trying to figure out why I can't NAT and reach 172.16.1.3 when going to 10.100.112.10

Re: problem with NAT on 2600

You have to have 2 interfaces doing nat if you want to nat. An inside and an outside. You do not have ip nat inside on any interface. To do natting you must go from one nat interface to another nat interface. Look at the example links I sent previously. This example config you are showing us will not do any nat. I do not think the ip nat inside source will even work properly without a "ip nat inside" on an interface that it is set up for.

If this helps please rate.

Mike

Re: problem with NAT on 2600

This configuration is in complete. Here is a link that can get you started.

http://www.cisco.com/en/US/customer/tech/tk648/tk361/technologies_configuration_example09186a0080093f8e.shtml

This TAC case has an example for extendable use.

http://www.ciscotaccc.com/iprout/showcase?case=K75019454

121
Views
0
Helpful
4
Replies
CreatePlease login to create content