Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

kvc
New Member

Problem with NAT to two differnt ISP's

Hi,

I have a router with a serial and an isdn port.

Both the ports are connected to two differnt isp's.

I have to implement NAT in both the cases. I am using ISDN as a backup to my serial link. So i want a particular set of nat to happen when serial is down and another set when when it is up.

the following is the config which i wanted.

int s0

ip address 200.1.1.2 255.255.255.248

ip nat outside

int bri0

ip address negotiated

ip nat outside

int e0

ip nat inside

ip nat inside source list 5 interface serial0 overlo

ip nat inside source list 6 interfade bri0 overload

access-list 5 permit any

access-list 6 permit any

But when i use the above statements eventhough my serial0 is down the router is still using the first nat statements only, and i am unable to access net.

Please suggest what changes should i make or is there any other alternative

1 REPLY

Re: Problem with NAT to two differnt ISP's

Hello

ip nat inside source route-map test1 interface serial0 overlo

ip nat inside source route-map test2 interfade bri0 overload

route-map test1

match interface serial0

route-map test1

match interface bri0

or you can use ip nex-hop matching.

78
Views
0
Helpful
1
Replies