Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Problem with STP on redundant Catalyst 3550

Hi all,

i have the szenario below:

Cat1(EMI) Cat2(EMI)

----------------------- ---------------------

I 3550 I------I 3550 I

------------------------ ----------------------

FE0/5 FE0/5

I I

I I

-----------------------

I 3COM I

-----------------------

Config Cat1 Config Cat2

spanning-tree vlan 3 priority 20480 spanning-tree vlan 3 priority 28672

interface FastEthernet0/5

switchport access vlan 3

switchport trunk encapsulation dot1q ................................................ how on Cat1

no ip address

no cdp enable

If i power on the cat2 Switch, FE0/5 on Cat1 go in BLK-Mode and i receive

the message:

5w6d: %SPANTREE-7-RECV_1Q_NON_TRUNK: Received 802.1Q BPDU on non trunk FastEthernet0/8 VLAN3.

5w6d: %SPANTREE-7-BLOCK_PORT_TYPE: Blocking FastEthernet0/5 on VLAN0003. Inconsistent port type.

Can anybody tell me what is my problem?

Has anybody an example configuration for Catalyst 3550 with 3Com?

Thanks in advance

Lorenz

3 REPLIES
Bronze

Re: Problem with STP on redundant Catalyst 3550

Probably caused by misconfiguration. You might want to try the following:

[Cat1]

interface FastEthernet0/5

switchport mode trunk

switchport trunk encapsulation dot1q

switchport allowed vlan add 3

switchport trunk native vlan 3

HTH.

New Member

Re: Problem with STP on redundant Catalyst 3550

Hi A.Manosca,

first once thank you for the fast answer.

When i use the parameter "switchport allowed vlan add 3 ", than this

interface get information for the vlan 3 only?

What have to i configure on the 3Com?

Is the parameter "switchport trunk native vlan 3 " necessary?

Thanks,

Lorenz

Bronze

Re: Problem with STP on redundant Catalyst 3550

Yes, the "switchport trunk allowed vlan add 3" command should be used if you

only want to allow vlan 3 to pass through the trunk. But you have to

explicitly disable other vlans. For example:

switchport allowed vlan remove 2,4-4094

and if you want to add other vlans, just use the 'add' option.

The command "switchport trunk native vlan 3" is used if you want to set

the native vlan of the trunk port to VLAN 3. All untagged traffic will

use VLAN 3. The default is VLAN 1.

As for you question about 3COM, sorry but I'm not familiar with 3COM

switches. But I'm sure there are documentations that could help.

Specifying your objective for this setup will help.

79
Views
0
Helpful
3
Replies