Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Problem with vtp trunk between Catalyst 5000 and 2900XL

I need to establish a vlan connection between two PCs being connected to the network as shown below:

PC1 <=link1=> WS-C2924C-XL <=link2=> WS-C5000 <=link3=> WS-C2924-XL-EN <=link4=> PC2

WS-C2924C-XL is running "IOS (tm) C2900XL Software (C2900XL-HS-M), Version 11.2(8.10)SA6, MAINTENANCE INTERIM SOFTWARE" (show version)

WS-C2924-XL-EN is running "IOS (tm) C2900xl Software (C2900xl-C3H2S-M), Version 12.0(5)WC5, RELEASE SOFTWARE (fc1)"

WS-C5000 is running "WS-C5000 Software, Version McpSW: 4.1(2) NmpSW: 4.1(2)"

As I understand it is neccessary to configure a VTP trunks on links 2 and 3, but while I successfuly turned on the trunk on the link 3 (isl, nonegotiate) I couldn't do the same on the link 2. I just couldn't find apropriate commands to turn trunking on - there is no "switchport mode trunk" command on the WS-C2924C-XL switch. It has "switchport mode access" and "switchport mode multi" only. But why?

Nickolay

  • Other Network Infrastructure Subjects
9 REPLIES

Re: Problem with vtp trunk between Catalyst 5000 and 2900XL

Hi,

I think you need to upgrade your WS-C2924C-XL.

trunking should be available since IOS 11.2(8)SA4 (-EN).

But I'd recommend to use the latest IOS your hardware is able to support (depends on the memory size, check with IOS upgrade Planner http://www.cisco.com/cgi-bin/Software/Iosplanner/Planner-tool/iosplanner.cgi).

Regards,

Milan

New Member

Re: Problem with vtp trunk between Catalyst 5000 and 2900XL

Milan, thanks for your response, but unfortunately I have no access to this tool :(

Could you please help me to choose right IOS version for my switch? Your help will be very much appreciated.

Below is full output of "show version" command:

===============

Cisco Internetwork Operating System Software

IOS (tm) C2900XL Software (C2900XL-HS-M), Version 11.2(8.10)SA6, MAINTENANCE INTERIM SOFTWARE

Copyright (c) 1986-1902 by cisco Systems, Inc.

Compiled Fri 15-Feb-02 09:47 by devgoyal

Image text-base: 0x00003000, data-base: 0x0020E278

ROM: Bootstrap program is C2900XL boot loader

Switch uptime is 1 day, 14 hours, 12 minutes

System restarted by reload

System image file is "flash:c2900XL-hs-mz-112.8.10-SA6.bin", booted via show

cisco WS-C2924C-XL (PowerPC403GA) processor (revision 0x11) with 4096K/640K bytes of memory.

Processor board ID 0x09, with hardware revision 0x00

Last reset from warm-reset

Processor is running Enterprise Edition Software

Cluster member switch capable

24 Ethernet/IEEE 802.3 interface(s)

32K bytes of flash-simulated non-volatile configuration memory.

Base ethernet MAC Address: 00:90:B1:B4:D5:00

Motherboard assembly number: 73-2911-06

Motherboard serial number: FAA0242A0QQ

System serial number: FAA0242Z13H

Configuration register is 0xF

================

Regards,

Nickolay

New Member

Re: Problem with vtp trunk between Catalyst 5000 and 2900XL

You will have to buy an upgrade from cisco which can be rather expensive..

you could always try and copy the image from your other switch to the one needing the upgrade.

Re: Problem with vtp trunk between Catalyst 5000 and 2900XL

Nikolay,

I've found the tool doesn't contain these obsolete IOS versions anymore.

But there should be 11.2.8.11.SA6 IOS available on http://www.cisco.com/cgi-bin/tablebuild.pl/cat2900XL-4MB.

According to Release Notes

http://www.cisco.com/univercd/cc/td/doc/product/lan/c2900xl/29_35sa6/ol467301.htm

http://www.cisco.com/univercd/cc/td/doc/product/lan/c2900xl/29_35sa6/ol033202.htm

this should be the right software for you.

Regards,

Milan

New Member

Re: Problem with vtp trunk between Catalyst 5000 and 2900XL

Milan,

I am not very familiar with Cisco but having read this document (http://www.cisco.com/univercd/cc/td/doc/product/lan/c2900xl/29_35sa6/ol033202.htm#23219) I have found out that my hardware probably doesn't support VTP trunking at all (see the footnote under the Table 3). Am I right?

Regards,

Nickolay

New Member

Re: Problem with vtp trunk between Catalyst 5000 and 2900XL

In addition to my previous posting

Under this link http://www.cisco.com/en/US/tech/tk389/tk390/technologies_tech_note09186a008017f86a.shtml#subtopic2h I've found that 4 MB Catalyst 2900XL series switches do not support trunking and here http://www.cisco.com/en/US/products/hw/switches/ps637/prod_release_note09186a00800d8af7.html#xtocid7 I've found that there are modules for 2900 which support trunking but my hardware does not expandable by these modules.

It seems there is nothing to do except buying new switch.

:(((

Milan, thank you very much!

New Member

Re: Problem with vtp trunk between Catalyst 5000 and 2900XL

Hi,

In the section of your above document "Minimum IOS Release for Major Features" it gives the minimum IOS version to support ISL and 802.1q trunking. Please re-check and upgrade your IOS. The software can be downloaded for free even for non-registered users.

New Member

Re: Problem with vtp trunk between Catalyst 5000 and 2900XL

Just read from the doc that 4 Mb 2900 doesnt support Trunking. You need to have 8 Mb 2900 with 12.0 IOS to do trunking.Ignore my last posting.

Re: Problem with vtp trunk between Catalyst 5000 and 2900XL

I agree.

These 5-years-old documents are not 100% reliable.

I'd try to upgrade to latest available IOS (it fixes some security bugs, at least) before spending money for a new switch..

If you find it useless for any reason, you can downgrade back in no price. (Backup the current IOS file first.)

Regards,

Milan

131
Views
0
Helpful
9
Replies