Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

problem with xmodem

hello

i tried to download via xmodem, a software file to a cisco switch 2924MXL.

however it fails (xmodem I/O error).

it seems to be i haven't access to the flash: because when i tried to make a new folder (mkdir) the switch rely by "access denied". but i can delete the env_var file !

I wonder if i can change any variable to have full access to the flash? or is it the flash that is damaged?

thanks for your help

5 REPLIES
Cisco Employee

Re: problem with xmodem

Issues with Xmodem can be wide spread. I'll give you some suggestions that I've seen solve these types fo problems in the past (you may have already tried these).

Don't know if you've seen this link:

http://www.cisco.com/en/US/products/hw/switches/ps607/products_installation_and_configuration_guide_chapter09186a008007d323.html#xtocid56836

Pretty good step by step for recovery on 2900XLs. See the section entitled "Recovering from Corrupted Software"

Other things you can try using:

-Different PC/laptop

-Different terminal emulation software program (hypertermial, etc)

-verify that the image being used is the correct file size, etc. May even want to try downloading a fresh copy of the image from Cisco.com.

If you are still having problems with the flash after trying the above, please reply back.

Hope this helps.

Community Member

Re: problem with xmodem

hello

i've tried all what you suggested but without success.

as i said, i think the problem is i don't have full access to the flash (R/W). i can't create a directory (mkdir).

do you suggest any other thing?

thanks for your help

Community Member

Re: problem with xmodem

Hello Oussama

Plz Try to use SecureCrt, I had the same problem last time.

Best regards

Kheireddine

Community Member

Re: problem with xmodem

Help from JOEBLOUGH !

joeblough

Feb 16, 2004, 10:44am PST

Simple solution...

The xmodem command outlined in Document ID: 12036 is ambiguous, or incorrect.

The noted command is:

switch: copy xmodem: Flash:filename

The command that worked on the 2900XL is:

switch: copy xmodem:filename flash:filename

Community Member

Re: problem with xmodem

hello joe

thank you very very very much for your help ;-)

every thing is ok now

160
Views
0
Helpful
5
Replies
CreatePlease to create content