Cisco Support Community
Community Member

Problems upgrading to CatOS 6.3(8)

I recently had some problems upgrading from my Cat6500 CatOS 6.2(3) to CatOS 6.3(8). Just wondering if anyone else has had any problems like I experienced. My success rate is 75% so far.

Scenario 1:

Successfully TFTP’ed 6.3(8) to slot0: of active (mod 1) Sup1A;

“cleared boot system all”;

“set boot system flash slot0:cat6000-sup.6-3-8.bin” [I tried bootflash: also]


After startup, mod 1 sh version states that the OS is updated. The supervisor issues its NMP image synchronizing messages

Now the fun begins – I want to test and see if it works

Reset mod 1

Show version of mod 2 states that the OS is at 6.2(3); the config file gets wiped out as the Sup1A reverts back to previous release. While I was here I manually cleared out bootflash and removed slot0: flash to force it to find bootflash:BTSYNC_cat6000-sup.6-3-8.bin image

Reset the switch; mod 2 doesn’t boot. After some investigation I run across message “system image bootflash BTSYNC_cat6000-sup.6-3-8.bin is corrupt, delete and download again”


I was expecting that the sh config #boot lists would be identical (minus the appended BTSYCN_). They were not. The mod2 Sup1A had retained all its past boot config records. Is this normal?

How do you know if the standby image is bad?

Scenario 2:

System successfully upgraded to CatOS 6-3-8 on both Sup1A. After a couple of days reset mod 1 and found the console port inactive on mod2. Called TAC. RMAed. Insert new card in mod2. According to TAC the card should have resynced with new image. NO it reverted back to old operating system.


I noticed that I was RMA’ed a 6.1 version of SUP1A. In the future do I need to specify a correctly matched operating system on the RMA request? Do I need to flush (delete and squeeze) any previous images that may be on bootflash:? How do I do that in a production environment?


Re: Problems upgrading to CatOS 6.3(8)


in scenario 1: have you tried "set boot sync now " and "show boot 2" and "dir 2/bootflash:" to be sure that boot variables and files were OK before the reset?



Community Member

Re: Problems upgrading to CatOS 6.3(8)

Thanks HTH,

I was able to corrupt the mod2 Sup1a file again. The only indication that one has a bad boot image is to "dir 2/bootflash" and compare the image lengths. Thanks for the "set boot sync now" command I forced a resync using a more lengthy process.



CreatePlease to create content