Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Problems with 1721 and DHCP

I have enable DHCP on my 1721 but it will not seem to work The clients see not DHCP server on the LAN. Any Help? Here is my current config file.

Current configuration : 1967 bytes

!

version 12.4

service nagle

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

!

hostname GreenCo_Bloomington

!

boot-start-marker

boot-end-marker

!

logging buffered 4096

enable secret 5 xxxxxxxxxxxxxxxxxxxx

!

no aaa new-model

clock timezone CST -6

clock summer-time CDT recurring

no ip source-route

no ip gratuitous-arps

ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.2.1 192.168.2.99

!

ip dhcp pool bloomington

  network 192.168.2.128 255.255.255.192

  default-router 192.168.2.1

  dns-server 208.67.222.222 208.67.220.220

  domain-name greenviewnet.local

  lease 0 0 1

!

!

no ip bootp server

ip name-server 205.171.3.65

ip name-server 205.171.2.65

ip name-server 198.6.1.4

multilink bundle-name authenticated

!

!

!       

!

!

archive

log config

  hidekeys

!

!

!

!

!

interface FastEthernet0

ip address 192.168.2.1 255.255.255.0

no ip redirects

no ip proxy-arp

speed auto

!

interface Serial1

ip address 63.232.191.150 255.255.255.252

no ip redirects

no ip proxy-arp

encapsulation ppp

!

interface Async1

no ip address

encapsulation slip

!

interface Group-Async1

physical-layer async

ip unnumbered FastEthernet0

encapsulation ppp

dialer in-band

dialer idle-timeout 600

dialer-group 1

async mode interactive

peer default ip address pool remote-access

ppp authentication chap

!

ip local pool remote-access 10.10.10.1

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 63.232.191.149

!

no ip http server

no ip http secure-server

!

dialer-list 1 protocol ip permit

!       

control-plane

!

!

line con 0

line 1

password 7 xxxxxxxxxxxxxxxxxxxxxxx

login

modem InOut

transport input all

stopbits 1

speed 115200

flowcontrol hardware

line aux 0

line vty 0 4

password 7 xxxxxxxxxxxxxxxxxxxxxxxxxxx

login

line vty 5 15

password 7 xxxxxxxxxxxxxxxxxxxxxxx

login

!

end

Everyone's tags (1)
4 REPLIES
Community Member

Re: Problems with 1721 and DHCP

The network in your DHCP config doesn't match your LAN

ip dhcp pool bloomington

  network 192.168.2.128 255.255.255.192

interface FastEthernet0

ip address 192.168.2.1 255.255.255.0

Try the following instead:

ip dhcp pool bloomington

  network 192.168.2.0 255.255.255.0

Community Member

Re: Problems with 1721 and DHCP

I had already tried that and it makes no difference. In the case show I was just using a starting IP out of the reserved range with a /26 netmask to give a pool of only 64 IPs instead of using the whole class. Any other thoughts?

Community Member

Re: Problems with 1721 and DHCP

In the dhcp config the network should match the LAN subnet

Use the command ip dhcp excluded-address to limit addresses from the scope.

To make sure the DHCP service is running. use: service dhcp command

Hall of Fame Super Gold

Re: Problems with 1721 and DHCP

I agree with a-moseley's post.  Your DHCP scope is incompatible with your LAN.  I don't know what your IOS is so I'd recommend you reload your router and release/renew the IP address of the clients.

873
Views
0
Helpful
4
Replies
CreatePlease to create content