Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Problems with C2948G

Hi, I have the next problem with a network that has a G2948G, a 2948G-L3 (this switch makes the routing between 3 vlan's), a 4912G and a 3550.

The core is the 4912G, the others switches are attached to it in star with fiber 1000SX.

All the links are trunks with the 3 vlan's with 802.1Q.

The problem happens when I do a FTP to a server attached to the 2948G from a PC attached to the 2948G-L3 (both are in VLAN1), the speeed is very low.

If we change the server to VLAN2 for example, the speed is normal. It does work well too when the server and the PC are in the same switch no matter the VLAN when they are.

The problem seems to be in the fiber between the C2948G and C4912G, but the routing does work very well and all go through the same fiber.

I've changed the fibers, the GBIC's ,etc.

Finally I've disconnected the fiber, and with a cross cable I've attached the C2948G and the 3550. What can I do to put the fiber?

Here there are the configurations

2948G-L3

!

version 12.0

no service pad

hostname cpd_2948G_L3

!

sdm size ipx-bvi-network 32

sdm size ip-adjacency 2048

sdm size ipx-node 2048

sdm size ip-prefix 8192

sdm size ipx-network 6144

sdm size ip-mcast 3072

sdm size udp-flooding 256

sdm size l2-switching 1024

sdm autolearn

ip subnet-zero

bridge irb

interface FastEthernet47

no ip address

no ip directed-broadcast

bridge-group 1

!

interface FastEthernet48

no ip address

no ip directed-broadcast

bridge-group 1

!

interface GigabitEthernet49

no ip address

no ip directed-broadcast

!

interface GigabitEthernet49.1

encapsulation dot1Q 1 native

no ip directed-broadcast

bridge-group 1

!

interface GigabitEthernet49.2

encapsulation dot1Q 2

no ip directed-broadcast

bridge-group 2

!

interface GigabitEthernet49.3

encapsulation dot1Q 3

no ip directed-broadcast

bridge-group 3

!

interface GigabitEthernet50

no ip address

no ip directed-broadcast

bridge-group 1

!

interface BVI1

ip address x.x.x.182 255.255.255.0

no ip directed-broadcast

!

interface BVI2

ip address 192.168.151.254 255.255.255.0

no ip directed-broadcast

no ip route-cache cef

!

interface BVI3

ip address 192.168.152.254 255.255.255.0

no ip directed-broadcast

no ip route-cache cef

!

ip classless

ip route 0.0.0.0 0.0.0.0 194.246.60.3

ip http server

!

dialer-list 1 protocol ip permit

dialer-list 1 protocol ipx permit

snmp-server community public RO

snmp-server community private RW

snmp-server enable traps snmp

snmp-server enable traps config

snmp-server enable traps entity

snmp-server enable traps bgp

bridge 1 protocol ieee

bridge 1 route ip

bridge 2 protocol ieee

bridge 2 route ip

bridge 3 protocol ieee

bridge 3 route ip

C2948G

!

#version 5.5(10)

!

!

#system web interface version(s)

set prompt cpd_2948G>

!

#system

#frame distribution method

set port channel all distribution mac both

!

#vtp

set vtp domain benteler

set vtp v2 enable

set vlan 1 name default type ethernet mtu 1500 said 100001 state active

set vlan 2 name red_151 type ethernet mtu 1500 said 100002 state active

set vlan 3 name red_152 type ethernet mtu 1500 said 100003 state active

set vlan 1002 name fddi-default type fddi mtu 1500 said 101002 state active

set vlan 1004 name fddinet-default type fddinet mtu 1500 said 101004 state active bridge 0x0 stp ieee

set vlan 1005 name trbrf-default type trbrf mtu 4472 said 101005 state active bridge 0xf stp ibm

set vlan 1003 name trcrf-default type trcrf mtu 4472 said 101003 state active parent 1005 ring 0xccc mode srb aremaxhop 7 stemaxhop 7 backupcrf off

!

#ip

set interface sc0 1 x.x.x.63/255.255.255.0 192.0.2.255

set interface sl0 down

set interface me1 down

!

!

#set boot command

set boot config-register 0x2

set boot system flash bootflash:cat4000.5-5-10.bin

!

#module 1 : 0-port Switching Supervisor

!

#module 2 : 50-port 10/100/1000 Ethernet

set udld enable 2/1-48

set trunk 2/9 on dot1q 1-1005

end

C4912G

!

#version 4.5(3)

set prompt cpd_4912G>

set length 24 default

set logout 20

#ip

set interface sc0 1 x.x.x.181 255.255.255.0 192.0.2.255

set interface sc0 up

set interface sl0 0.0.0.0 0.0.0.0

set interface sl0 down

set interface me1 0.0.0.0 0.0.0.0 0.0.0.0

set interface me1 down

set arp agingtime 1200

set ip redirect enable

set ip unreachable enable

set ip fragmentation enable

set ip alias default 0.0.0.0

!

!

#vtp

set vtp domain benteler

set vtp mode server

set vtp v2 enable

set vtp pruning disable

set vtp pruneeligible 2-1000

clear vtp pruneeligible 1001-1005

set vlan 1 name default type ethernet mtu 1500 said 100001 state active

set vlan 2 name red_151 type ethernet mtu 1500 said 100002 state active

set vlan 3 name red_152 type ethernet mtu 1500 said 100003 state active

set vlan 1005 name trbrf-default type trbrf mtu 4472 said 101005 state active bridge 0xf stp ibm

set vlan 1003 name trcrf-default type trcrf mtu 4472 said 101003 state active parent 1005 ring 0xccc mode srb aremaxhop 7 stemaxhop 7

!

#spantree

#uplinkfast groups

set spantree uplinkfast disable

#backbonefast

set spantree backbonefast disable

#vlan 1

set spantree enable 1

set spantree fwddelay 15 1

set spantree hello 2 1

set spantree maxage 20 1

set spantree priority 32768 1

#vlan 2

set spantree enable 2

set spantree fwddelay 15 2

set spantree hello 2 2

set spantree maxage 20 2

set spantree priority 32768 2

#vlan 3

set spantree enable 3

set spantree fwddelay 15 3

set spantree hello 2 3

set spantree maxage 20 3

set spantree priority 32768 3

#vlan 1003

set spantree enable 1003

et spantree fwddelay 4 1003

set spantree hello 2 1003

set spantree maxage 10 1003

set spantree priority 32768 1003

#vlan 1005

set spantree enable 1005

set spantree fwddelay 15 1005

set spantree hello 2 1005

set spantree maxage 20 1005

set spantree priority 32768 1005

!

#set boot command

set boot config-register 0x2

set boot system flash bootflash:

!

#permit list

set ip permit disable

!

#protocolfilter

set protocolfilter disable

!

#standby ports

set standbyports disable

!

#module 1 : 0-port Switching Supervisor

set module name 1

!

#module 2 : 12-port 1000BaseX Ethernet

set module name 2

set module enable 2

set vlan 1 2/1-12

set port channel 2/1-4 off

set port channel 2/5-8 off

set port channel 2/9-12 off

set port channel 2/1-2 on

set port channel 2/3-4 auto

set port channel 2/5-8 auto

set port channel 2/9-12 auto

set port enable 2/1-12

set port level 2/1-12 normal

set port duplex 2/1-12 full

set port trap 2/1-12 disable

set port name 2/1-12

set port security 2/1-12 disable

set port membership 2/1-12 static

set port protocol 2/1-12 ip on

set port protocol 2/1-12 ipx auto

set port negotiation 2/1-12 enable

set port flowcontrol send 2/1-12 desired

set port flowcontrol receive 2/1-12 off

set cdp enable 2/1-12

set cdp interval 2/1-12 60

set trunk 2/1 on dot1q 1-1005

set trunk 2/2 on dot1q 1-1005

set trunk 2/3 on dot1q 1-1005

set trunk 2/4 on dot1q 1-1005

set trunk 2/5 on dot1q 1-1005

set trunk 2/6 on dot1q 1-1005

set trunk 2/7 auto dot1q 1-1005

set trunk 2/8 on dot1q 1-1005

set trunk 2/9 on dot1q 1-1005

set trunk 2/10 on dot1q 1-1005

set trunk 2/11 auto dot1q 1-1005

set trunk 2/12 on dot1q 1-1005

set spantree portfast 2/1-12 disable

set spantree portcost 2/1-12 4

set spantree portpri 2/1-12 32

set spantree portvlanpri 2/1 0

set spantree portvlanpri 2/2 0

set spantree portvlanpri 2/3 0

set spantree portvlanpri 2/4 0

set spantree portvlanpri 2/5 0

set spantree portvlanpri 2/6 0

set spantree portvlanpri 2/7 0

set spantree portvlanpri 2/8 0

set spantree portvlanpri 2/9 0

set spantree portvlanpri 2/10 0

set spantree portvlanpri 2/11 0

set spantree portvlanpri 2/12 0

set spantree portvlancost 2/1 cost 18

set spantree portvlancost 2/2 cost 18

set spantree portvlancost 2/3 cost 18

set spantree portvlancost 2/4 cost 18

set spantree portvlancost 2/5 cost 18

set spantree portvlancost 2/6 cost 18

set spantree portvlancost 2/7 cost 18

set spantree portvlancost 2/8 cost 18

set spantree portvlancost 2/9 cost 18

set spantree portvlancost 2/10 cost 18

set spantree portvlancost 2/11 cost 18

set spantree portvlancost 2/12 cost 18

!

#switch port analyzer

!set span 1 1/1 both inpkts disable

set span disable

!

#cam

set cam agingtime 1-3,1003,1005 300

end

C3550

Current configuration : 1568 bytes

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname cpd_3550

!

enable secret xxxxxxxx!

ip subnet-zero

no ip finger

!

!

!

!

interface Port-channel1

switchport trunk encapsulation dot1q

switchport mode trunk

no ip address

snmp trap link-status

!

!

interface GigabitEthernet0/7

no ip address

snmp trap link-status

!

interface GigabitEthernet0/8

no ip address

snmp trap link-status

!

interface GigabitEthernet0/11

switchport trunk encapsulation dot1q

switchport mode trunk

no ip address

snmp trap link-status

channel-group 1 mode on

!

interface GigabitEthernet0/12

switchport trunk encapsulation dot1q

switchport mode dynamic auto

no ip address

snmp trap link-status

channel-group 1 mode on

!

interface Vlan1

ip address x.x.x.232 255.255.255.0

end

Many thanks in advance

1 REPLY
New Member

Re: Problems with C2948G

I need some more information:

1.) Whether this problem happens only when doing FTP?

2.) How about accessing servers in other VALNS?

3.) How is the ping response? Is it continious?

4.) To which port to which port between 2948G-l3 and 4900 is the connection?

102
Views
0
Helpful
1
Replies
CreatePlease to create content