Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

problems with Catalyst 5500 ports after enabling MLS

I have a Catalyst 5500, which has the following modules:

Mod Slot Ports Module-Type Model Status

--- ---- ----- ------------------------- ------------------- --------

1 1 2 1000BaseX Supervisor IIIG WS-X5550 ok

15 1 1 Route Switch Feature Card WS-F5541 ok

3 3 Gigabit Ethernet Ext WS-X5410

4 4 9 Gigabit Ethernet WS-X5410 ok

5 5 24 10/100BaseTX Ethernet WS-X5234 ok

6 6 24 10/100BaseTX Ethernet WS-X5234 ok

7 7 24 10/100BaseTX Ethernet WS-X5234 ok

8 8 24 10/100BaseTX Ethernet WS-X5234 ok

9 9 24 10/100BaseTX Ethernet WS-X5234 ok

10 10 2 MM MIC FDDI WS-X5101 ok

11 11 2 MM MIC FDDI WS-X5101 ok

12 12 24 100BaseFX MM Ethernet WS-X5236 ok

13 13 ASP/SRP

I have configured MLS-SW on Supervisor and MLS-RP on RSFC. At first MLS worked fine, cpu usage on RSFC gone from 85% to 35%. After five days one problem arose, some ports on slots 5, 6, 7, 8 e 9 stoped working. I disabled MLS, I issued clear cam, clear counters and so on. The problem has been solved after rebooting the switch. If I configure MLS to work again, the problem repeats.

Can anybody help me about that?

Thanks in advance.

5 REPLIES
Cisco Employee

Re: problems with Catalyst 5500 ports after enabling MLS

We need more info to assist.

What version of code?

By stopped working do you mean stopped forwarding traffic? ie, successive 'sh mac' indicates no tx or rx traffic.

Was it the same ports on all blades or same group of ports?

Where there cam entries for the ports? sh cam dyn

Are there any messages in the log? sh logg buff.

New Member

Re: problems with Catalyst 5500 ports after enabling MLS

* Switch version:

------------------

WS-C5500 Software, Version McpSW: 5.4(2) NmpSW: 5.4(2)

Copyright (c) 1995-2000 by Cisco Systems

NMP S/W compiled on Apr 7 2000, 16:59:29

MCP S/W compiled on Apr 07 2000, 16:53:52

System Bootstrap Version: 5.1(1)

Hardware Version: 1.4 Model: WS-C5500 Serial #: 069088154

Mod Port Model Serial # Versions

--- ---- ---------- --------- ----------------------------------------

1 2 WS-X5550 014375832 Hw : 1.1

Fw : 5.1(1)

Fw1: 5.2(1)

Sw : 5.4(2)

4 9 WS-X5410 028990903 Hw : 1.3

Fw : 4.2(500)

Fw1: 4.2(500)

Sw : 5.1(1)

5 24 WS-X5234 014907267 Hw : 1.0

Fw : 4.5(2)

Sw : 5.4(2)

6 24 WS-X5234 014907339 Hw : 1.0

Fw : 4.5(2)

Sw : 5.4(2)

7 24 WS-X5234 029348604 Hw : 1.1

Fw : 4.5(2)

Sw : 5.4(2)

8 24 WS-X5234 029348503 Hw : 1.1

Fw : 4.5(2)

Sw : 5.4(2)

9 24 WS-X5234 029347911 Hw : 1.1

Fw : 4.5(2)

Sw : 5.4(2)

10 2 WS-X5101 004769409 Hw : 1.3

Fw : 2.1

Fw1: 3.1(2)

Sw : 3.2(1a)

11 2 WS-X5101 009989904 Hw : 1.4

Fw : 2.1

Fw1: 3.1(2)

Sw : 3.2(1a)

12 24 WS-X5236 014369223 Hw : 1.0

Fw : 4.5(2)

Sw : 5.4(2)

15 1 WS-F5541 024976541 Hw : 1.0

Fw : 12.0(3c)W5(8),

Sw : 12.0(3c)W5(8),

DRAM FLASH NVRAM

Module Total Used Free Total Used Free Total Used Free

------ ------- ------- ------- ------- ------- ------- ----- ----- -----

1 32768K 19540K 13228K 8192K 4187K 4005K 512K 242K 270K

** rsfc version:

------------------

Cisco Internetwork Operating System Software

IOS (tm) RSFC Software (C5RSFC-D-M), Version 12.0(3c)W5(8), RELEASE SOFTWARE

Copyright (c) 1986-1999 by cisco Systems, Inc.

Compiled Mon 10-May-99 19:52 by integ

Image text-base: 0x60009900, data-base: 0x608D0000

ROM: System Bootstrap, Version 12.0(3c)W5(8), RELEASE SOFTWARE

anexo-gw uptime is 1 week, 10 hours, 38 minutes

System restarted by power-on at 06:58:00 GMT-3 Wed Oct 8 2003

System image file is "bootflash:c5rsfc-d-mz.120-3c.W5.8.bin"

cisco Cat5k-RSFC (R5000) processor with 122880K/8192K bytes of memory.

Processor board ID 24976541

R5000 processor, Implementation 35, Revision 2.1 (512KB Level 2 Cache)

Last reset from power-on

Bridging software.

X.25 software, Version 3.0.0.

30 Virtual Ethernet/IEEE 802.3 interface(s)

123K bytes of non-volatile configuration memory.

4096K bytes of packet SRAM memory.

8192K bytes of Flash internal SIMM (Sector size 256K).

Configuration register is 0x2101

- I have not issued the command sh mac;

- The ports were located in different blades;

- There were entries on sh cam dyn ;

- I forgot to say, that I issued the command show logg buffer and it showed nothing about the problem.

Thanks.

New Member

Re: problems with Catalyst 5500 ports after enabling MLS

Hi

I have seen a similar bug occur several times. Under certain conditions when a host moves from one switch port to another switch port (or one access switch to another), recently connected hosts cannot reconnect to moved host (or moved host to these hosts) but new connections are OK. Clearing the MLS entries on the switch or clearing the arp table on the RSM/RSFC clears the problem in the short term ie. until a host moves again. Rebooting the switch is the only way to really clear the problem.

If you problem sounds the same and I will give you more details.

Peter

Purple

Re: problems with Catalyst 5500 ports after enabling MLS

If you things moving around then you will have problems as the arp timeout is like 3 hours where the default on the layer 2 side is 5 minutes , clearing arp forces it to query and get the correct address and port and you can connect again . It's not really a problem , it's working as designed .

New Member

Re: problems with Catalyst 5500 ports after enabling MLS

Think about it...When a host move from one switch to another:

- the ARP table does not have to change

- the cam table updates as soon at they see the moved hosts MAC address come from another port

When you have a problem, do a 'show cam' and 'show mls entry' and see if they are correct. If OK, you have the bug. A clear arp on the router or clear mls entry on switch both result in clearing the mls entries.

Peter

Peter

104
Views
0
Helpful
5
Replies