Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Problems with CRMTFTP

Whenevr I attempt to copy a file from a device to the TFTP server on my CiscoWorks LMS 2.1 server, the file copy fails, and I get an error in the W2K event log;

C:\PROGRA~1\CSCOpx\tftpboot\dogrtr01-confg failed: The system cannot find the file specified.

Where dogrtr01 is the name of the device I am trying to backup the config of to TFTP.

I have checked the following as per the CRM Tech Tip;

The CRMTFTP service is running

There are no other TFTP services running on the server

Both of the registry values for the TFTP executable location, and the Directory location are correct.

I have run the Calca c:\progra~1\cscopx\tftpboot /T /E /G NETWORK:F as documentated to address the NTFS issues.

My problem is still not resolved. This is on a brand new W2K build, with a new LMS installation. This problem also existed on a trial box I built on LMS 2.0. I was hoping that it would resolve itself in LMS ver 2.1, but has not.

What would you suggest I do to address this?

Thanks

6 REPLIES
Blue

Re: Problems with CRMTFTP

Does the file dogrtr01-confg exist on the tftp server with read-write permissions?. Normally the above messages in the event log are due to routers/switches that have the command:

service config

and/or

boot network ... / boot host

in the configuration. If service config, but no boot command is specified, the router broadcasts for the next available tftp server, in this case CRMtftp on the CW2000 NT machine, and requests a configuration file. If the .cfg is not there the CRMtftp error will be logged in the Event Viewer. To avoid these messages remove the service config ( boot) commands from the router configuration.

Community Member

Re: Problems with CRMTFTP

There are no *-config files pre-existing on the tftp server in the tftpboot directory.

I am having this problem when I telnet directly to the router, issue copy start tftp, supply the IP address of the LMS / TFTP server manually, and accept the default config name.

There are no service config or boot network configs on the router.

I can successfully copy a config to an alternative tftp server following the same process.

The error I get on the router is;

TFTP: error code 2 received - Access violation

[Failed]

It almost appears to be a permissions issue. However, as noted earlier, I have followed the Tech Tip regards this.

One question, the TT specified Full Control for the account BIN. Is this a Unix / Solaris reference, and is there an equivilent account in an NT domain that I have to give rights to?

Thanks

Community Member

Re: Problems with CRMTFTP

You must already have a dummy file with the same name located in the TFTPBOOT directory on the CW2000 server.

Just create a blank text file with the name (eg. router-confg) and without the .TXT extension. Now issue the TFTP command from your router/switch with the same name as created above.

I believe it is a permissions control with CiscoWorks2000.

Community Member

Re: Problems with CRMTFTP

Thank you Alctelecom, for your help. This does indeed allow the tftp copy to complete.

However, this does not address my underlying requirement, namely that Configuration Management actions from within LMS maintain configuration generation histories from previous configs for rollback purposes.

My understanding is that when ConfMan implements a change, the devices config is copied to the crmtftp server with a unique name that is a combination of dev name plus a date time stamp.

Given that this name is unique each time, and the desire to maintain multiple past generations of configs, having a pre-existing file does not meet the requirement.

Are you aware of exactly what the permissions issue is? I have enabled auditing on the tftpboot directory for everyone and network, and can see only success audits.

Thanks

Community Member

Re: Problems with CRMTFTP

I am having this exact same problem on my CW2K LMS v2.1 installation. I am running Windows 2000 Server with the required SPs. I have followed the CRM Tech Tip mentioned elsewhere in this conversation. I get the same error messages. The only difference in my environment is that my system is a migration from an older server to a newer server. I did a backup of the old CW2K system, built a new CW2K system and did a restore of the databases as documented for backup/restore functions in the CW2K help files. This certainly looks like a permissions issue. Is it possible that the CASUSER ID and password is not syncronized with something in CW2K? I do need help with this.

Community Member

Re: Problems with CRMTFTP

Do you already have "a blank or dummy" file located in the TFTPBOOT Directory on the CiscoWorks Station with the same name?

CW2K has a "security" feature that in order to have a file copied to it's TFTPBOOT directory, there must already be a file of the same name there.

If your are copying off a TFTP'd config file for your router (e.g. called router-confg), just create a Notepad file of the same name on the CW2K Station and save it to the TFTPBOOT Dir as router-confg and remove the .TXT extension.

Hope this Helps

468
Views
0
Helpful
6
Replies
CreatePlease to create content