Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Problems with supervisor III module -- rommon mode

Hi,

I have a new supervisor III (ws-5530-E1) with version 4.5(4). I have tried to ugrage the IOS to version 6.3.5 but failed halfway as it exceeded the available DRAM.

A sh flash or dir bootflash: (can't remember which one I used) shows the file # and the file name (cat5000-sup3.4-5-4.bin) of the current IOS on the first line and just the name (without file #) of the intended IOS (6.3.5) on the second line (cat5000-sup3.6-3-5.bin).

I did a squeeze to remove the imcomplete 6.3.5 IOS file. After that, I did a sh flash and the current IOS (4.5.4) was still there (incomplete 6.3.5 was gone). I turned off the switch to resume testing the next day. However, when the switch was booted up it went into rommon mode. I did a dir bootflash:, it showed the IOS name cat5000-sup3.4-5-4 (deleted)!!

I am not sure what happened. Does the above (deleted) showed that the file is definetely gone and not recoverable? Can anyone explain why the file is deleted? A squeeze should only remove a deleted/incomplete file and not files that are not deleted. Most importantly, what should I do from here (I do not have any flash card with the module)? Is there any hidden commands that I could use to boot the switch via other means? I couldn't find any information on this site about the problem.

Any help is much appreciated. Thanks.

5 REPLIES
Bronze

Re: Problems with supervisor III module -- rommon mode

If you do not have another SUP III you can use to write the flash card, you can check this matrix to see if you have a compatible Cisco device that will work for you...

http://www.cisco.com/warp/public/63/pcmciamatrix.html

At this point, if all else fails, you should still be able to do an xmodem to load another image on the flash.

http://www.cisco.com/warp/public/473/26.html#cat5k2

Cisco Employee

Re: Problems with supervisor III module -- rommon mode

What you describe is not normal. However, the following page should help in recovering the Supervisor Engine

http://www.cisco.com/warp/public/473/26.html#cat5k

Make sure you read the release notes for memory/DRAM requirements

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat5000/c5krn/sw_rns/78_11304.htm

New Member

Re: Problems with supervisor III module -- rommon mode

Hi,

Thanks very much for the replies. I tried using xmodem to load the image on but failed on loading network management processor image.

Here's the display of error messages.

Loading Network Management Processor image

Uncompressing file: ######################

*** Bus Error (load) Exception ***

Access address = 0x

*** TLB (Store) Exception ***

Access address = 0x6167

PC = 0x80010604, Cause = 0x800c, Status Reg = 0x3041d003

monitor: command "xmodem" aborted due to exception

Do you know what the problem is?

Thanks.

New Member

Re: Problems with supervisor III module -- rommon mode

Hi,

Talked to the TAC. Can't resolve the issue and the TAC RMA another module to replace it.

Thanks.

PF

Purple

Re: Problems with supervisor III module -- rommon mode

Yup always have to check your dram requirements , 4.x I believe needed 16 meg , 5.X needed 32 meg and 6.x code needs 64 meg to run .

126
Views
0
Helpful
5
Replies