Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Problems working with ip helper-address command

I have 2 switches L3 4507 working in HA with HSRP, so in the active switch I have the following interface configuration:

interface Vlan2

ip address 10.1.0.2 255.255.254.0

standby 2 ip 10.1.0.1

standby 2 priority 150

standby 2 preempt

!

interface Vlan4

ip address 10.1.4.2 255.255.255.0

ip helper-address 10.1.0.8

standby 4 ip 10.1.4.1

standby 4 priority 150

standby 4 preempt

!

interface Vlan15

ip address 10.1.5.2 255.255.255.128

ip helper-address 10.1.0.8

standby 15 ip 10.1.5.1

standby 15 priority 150

standby 15 preempt!

And, in my standby switch I have this configuration:

interface Vlan2

ip address 10.1.0.3 255.255.254.0

standby 2 ip 10.1.0.1

!

interface Vlan4

ip address 10.1.4.3 255.255.255.0

ip helper-address 10.1.0.8

standby 4 ip 10.1.4.1

standby 4 priority 50

interface Vlan15

ip address 10.1.5.3 255.255.255.128

ip helper-address 10.1.0.8

standby 15 ip 10.1.5.1

standby 15 priority 50

!

So, the problem is that in some ports belonging to a particular vlan, for example to the vlan 15 most to take an IP address form the network 10.1.5.0 /25, but that port are takenig an ip from the network 10.1.0.0 /23…

I’ll apreciate your help, thank’s

6 REPLIES

Re: Problems working with ip helper-address command

Other than making sure the DHCP Server's scope defined properly. You might have to get a sniffer trace and see why hosts in vlan 15 are being assigned ip address for vlan 2.

New Member

Re: Problems working with ip helper-address command

The issue is that there are users with laptops, so I have segmented my LAN by floors, and the users moves between them, so in floor 1 they get an IP from vlan 2 and in floor 3 take an IP from vlan 15... well that's the idea, but some times when the users (not all users) are in floor 1 and they move to floor 3, automatically they are trying to get the old IP and the DHCP server grants that... so I don't know if the switch must change something in the packet that is forwarding.

New Member

Re: Problems working with ip helper-address command

I guess the issue will be related to the DHCP server alone and its settings since you said your clients get an IP from the DHCP server. That confirms that your ip-helper is working fine and its routing the DHCP broadcasts and then assigns an IP from the DHCP server.

So the only possible reason i can think of should be the settings of the DHCP scope.

Do you have the same problem with all the scopes, i mean whether all the different vlans get incorrect IP or ???, is this issue is related to only one VLAN ??

Also check whether you have any other DHCP servers other than the allowed since its some times possible in your network other DHCP servers unknowingly which you can find by shutting this DHCP :)

New Member

Re: Problems working with ip helper-address command

I have the same problem in all the vlans, but not all the users have the problem, just few fortuitous users.

I have just one DHCP server, The DHCP server manager show me the wrong IP asigned to the user.

All this was working good.

I notice the problem just a few days after finish my 4th floor-vlan with this feature "ip helper-address".

Bronze

Re: Problems working with ip helper-address command

Within the forwarded packet to the DHCP discover or request packet the local host IP subnet is identified. Using this information the DHCP server derives the IP address to issue.

In your earlier post you said your users where using laptops. I will assume the laptops have batteries.

If a laptop were to move between VLANs it would maintain the same IP unless you shutdown the laptop or issue a release and renew from command prompt.

This may explain the sporadicalness of the problem.

HTH,

Ryan

New Member

Re: Problems working with ip helper-address command

That works for normal users, but for that fortuitous users that mentioned doesn't work.

182
Views
0
Helpful
6
Replies