Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

PSTN dial up from Cisco 3660 to Cisco 805 failed

--begin ciscomoderator note-- The following post has been edited to remove potentially confidential information. Please refrain from posting confidential information on the site to reduce security risks to your network. -- end ciscomoderator note --

Hi Network Professional,

Problem Description:

Cisco 3660 router is not able to PSTN dial up Cisco 805 router, but it works the other way round. Error message "3d00h:

Se0 PPP: Line appears to be looped back" was displayed in Cisco 805's debug output when Cisco 3660 dials into Cisco 805.

The following is configuration:

--------------------cisco 805 start-----------------------------

--moderator edit-- Router1#

--moderator edit-- Router1#sh conf

Using 1296 out of 8060 bytes

!

version 12.0

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname --moderator edit-- Router1

!

enable secret 5 --moderator edit--

!

username --moderator edit--password 1 --moderator edit--

ip subnet-zero

!

no ip domain-lookup

chat-script dial "" "AT" OK "ATM0DT\T" TIMEOUT 90 CONNECT \C

!

!

process-max-time 200

!

interface Ethernet0

ip address 10.10.92.1 255.255.255.0

no ip directed-broadcast

!

interface Serial0

physical-layer async

no ip address

no ip directed-broadcast

encapsulation ppp

dialer in-band

dialer pool-member 8

async default routing

async mode dedicated

no fair-queue

ppp authentication chap callin

!

interface Dialer1

ip unnumbered Ethernet0

no ip directed-broadcast

encapsulation ppp

no keepalive

dialer idle-timeout 180

dialer string 768660

dialer pool 8

dialer-group 1

no cdp enable

ppp authentication chap callin

!

no ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1 permanent

!

dialer-list 1 protocol ip permit

!

line con 0

password 7 --moderator edit--

login

transport input none

stopbits 1

line 1

modem InOut

modem autoconfigure discovery

transport input all

stopbits 1

speed 115200

flowcontrol hardware

line vty 0 4

password 7 --moderator edit--

login

!

end

--------------------cisco 805 end-------------------------------

--------------------cisco 3660 start-------------------------------

--moderator edit-- Router2#sh conf

Using 3863 out of 129016 bytes

!

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname --moderator edit-- Router2

!

logging rate-limit console 10 except errors

enable secret 5 --moderator edit--

!

username --moderator edit-- Router1 password 7 --moderator edit--

memory-size iomem 15

ip subnet-zero

!

!

no ip finger

no ip domain-lookup

!

isdn switch-type basic-net3

chat-script async "" "AT" OK "ATDT\T" TIMEOUT 30 CONNECT \C

!

!

!

interface FastEthernet0/0

ip address 10.10.10.1 255.255.192.0

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 10.1.1.2 255.255.255.252

duplex auto

speed auto

!

interface Async97

ip unnumbered FastEthernet0/0

encapsulation ppp

dialer in-band

dialer idle-timeout 180

dialer map ip 10.10.92.1 name --moderator edit-- Router1 modem-script async 772367

dialer-group 1

async mode interactive

ppp authentication chap callin

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.1.1.1 permanent

ip route 10.1.1.0 255.255.255.252 FastEthernet0/1 permanent

ip route 10.10.92.0 255.255.255.0 10.10.92.1

ip route 10.10.92.1 255.255.255.255 Async97

no ip http server

!

dialer-list 1 protocol ip permit

!

line con 0

password 7 --moderator edit--

login

transport input none

line 97 112

autoselect during-login

autoselect ppp

modem InOut

autocommand ppp

stopbits 1

flowcontrol hardware

line aux 0

password 7 --moderator edit--

login

line vty 0 4

timeout login response 10

password 7 --moderator edit--

login

!

end

--------------------cisco 3660 end---------------------------------

Note that in Cisco 3660 router, Async97 is the interface that dial out. Also, Aztech modem is the external modem attached to Cisco 805. Up to this stage, I somehow know that it could be due to the loop in Cisco 805, but has no idea and can't find solution to solve it.

Kindly provide technical advice if you have, I really appreciate it.

Thanks.

4 REPLIES
Cisco Employee

Re: PSTN dial up from Cisco 3660 to Cisco 805 failed

As it complains, Line is looped. You must be seeing the same MAGIC number during PPP LCP negotiation..So there is a loop in analog circuit path. I think try changing the analog line at 805 side or both the place..

New Member

Re: PSTN dial up from Cisco 3660 to Cisco 805 failed

Hi tepatel,

Thanks for your reply first.

Actually I found that even the successful dial up, the magic number is also the same. Anyway, I found that line 1 is used in Cisco 805 and line 97 in Cisco 3660, there are already different, so how should I change it?

Thanks.

Cisco Employee

Re: PSTN dial up from Cisco 3660 to Cisco 805 failed

Same Magic number in LCPfrom805 and 3660 side "should" not be the same.

It should be different from both the side according to RFC.

Now i am not clear about what do you want to change about line 97 and line 1. Pl. explain.

New Member

Re: PSTN dial up from Cisco 3660 to Cisco 805 failed

Hi Tepatel,

I have misunderstood your reply and hence I ask a funny question. In fact so far I have found out the problem is because I do not specify "asyn mode interactive" for serial0 and do not specify "autoselect ppp" for line 1 in Cisco 805 router.

I have simulated in my office and it works fine for me to dial in to Cisco 805 using my notebook. I have requested my customer to test it out and l am waiting his reply.

I will update you once I get the result from him if he still face problem.

Thanks.

93
Views
0
Helpful
4
Replies
CreatePlease login to create content