Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

ian
New Member

Public IP through NAT device

I want to be able to give a server on the network a public routable IP and not a private natted IP. I thought I was on the right track here, but it didn't work. I am obviously missing something.

I have the following config:

interface FastEthernet0

ip address a.b.c.d 255.255.255.252 secondary

ip address 192.168.10.1 255.255.255.0

ip nat inside

speed auto

!

interface Serial0

ip address w.x.y.z 255.255.255.252

ip nat outside

!

ip nat inside source list 2 interface Serial0 overload

ip classless

ip route 0.0.0.0 0.0.0.0 66.178.174.73

no ip http server

!

access-list 2 permit 192.168.10.0 0.0.0.255

a.b.c.d is the public IP to be on the inside network.

w.x.y.z is the global IP address.

I am using 192.168.10.0 as the private network.

6 REPLIES
Hall of Fame Super Bronze

Re: Public IP through NAT device

Can you ping the Fa0 secondary IP from the server ?

What's the server default gateway ?

Can you ping out to the internet when sourcing from Fa0 secondary IP ?

ian
New Member

Re: Public IP through NAT device

no

Hall of Fame Super Bronze

Re: Public IP through NAT device

Ian,

Can you elaborate a bit more ?

ian
New Member

Re: Public IP through NAT device

I perform the ping with the following results.

Router#ping 66.178.167.3 source 66.178.174.78

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 66.178.167.3, timeout is 2 seconds:

Packet sent with a source address of 66.178.174.78

.....

Success rate is 0 percent (0/5)

Router#

ian
New Member

Re: Public IP through NAT device

This should have been a reply to a different message

Gold

Re: Public IP through NAT device

Depends on what address your sample ping implies

You should be able to ping 66.178.174.73 with a source of a.b.c.d If this does not work then your ISP has the routing messed up.

Now if you are tring to ping between a.b.c.d and w.x.y.z you are going to have a number of issues. Partially it is that it is hard to test using the router interfaces because of how nat works. You also have issues running nat when the inside and outside interface are the same interface. This configuration is called nat on a stick but I would not recommend it as other than a last option.

It should be possible to talk between 192.168.10.x and a.b.c.d network if you have your gateways and subnets setup correctly.

385
Views
0
Helpful
6
Replies