Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

Putty pauses until some input

Hello. I'm using Putty 0.63 to access all corporate routers (28xx, 29xx, 39xx, different IOSes) and stumbled into one common problem: if i launch some long running command like ping with many repeats or file operation then it runs for about 50 seconds and then just stops - nothing happening, no input from router, ping stops, file transfer stops etc.

If i hit any key it resumes! Though file operations get timed out if i notice too late.

 

Using other ssh clients do not have such problems. Also if i connect to Linux machine and then ssh from there, there is no such problem too.

 

Any ideas?

7 REPLIES
VIP Purple

Hi, try downloading putty 0

Hi,

 

try downloading putty 0.64 and check .May be there are some caveats in 0.63.

what is the IOS version of boxes for which you are trying to do putty?

regds,

aman

New Member

0.64 - same issueI cant say

0.64 - same issue

I cant say who's bug it is. I wiresharked, no traffic comes from cisco when it stops. tcp stack sends last ACK to packet from router and then... nothing else.

But why there is no such problem when using linux ssh client (openssh) ?

 

3945E IOS 15.3(3)M3 - has problem

3925E IOS 15.1(4)M7 - has problem

 

3750 IOS 12.2(55)SE8 - no problem

1721 IOS 12.4(16) - no problem

2811 IOS 12.4(24)T8 - no problem

 

smells like problem is with modern IOSes. Can someone check their 15.1, 15.3 routers?

VIP Purple

Hi , I could find bug but not

Hi ,

 

I could find bug but not exaclty related to the putty version and IOS u are using.

 

SSH Sessions disconnect when viewing logs w/ big oputput
CSCui94558

Symptom:
SSH session is closed when viewing logs w/ big output.

Conditions:
When customer uses ssh version 2 and putty

Workaround:
Use xshell terminal
 
Known Affected Releases:
(1)

 

15.0(2)SG6

 

regds,

aman

New Member

I've seen it, but it is

I've seen it, but it is different.

In my case session is not closed and output resumes on input from my side.

 

I would blame putty, but, wiresharks indicates what it is IOS stops sending data.

New Member

Worked around by turning off

Worked around by turning off null keep-alives. Socket keep-alives left on.

Take a look at bug CSCui83823

Take a look at bug CSCui83823.

Any show command that gives a long output may close putty prematurely.

 

"Though file operations get timed out if i notice too late "

New Member

Hi, Use Putty 0.64. Install

Hi,

 

Use Putty 0.64. Install it and check.

 

 

Jerry Paul

www.thenetworkhardware.com

121
Views
0
Helpful
7
Replies
CreatePlease to create content