Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

QoS across DS-3

Hi,

We have a private p2p DS-3 between 2 facilities, used for monitoring and management of a remote facility. For 6 hours each day a database is copied across this line that puts it at about 85% utilization for most of that duration, the rest of the time the line sits quite underutilized. This is our first attempt with QoS so we're trying to balance the combination of congestion management and avoidance. We'd like to limit that database copy to no more than 50% of the available bandwidth, once that is reached we'd like to queue or selectively drop the traffic, but not completely black hole it all that's over the 50% mark. One end of the line is a 7206VXR and the other is a 3725. Below is our config, can anyone dell us how far off we are:?

access-list 2000 remark pkx_dbs

access-list 2000 permit ip 10.28.136.0 0.0.0.255 any

access-list 2001 remark pkx-dbs

access-list 2001 permit ip any 10.28.136.0 0.0.0.255

class-map match-any pkx_db

description test

match access-group 2000

match access-group 2001

policy-map test2

class pkx_db

bandwidth percent 50

random-detect

interface GigabitEthernet0/1

ip nbar protocol-discovery

service-policy history

service-policy output test2

5 REPLIES
Silver

Re: QoS across DS-3

Your config looks good the only thing you may want to consdier is you are using defaults for Random detect , random detect with randomly drop based on IP Precedence , so if all your traffic has the same Ip Precendence the random detect config will more agrresively drop ,

You may want to set the TOS bit in your class map to something higher If you want the traffic in your ACL to be dropped less agressively .

policy-map test2

class pkx_db

set ip precedence X

bandwidth percent 50

random-detect

New Member

Re: QoS across DS-3

thanks for you the info. so if we were take it that step farther and do this:

policy-map test2

class pkx_db

set ip precedence 4

bandwidth percent 50

random-detect

by setting those to 4 they will be dropped before anything else?

As I see it we are going to be reserving 50% of the bandwidth for this data flow, which is not exactly what we want, but the other traffic flow will be able to use it when it isn't maxed. However, we do want to make sure that this flow cannot ever go over the 50% mark. Have we accomplished this goal?

thanks

Silver

Re: QoS across DS-3

No they will be dropped less aggressively the TOS bit goes 0 is most aggressivley dropped 5 is least aggresively dropped .

You are correct with your second assumption

Refer to the Qos design link on the right side of this page it is an excellent document .

New Member

Re: QoS across DS-3

thanks again for the info. gone through some of the TAC docs, maybe this one will help compliment that from the design side. did have one last quick question. Although somewhat obvious, I wanted to verify it, even though we're specifying our policy against a class of specific ACL matches, any other traffic will be passed on the class-default class which allows all traffic, right?

thanks

Silver

Re: QoS across DS-3

Yes that is correct .

82
Views
0
Helpful
5
Replies
CreatePlease to create content